WSUS.DE
Windows Server Update Services >> Troubleshooting >> Installer 3.1 wird installiert - dann ist schluss
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1179825295

Beitrag begonnen von e-head am 22.05.07 um 11:14:53

Titel: Installer 3.1 wird installiert - dann ist schluss
Beitrag von e-head am 22.05.07 um 11:14:53
Hallo zusammen,

ich hoffe mir kann jemand weiterhelfen. Auf einigen Windows 2000 und Windows 2003 Servern wird zwar der Windows Installer 3.1 per WSUS installiert, danach passiert allerdings gar nichts mehr. In der Übersicht steht "907 Updates wurden installiert oder sind nicht zutreffend". Installiert ist nichts.

Hat jemand das selbe Phänomen und evtl. eine Lösung dazu?

Danke schonmal...

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von skyopi69 am 22.05.07 um 11:25:52
bei den win2000 mal probieren ob es nach der installation von "Updaterollup1fürWindows2000SP4.EXE" auch noch so ist.

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von Sunny am 22.05.07 um 11:30:01

e-head schrieb am 22.05.07 um 11:14:53:

ich hoffe mir kann jemand weiterhelfen. Auf einigen Windows 2000 und Windows 2003 Servern wird zwar der Windows Installer 3.1 per WSUS installiert, danach passiert allerdings gar nichts mehr. In der Übersicht steht "907 Updates wurden installiert oder sind nicht zutreffend". Installiert ist nichts.


Welchen Patchlevel haben die Server? Das hört sich für mich nach W2K ohne SP4 an. Beim W2K3 sollte man jetzt schon das SP2 installiert haben, dann kommt AFAIK kein Installer 3.1 mehr.

Die erforderlichen Updates sind alle gedownloadetet und auf dem WSUS verfügbar? Wie lange hast Du gewartet, zwischen der Installation vom Installer 3.1 und dem Posting hier? Was sagt eine bereinigte WindowsUpdate.log vom Client? Reboot ist nach der Installation vom Installer 3.1 gemacht? Du kannst das auch forcieren mit: wuauclt /detectnow auf der Commandline, mit netstat kontrollieren ob der Server eine HTTP-Verbindung zum WSUS aufgebaut hat.

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von e-head am 22.05.07 um 11:36:38
Hallo und danke für die schnellen Antworten,

der W2K ist auf SP4, bei dem 2003er ist´s ne komplette Neuinstallation ohne alles per OSD. SP1 wurde bis Dato per WSUS 2.0 installiert, ging auch immer gut, erst seit der Umstellung auf 3.0 gibt´s da Probleme. SP2 ist bei uns hier im Unternehmen noch nicht frei gegeben, von daher keine Chance es zu installieren.

Das Updatelog auf dem Server spricht:

+++++++++++  PT: Synchronizing server updates  +++++++++++
2007-05-22      11:18:11:558       956      15fc      PT        + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL =   (Du musst Dich Einloggen oder Registrieren
2007-05-22      11:18:11:636       956      15fc      PT      Initializing simple targeting cookie, clientId = 395f1c53-44f6-4ba4-b211-1d7162fe9a17, target group = , DNS name = m9905s50.spk.svb.ad.sko.de
2007-05-22      11:18:11:636       956      15fc      PT        Server URL =   (Du musst Dich Einloggen oder Registrieren
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: GetCookie failure, error = 0x8024400D, soap client error = 7, soap error code = 300, HTTP status code = 200
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: SOAP Fault: 0x00012c
2007-05-22      11:18:11:683       956      15fc      PT      WARNING:     faultstring:Fault occurred
2007-05-22      11:18:11:683       956      15fc      PT      WARNING:     ErrorCode:ServerChanged(4)
2007-05-22      11:18:11:683       956      15fc      PT      WARNING:     Message:Server rolled back since last call to GetCookie
2007-05-22      11:18:11:683       956      15fc      PT      WARNING:     Method:"   (Du musst Dich Einloggen oder Registrieren"
2007-05-22      11:18:11:683       956      15fc      PT      WARNING:     ID:f9740cad-165e-4e4b-a427-c52f579ff340
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: PTError: 0x80244015
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: GetCookie_WithRecovery failed : 0x80244015
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: RefreshCookie failed: 0x80244015
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: RefreshPTState failed: 0x80244015
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: Sync of Updates: 0x80244015
2007-05-22      11:18:11:761       956      15fc      PT      WARNING: Cached cookie has expired or new PID is available
2007-05-22      11:18:11:761       956      15fc      PT      Initializing simple targeting cookie, clientId = 395f1c53-44f6-4ba4-b211-1d7162fe9a17, target group = , DNS name = m9905s50.spk.svb.ad.sko.de
2007-05-22      11:18:11:761       956      15fc      PT        Server URL =   (Du musst Dich Einloggen oder Registrieren
2007-05-22      11:18:11:964       956      15fc      Agent        * WARNING: Failed to synchronize, error = 0x80244015
2007-05-22      11:18:11:964       956      15fc      DnldMgr      File locations for service 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7 changed
2007-05-22      11:18:11:964       956      15fc      Agent      Server changed and need resyncing with server

Ich kann damit leider nicht allzu viel anfangen. Seltsamerweise scheinen wir das Problem aber auf mehreren Maschinen zu haben....

Danke für Euere Hilfe...

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von WSUS.DE-Admin am 22.05.07 um 11:51:18
Sieht so aus, als würde der AU-Client hängen.
Hatte gerade auch auf einem neuen Windows Server 2003 dieses Problem!

Versuchs mal hiermit:
[code]@Echo off

Echo Dienste beenden
Echo

start /wait net stop SharedAccess

start /wait net stop winmgmt



Echo Verzeichnis loeschen
Echo

rd %systemroot%\system32\wbem\repository /S /Q


Echo Dienste starten
Echo

start /wait net start SharedAccess

start /wait net start winmgmt


Echo AU-Client beim WSUS-Server registrieren
Echo

wuauclt.exe /detectnow[/code]

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von Sunny am 22.05.07 um 11:55:58

e-head schrieb am 22.05.07 um 11:36:38:

der W2K ist auf SP4, bei dem 2003er ist´s ne komplette Neuinstallation ohne alles per OSD. SP1 wurde bis Dato per WSUS 2.0 installiert, ging auch immer gut, erst seit der Umstellung auf 3.0 gibt´s da Probleme.


IMHO ist es auch keine gute Entscheidung ein SP für einen Server vom WSUS verteilen/installieren zu lassen. Das mache ich am liebsten manuell und kontrolliert.

2007-05-22      11:18:11:683       956      15fc      PT      WARNING: GetCookie failure, error = 0x8024400D, soap client error = 7, soap error code = 300, HTTP status code = 200
2007-05-22      11:18:11:683       956      15fc      PT      WARNING:     Method:"   (Du musst Dich Einloggen oder Registrieren"
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: GetCookie_WithRecovery failed : 0x80244015
2007-05-22      11:18:11:761       956      15fc      PT      WARNING: Cached cookie has expired or new PID is available
Ich kann damit leider nicht allzu viel anfangen. Seltsamerweise scheinen wir das Problem aber auf mehreren Maschinen zu haben....
[/quote]

  (Du musst Dich Einloggen oder Registrieren

Habt ihr den IE7 auf dem W2K3 Server installiert? Oder irgendwelche Policys verändert?
Laß dir mal einen Gruppenrichtlinienergebnissatz in der GPMC für die betreffenden Server anzeigen. Habt ihr einen ISA im Einsatz?

Den hier kannst Du auch probieren:   (Du musst Dich Einloggen oder Registrieren

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von e-head am 22.05.07 um 13:28:52

Sunny schrieb am 22.05.07 um 11:55:58:

e-head schrieb am 22.05.07 um 11:36:38:

der W2K ist auf SP4, bei dem 2003er ist´s ne komplette Neuinstallation ohne alles per OSD. SP1 wurde bis Dato per WSUS 2.0 installiert, ging auch immer gut, erst seit der Umstellung auf 3.0 gibt´s da Probleme.


IMHO ist es auch keine gute Entscheidung ein SP für einen Server vom WSUS verteilen/installieren zu lassen. Das mache ich am liebsten manuell und kontrolliert.

2007-05-22      11:18:11:683       956      15fc      PT      WARNING: GetCookie failure, error = 0x8024400D, soap client error = 7, soap error code = 300, HTTP status code = 200
2007-05-22      11:18:11:683       956      15fc      PT      WARNING:     Method:"   (Du musst Dich Einloggen oder Registrieren"
2007-05-22      11:18:11:683       956      15fc      PT      WARNING: GetCookie_WithRecovery failed : 0x80244015
2007-05-22      11:18:11:761       956      15fc      PT      WARNING: Cached cookie has expired or new PID is available
Ich kann damit leider nicht allzu viel anfangen. Seltsamerweise scheinen wir das Problem aber auf mehreren Maschinen zu haben....


  (Du musst Dich Einloggen oder Registrieren

Habt ihr den IE7 auf dem W2K3 Server installiert? Oder irgendwelche Policys verändert?
Laß dir mal einen Gruppenrichtlinienergebnissatz in der GPMC für die betreffenden Server anzeigen. Habt ihr einen ISA im Einsatz?

Den hier kannst Du auch probieren:   (Du musst Dich Einloggen oder Registrieren


IE 7 ist nicht installiert, und ISA haben wir ebenfalls nicht im Einsatz. Der Server hat standart Policys, ist so installiert wie rund 100 andere bei uns auch. Das Problem ist auch nicht, daß er mit dem WSUS Server einwandfrei kommuniziert, sondern scheinbar glaubt es gäbe keine Updates für ihn. Er hat aber gar keine Updates installiert. Ich habe ihn jetzt auch schon auf einen anderen WSUS-Server umgehängt, selbes Spiel. Auch die Neuinstallation des Servers, also des Clients, von gestern auf heute hat nichts gebracht.  :-/

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von Sunny am 22.05.07 um 14:29:27
Hast Du das hier probiert?   (Du musst Dich Einloggen oder Registrieren

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von e-head am 23.05.07 um 15:15:30
Ich hab den Fehler gefunden - und schuld war NUR ICH. Wenn man die richtigen Sprachen mitanhakeln würde, die man braucht, dann würds auch bei allen Servern klappen  :-[
Wer kommt denn auch darauf, ich hab das wohl in geistiger Umnachtung rausgenommen.

Aber ich wollte mich für die Hilfsbereitschaft bedanken, Sunny. Ich war echt am Verzweifeln, danke!

Der Threat kann dann zu  :)

Grüße

e-head

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von Sunny am 23.05.07 um 15:21:58

e-head schrieb am 23.05.07 um 15:15:30:
Ich hab den Fehler gefunden - und schuld war NUR ICH. Wenn man die richtigen Sprachen mitanhakeln würde, die man braucht, dann würds auch bei allen Servern klappen  :-[
Wer kommt denn auch darauf, ich hab das wohl in geistiger Umnachtung rausgenommen.


Hä? Du hast Sprachen deaktiviert? Welche waren denn noch aktiviert?


e-head schrieb am 23.05.07 um 15:15:30:

Aber ich wollte mich für die Hilfsbereitschaft bedanken, Sunny. Ich war echt am Verzweifeln, danke!


Bitte, gern geschehen und Danke für die Rückmeldung. ;)

Titel: Re: Installer 3.1 wird installiert - dann ist schl
Beitrag von e-head am 30.05.07 um 09:45:23
Deutsch war aktiviert, bei "Englisch" habe ich wohl offensichtlich den Haken rausgenommen (kann mich zwar nicht wirklich dran erinnern, aber ok).
Das erklärt warum meine Clients gingen und auch meine Printserver (die sind auf Deutsch installiert). Nur der Rest ging halt nicht mehr  :-/

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.