WSUS.DE
Windows Server Update Services >> Troubleshooting >> Update von Wsus 2 auf 3 - Probleme
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1180226482

Beitrag begonnen von webactivity am 27.05.07 um 02:41:21

Titel: Update von Wsus 2 auf 3 - Probleme
Beitrag von webactivity am 27.05.07 um 02:41:21
Hallo zusammen!

So wie es aussieht habe ich ein Problem.. bisher setzte ich wsus 2 ein auf MS Server 2003 standard ger. Darin eingebunden 40 x clients XP SP2 von der Verkaufsabteilung. Alles bene, keine Probleme.

Habe nun upgedatet auf v.3. Die Prozedur stiess ich an über Windows Update per web. Zuerst .Net 2, danach wsus3... alles in allem lief das so ca 60min. Vor dem Start des setups von wsus 3 wurde wsus 2 von mir nicht angefasst, lief ja alles.

Tja.. und was nun? So wie es aussieht ist die Datenbank autom. migriert worden. Aber wenn ich nun in die Admin-Konsole gehe von WSUS3 sehe ich NIX wo ich was tun könnte!

Nur verbinden mit server ist da zu sehen..  klar, der ist localhost denk ich..
aber nix geht, auf keinem der Ports. Ich sehe nix.
Sollte es nicht so sein dass alle settings von der alten wsus 2 installation übernommen wurden? Denn die hat einwandfrei funktioniert..
Ein blick in die Logfiles zeigt folgendes das nach dem Reboot der Maschine und dem start des wsus-dienstes angezeigt wurde:

Event-id: 12052
Der DSS-Authentifizierungswebdienst funktioniert nicht.

Event-id: 12042
Der SimpleAuth-Webdienst funktioniert nicht.

Event-id: 12022
Der Clientwebdienst funktioniert nicht.

Event-id: 12032
Der Serversynchronisierungs-Webdienst funktioniert nicht.

Event-id: 12012
Der API-Remoting-Webdienst funktioniert nicht.

Event-id: 12002
Der Berichterstattungswebdienst funktioniert nicht.

Event-id: 10032
Der Server kann einige Updates nicht herunterladen.

Event-id: 13042
Selbstupdate funktioniert nicht.

Was mach ich jetzt? Was übersehen ? Weiss jemand Rat?

Viele Gruesse + vielen Dank schon mal

Tom

Titel: Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Beitrag von Sunny am 28.05.07 um 14:53:20

webactivity schrieb am 27.05.07 um 02:41:21:

Habe nun upgedatet auf v.3. Die Prozedur stiess ich an über Windows Update per web. Zuerst .Net 2, danach wsus3... alles in allem lief das so ca 60min. Vor dem Start des setups von wsus 3 wurde wsus 2 von mir nicht angefasst, lief ja alles.


Schlechte Strategie. Solche Updates macht man nicht über Windows Update. Alle benötigten Files downloaden, und wenn möglich den Server vorher einmal sauber neu starten.


webactivity schrieb am 27.05.07 um 02:41:21:

Tja.. und was nun? So wie es aussieht ist die Datenbank autom. migriert worden. Aber wenn ich nun in die Admin-Konsole gehe von WSUS3 sehe ich NIX wo ich was tun könnte!

Nur verbinden mit server ist da zu sehen..  klar, der ist localhost denk ich..
aber nix geht, auf keinem der Ports. Ich sehe nix.
Sollte es nicht so sein dass alle settings von der alten wsus 2 installation übernommen wurden? Denn die hat einwandfrei funktioniert..


Du benutzt aber schon die MMC, die vom WSUS 3 mit installiert wurde?


webactivity schrieb am 27.05.07 um 02:41:21:

Event-id: 12052
Der DSS-Authentifizierungswebdienst funktioniert nicht.
Event-id: 12042
Der SimpleAuth-Webdienst funktioniert nicht.
Event-id: 12022
Der Clientwebdienst funktioniert nicht.
Event-id: 12032
Der Serversynchronisierungs-Webdienst funktioniert nicht.
Event-id: 12012
Der API-Remoting-Webdienst funktioniert nicht.
Event-id: 12002
Der Berichterstattungswebdienst funktioniert nicht.
Event-id: 10032
Der Server kann einige Updates nicht herunterladen.
Event-id: 13042
Selbstupdate funktioniert nicht.


Ist das ein SBS? Hast Du das WhitePaper zur Installation auf dem SBS gelesen?

Wenn Du den SMTP-Dienst nicht benötigst kannst Du ihn deaktivieren.

Hast Du den Windows Scripting Host installiert? Wenn nein, hol es nach:   (Du musst Dich Einloggen oder Registrieren

Hast Du auch den ReportViewer 2005 incl. SP1 installiert? Vermutlich nicht:   (Du musst Dich Einloggen oder Registrieren

Titel: Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Beitrag von webactivity am 29.05.07 um 19:33:00
Hallo,

vielen Dank zuerst mal. Heute habe ich WSUS3 wieder deinstalliert und danach neu Installiert, Ohne Erfolg, er läuft immer noch nicht.

Zu deinen Fragen.

Es ist kein sbs. Das System ist auf W2K3 SP2, MMC v.3 ist drauf,
ReportViewer 2005, .Net 2, IIS-6...

Die WSUS 3 De-Installation verlief reibungslos. Die ursprünglich beim Update migrierten WSUS 2 DB Datensätze sind nun natürlich weg.

Die anschliessende Neuinstallation velief ebenso reibungslos.
Die Probleme beginnen wenn der WSUS Setup-Wizard anstartet.
Dies resultiert in angehängter Fehlermeldung.
Der direkte Aufruf des Wizards unter:

LW:\Programme\Update Services\administrationsnapin\
microsoft.updateservices.ui.oobewizard.exe

mit dem selben Ergebnis. Im Snapin kann ich nach wie vor nur auf
"Verbindung mit dem Server herstellen! was aber Fehler erzeugt dass
auf den Server nicht zugegriffen werden kann.

Woran könnts liegen?




001.gif (Anhang gelöscht)

Titel: Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Beitrag von webactivity am 29.05.07 um 19:37:34
Hier noch zwei Shots:
003.gif (Anhang gelöscht)

Titel: Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Beitrag von webactivity am 29.05.07 um 19:38:58
Hab alles durchprobiert.. Weiss jemand Rat?

Gruesse

Tom
004.gif (Anhang gelöscht)

Titel: Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Beitrag von Sunny am 29.05.07 um 21:31:41

webactivity schrieb am 29.05.07 um 19:33:00:

vielen Dank zuerst mal. Heute habe ich WSUS3 wieder deinstalliert und danach neu Installiert, Ohne Erfolg, er läuft immer noch nicht.


Warum deinstalliert eigentlich jeder den WSUS wieder, wenn es Probleme gibt?


webactivity schrieb am 29.05.07 um 19:33:00:

Es ist kein sbs. Das System ist auf W2K3 SP2, MMC v.3 ist drauf,
ReportViewer 2005, .Net 2, IIS-6...


Was läuft denn sonst noch so alles auf dem Server? Könntest Du den IIS auch mal komplett deinstallieren und den Server rebooten? Oder als Alternative einen virtuellen Server nur für den WSUS installieren?



webactivity schrieb am 29.05.07 um 19:33:00:

Die WSUS 3 De-Installation verlief reibungslos. Die ursprünglich beim Update migrierten WSUS 2 DB Datensätze sind nun natürlich weg.


Das Contentverzeichnis hast Du aber behalten, oder?


webactivity schrieb am 29.05.07 um 19:33:00:

Die anschliessende Neuinstallation velief ebenso reibungslos.
Die Probleme beginnen wenn der WSUS Setup-Wizard anstartet.
Dies resultiert in angehängter Fehlermeldung.


Der WSUS erzeugt beim installieren ein Logfile im Tempverzeichnis. Bevor Du die Installation abbrichst, sichere mal das Logfile und poste es hier.

Welche Einträge hast Du im EventLog auf dem Server?

Titel: Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Beitrag von webactivity am 31.05.07 um 08:12:14

Zitat:
Was läuft denn sonst noch so alles auf dem Server?


File, Print und DHCP Services



Zitat:
Könntest Du den IIS auch mal komplett deinstallieren und den Server rebooten


Deinstallieren nein, rebooten ja.. schon passiert, Effekt 0


Zitat:
Oder als Alternative einen virtuellen Server nur für den WSUS installieren?


Nein, derzeit keine Testmaschine verfügbar.


Zitat:
Das Contentverzeichnis hast Du aber behalten, oder?


Nein, ich wollte einnen Schnitt machen und alles neu ziehen.



Zitat:

Der WSUS erzeugt beim installieren ein Logfile im Tempverzeichnis. Bevor Du die Installation abbrichst, sichere mal das Logfile und poste es hier.


Wie heisst das Log?


Zitat:
Welche Einträge hast Du im EventLog auf dem Server?


Siehe mein erster Beitrag..

Event-id: 12052
Der DSS-Authentifizierungswebdienst funktioniert nicht.

Event-id: 12042
Der SimpleAuth-Webdienst funktioniert nicht.

Event-id: 12022
Der Clientwebdienst funktioniert nicht.

Event-id: 12032
Der Serversynchronisierungs-Webdienst funktioniert nicht.

Event-id: 12012
Der API-Remoting-Webdienst funktioniert nicht.

Event-id: 12002
Der Berichterstattungswebdienst funktioniert nicht.

Event-id: 10032
Der Server kann einige Updates nicht herunterladen.

Event-id: 13042
Selbstupdate funktioniert nicht.


Also langsam nervt dieses WSUS...

Gruesse

Tom

Titel: Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Beitrag von Sunny am 31.05.07 um 10:14:59

webactivity schrieb am 31.05.07 um 08:12:14:

File, Print und DHCP Services


Sonst nichts?


webactivity schrieb am 31.05.07 um 08:12:14:

Deinstallieren nein, rebooten ja.. schon passiert, Effekt 0


Warum den IIS nicht deinstallieren? Was läuft noch im IIS?


webactivity schrieb am 31.05.07 um 08:12:14:

Nein, derzeit keine Testmaschine verfügbar.


Für einen virtuellen Server brauchts keine Testmaschine. Virtual Server 2005 ist kostenlos von MS und eine W2K3 Server-CD hast Du bestimmt auch noch. W2K3 Server in der virtuellen Maschine installieren, den WSUS installieren und testen.



webactivity schrieb am 31.05.07 um 08:12:14:

Wie heisst das Log?


Liegt im Temp-Verzeichnis: *.log. Genaueres hab ich jetzt nicht zur Hand. Schau dort rein, bevor Du den Assi beendest.


webactivity schrieb am 31.05.07 um 08:12:14:

Also langsam nervt dieses WSUS...


Auf Deinem Server ist irgendwas nicht in Ordnung, das hat mit dem WSUS nix zu tun. Ist auf dem Server eine Virenscanner Managment Konsole installiert? Wenn ja, läuft die im IIS? Ist das Laufwerk komprimiert?

Titel: Re: Update von Wsus 2 auf 3 - Probleme
Beitrag von Galban am 14.06.07 um 10:36:24
Hallo,

prinzipiell ein ResolverProblem - Der Name wird als IPv6 aufgelöst! Und
somit wird die Verbindung zum IIS via IPv6 hergestellt mit dem offensichtlich der IIS mit dem WSUS Aufsatz nicht umgehen kann!

Für mich war die Lösung den IPv6 Stack komplett zu entfernen!
(Stack aus der Netzwerkverbindungen->Eigenschaften LAN-Verbindung -> IPv6 .. entfernen. )
Danach waren die Fehlermeldungen komplett verschwunden und der Zugriff war wieder unproblematisch möglich.

Nicht untersucht habe ich:
- Es reicht vielleicht auch den IPv6 Eintrag aus der /windows/system32/drivers/etc/hosts zu löschen oder die Reihenfolge zu ändern
- Eventuell den Nameserver anpassen
- ein IPv4-IPv6 Gateway

Wer also mit den letzten Punkten rumprobiert hat ich würde mich über Kommentare dazu freuen!

Gruß
Galban

Titel: Re: Update von Wsus 2 auf 3 - Probleme
Beitrag von Doquentin am 14.06.07 um 15:55:02
Hi,

du hast die Datenbank mitgenommen, den Content aber gelöscht?
Ob das so gut ist..

Kam WSUS 3 mit dem Umstand klar? Was zeigt er nun für Updates an?

Titel: Re: Update von Wsus 2 auf 3 - Probleme
Beitrag von AdminTrainee am 10.07.07 um 18:53:35
Ich habe auf einem Kundenserver exakt das gleiche Problem.
Mittlerweile bin ich auch bei einer frischen WSUS 3.0 Installation angekommen, konsole und alles geht, nur kann sich kein client connecten.
Im Eventlog habe ich die gleichen Einträge.
IP6 ist nicht installiert.

Titel: Re: Update von Wsus 2 auf 3 - Probleme
Beitrag von Sunny am 10.07.07 um 23:21:41
Fehlermeldungen in der WindowsUpdate.log auf den Clients? Die Datei liegt im Windows Verzeichnis.

Titel: Re: Update von Wsus 2 auf 3 - Probleme
Beitrag von immelmann am 13.07.07 um 13:09:19
die 12xxx Ereignisse rühren daher, dass der Dienst "Update Services" nicht gestartet ist.

Beim Installieren von WSUS 3 kann ausgewählt werden, ob Standardport oder ein anderer, in diesem Fall 8530.
Diesen kennen aber die Clients nicht und sollten per Gruppenrichtlinie (ihr habt ja alle einen Server) bekannt gemacht werden.
Gruppenrichtlinie-Computerkonfig.-Administrative Vorlagen-Windows Komponenten-Windows Update  und dort den "internen Pfad..." bearbeiten, z.B. http://EuerServer:8530
Dann sollten die Clients den WSUS finden.

Gruß Torsten

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.