WSUS.DE
Windows Server Update Services >> Installation und Konfiguration >> Update auf WSUS 3.0 funzt nicht
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1184226635

Beitrag begonnen von ke_mi am 12.07.07 um 09:50:34

Titel: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 09:50:34
Hallo Leute, ich versuche seit ein paar Tagen verzweifelt meinen WSUS 2 auf 3.0 zu Updaten. Aber anscheinend gibts Probleme mit der Datenbank. Nach aufruf des Setups kommt das obere Fenster, sieht das normalerweise bei einem Update so aus??
Wenn ich weiter gehe dann kommt die untere Fehlermeldung, und das wars dann.
Habe auch schon probiert den WSUS 2 erst zu deintsllieren (Ohne Datenbank und so zu löschen) und dann den WSUS 3.0 zu istallieren.
Das hat auch geklappt, aber die alten Protokolldateien, Gruppen und einstelluneg sind alle Weg.
Kann mir da jemand weiterhelfen??
Mein BS ist W2K3 SP1
Und der WSUS hat die Version 2.0.0.2340

Viele Grüße KE_MI

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 10:00:31
Verdammt, bin sogar noch zu blöd um ein einfachen Bild Hinzuzufügen  :-/

Also dann halt hier ein Link zu der Grafik:



[url]http://home.arcor.de/zauberer/JAGS/fehler.jpg
[/url]

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 10:17:40
Kann es sein, daß dort noch ein alter SUS 1.0 läuft? Wenn ja, den deinstallieren vorher. Systemsteuerung > Software.

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 11:00:17
Ne der 1.0 er ist schon ne weile runter.
Läuft nur ein WSUS 2er drauf.
Aber schon mla danke für den Tipp

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 11:06:17
Sicher daß in der Systemsteuerung > Software nichts mehr drin ist?

Ist die DB und/oder SQL-Server Version vom WSUS 2.0 oder hast Du dort einen eigenen SQL-Server am laufen? Ist das vielleicht die MSDE ohne SP? Auch könntest Du vorher auf den WSUS 2.0 SP1 aktualisieren und danach nochmal probieren auf den 3er zu aktualisieren.


Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 11:15:43

Ja, da bin ganz sicher, in der Softwareumgebung gibts nur einen Eintrag und das ist der  2er WSUS.

Die DB ist die "einfache" WSUS DB kein SQL Server.

Das mit dem WSUS SP1 hatte ich auch schon probiert. Da führt mich der Wizard aber auch direkt in die Deinstallationsroutine und will nicht upgraden


Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 11:19:01
Dann lade mal die Logs dazu hoch. %temp%\*wsus*.log. Irgendwas passt wohl noch nicht. Ist ein Virenscanner installiert? Sind Ordner/Laufwerke komprimiert?

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 11:29:07
AAAASO als erstes mal danke für den schnellen Hilfeversuch !!!
Note 1+
Und hier ein Auszug aus dem ewünschten LOG:


  • 2007-07-12 09:39:07  Success   MWUSSetup          Validating pre-requisites...
    2007-07-12 09:39:07  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed. Assuming it is not... (Error 0x80070002: Das System kann die angegebene Datei nicht finden.)
    2007-07-12 09:39:40  Success   MWUSSetup          SQL version is not Yukon. Yukon version 9.00.2047. SQL instance version 8.00.881

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 11:43:36
Das ist aber nicht das komplette Log. Das wäre schon hilfreich.
Probier das hier mal:
Somit folgenden Key auf "0" setzen:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Service\Server\Setup\
WmsdeInstalled

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 13:02:13
Auch der RegKey hat leider nichts gebracht.
Hab den Schlüssel geändert und nach und vor reboot(nur zur sicherheit) erneut versucht den 3er zu installieren. Gleiches Bisl.
Auch das Update auf WSUS 2.0 SP1 bleibt gleich.

Das komplette Log nach dem Reboot sieht so aus:

  • 2007-07-12 12:58:29  Success   MWUSSetup          Validating pre-requisites...
    2007-07-12 12:58:30  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed. Assuming it is not... (Error 0x80070002: Das System kann die angegebene Datei nicht finden.)
    2007-07-12 12:58:43  Success   MWUSSetup          SQL version is not Yukon. Yukon version 9.00.2047. SQL instance version 8.00.881
    2007-07-12 12:58:49  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup is cancelled or an error occurred (Error 0x80070642: Die Installation wurde vom Benutzer abgebrochen.)
    2007-07-12 12:58:50  Success   MWUSSetup          User cancelled the setup
    2007-07-12 12:58:50  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070642: Die Installation wurde vom Benutzer abgebrochen.)


is leider nicht mehr :-(

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 13:18:51
Nene, das ist nicht das komplette Log. Sieh VOR dem klicken auf Abbrechen nochmal im Temp-Ordner nach. Da muß es mehr geben.

Ist das ein Member Server in einer Domain? Wenn ja, kannst Du manuell Benutzer anlegen? Ist der aktuelle Windows Scripting Host installiert? Ist MDAC 2.8 SP1 installiert?
How to Repair MDAC:
  (Du musst Dich Einloggen oder Registrieren

Was ist mit den Fragen nach dem Virenscanner und der Komprimierung? Wie lauten die zeitgleichen Fehlermeldungen im Ereignisprotokoll? EventID + Source sind wichtig.

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 13:52:32
Also das Log zeigt leider nicht mehr, auch nicht vor Abbruch !!!
Das einzige was vorher noch passiert ist das im Temp eine 0kb grosse xml Datei angelegt wird die dann wiede rgelöscht wird.


Sorry,nun zu dern Fragen:

Kein Virenskanner

Keine Koprimierung an

Rechner ist in ner Domäne

Lokale Benuzer anlegen geht (k.a. warum du das fragst!)
Oder meinste Domänennutzer ????

MDAC gibts doch nicht für W2K3, oder ??

WSH ist in Version 5.6.0.8827 installiert

Das Event Log hilft auch nicht wirklich weiter:
WSUSLOG:


    2007-07-12 12:58:29  Success   MWUSSetup          Validating pre-requisites...
    2007-07-12 12:58:30  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed. Assuming it is not... (Error 0x80070002: Das System kann die angegebene Datei nicht finden.)
    2007-07-12 12:58:43  Success   MWUSSetup          SQL version is not Yukon. Yukon version 9.00.2047. SQL instance version 8.00.881
    2007-07-12 12:58:49  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup is cancelled or an error occurred (Error 0x80070642: Die Installation wurde vom Benutzer abgebrochen.)
    2007-07-12 12:58:50  Success   MWUSSetup          User cancelled the setup
    2007-07-12 12:58:50  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070642: Die Installation wurde vom Benutzer abgebrochen.)
    2007-07-12 13:20:35  Success   MWUSSetup          Validating pre-requisites...
    2007-07-12 13:20:35  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed. Assuming it is not... (Error 0x80070002: Das System kann die angegebene Datei nicht finden.)
    2007-07-12 13:20:52  Success   MWUSSetup          SQL version is not Yukon. Yukon version 9.00.2047. SQL instance version 8.00.881
    2007-07-12 13:22:15  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup is cancelled or an error occurred (Error 0x80070642: Die Installation wurde vom Benutzer abgebrochen.)
    2007-07-12 13:22:15  Success   MWUSSetup          User cancelled the setup
    2007-07-12 13:22:18  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070642: Die Installation wurde vom Benutzer abgebrochen.)



AppLog:


    12.07.2007      12:59:05      SpntLog      Warnung      System Info.      211      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "The compressed file ""C:\44ac04712cc4e415d8d9a20462\WMSDE\SqlRun.cab"" contains a file ""sqlredis.exe.F26FFD4A_05B4_4969_A552_30C7F9BAB1F4"" that is larger than 2MB. The file was skipped by Real-Time scan."
    12.07.2007      12:57:56      LoadPerf      Informationen      Keine      1000      Nicht zutreffend      SUS-SRV-01      Die Leistungsindikatoren für den Dienst WmiApRpl (WmiApRpl) wurden geladen. Die Daten enthalten die dem Dienst zugeordneten neuen Indexwerte.
    12.07.2007      12:57:56      LoadPerf      Informationen      Keine      1001      Nicht zutreffend      SUS-SRV-01      Die Leistungsindikatoren für den Dienst WmiApRpl (WmiApRpl) wurden entfernt. Die Daten enthalten die neuen Werte der Registrierungseinträge Last Counter und Last Help.
    12.07.2007      12:54:54      Windows Server Update Services      Informationen      Synchronization      361      Nicht zutreffend      SUS-SRV-01      Inhaltsynchronisierung wurde gestartet.
    12.07.2007      12:54:48      Windows Server Update Services      Informationen      WUS Service      501      Nicht zutreffend      SUS-SRV-01      Windows Update Server Service wurde gestartet
    12.07.2007      12:54:42      ESENT      Informationen      Allgemein      100      Nicht zutreffend      SUS-SRV-01      lserver (592) Das Datenbankmodul 5.02.3790.2555 ist gestartet.
    12.07.2007      12:54:41      EventSystem      Informationen      Keine      4625      Nicht zutreffend      SUS-SRV-01      Das EventSystem-Subsystem unterdrückt duplizierte Ereignisprotokolleinträge für eine Dauer von 86400 Sekunden. Dieses Zeitlimit kann durch den REG_DWORD-Wert SuppressDuplicateDuration unter folgendem Registrierungsschlüssel gesteuert werden: HKLM\Software\Microsoft\EventSystem\EventLog.
    12.07.2007      12:54:41      BigBrotherClient      Informationen      Keine      256      Nicht zutreffend      SUS-SRV-01      Started Big Brother SNM Client 1.08d
    12.07.2007      12:54:41      MSDTC      Informationen      TM      4193      Nicht zutreffend      SUS-SRV-01      MS DTC wurde mit den folgenden Einstellungen gestartet (AUS = 0 und EIN = 1):

     Sicherheitskonfiguration:
         Netzwerkverwaltung von Transaktionen = 1,
         Netzwerkclients = 0,
         Eingehende verteilte Transaktionen mit Hilfe des systemeigenen MSDTC-Protokolls = 1,
         Ausgehende verteilte Transaktionen mit Hilfe des systemeigenen MSDTC-Protokolls = 1,
         Transaction Internet Protocol (TIP) = 0,
         XA-Transaktionen = 1
     Filterung duplizierter Ereignisse = 1
    12.07.2007      12:54:32      SpntLog      Informationen      Scan Summary      10      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      Real-time scan start success.
    12.07.2007      12:50:27      SpntLog      Warnung      System Info.      211      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "The compressed file ""C:\35f6a6c4159e180ef3ccfd286167\WMSDE\SqlRun.cab"" contains a file ""sqlredis.exe.F26FFD4A_05B4_4969_A552_30C7F9BAB1F4"" that is larger than 2MB. The file was skipped by Real-Time scan."
    12.07.2007      11:10:39      SpntLog      Warnung      System Info.      211      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "The compressed file ""C:\5a12165d70119c606cab2f\WMSDE\SqlRun.cab"" contains a file ""sqlredis.exe.F26FFD4A_05B4_4969_A552_30C7F9BAB1F4"" that is larger than 2MB. The file was skipped by Real-Time scan."





Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 13:53:35
und hier noch das Syslog weils nicht reingepasst hat :




    12.07.2007      13:25:42      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""Anwendungsverwaltung"" befindet sich jetzt im Status ""Ausgeführt""."
    12.07.2007      13:25:42      Service Control Manager      Informationen      Keine      7035      SUS-SRV-01\Administrator      SUS-SRV-01      "Der Steuerbefehl ""starten"" wurde erfolgreich an den Dienst ""Anwendungsverwaltung"" gesendet."
    12.07.2007      13:08:40      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""Windows Installer"" befindet sich jetzt im Status ""Beendet""."
    12.07.2007      12:59:09      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""Windows Installer"" befindet sich jetzt im Status ""Ausgeführt""."
    12.07.2007      12:59:09      Service Control Manager      Informationen      Keine      7035      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Steuerbefehl ""starten"" wurde erfolgreich an den Dienst ""Windows Installer"" gesendet."
    12.07.2007      12:58:12      TermServDevices      Fehler      Keine      1111      Nicht zutreffend      SUS-SRV-01      Der für den Drucker !!ibs-server!IBS-02 OKI C5450n PCL6 erforderliche Treiber OKI C5450n(PCL6) ist unbekannt. Wenden Sie sich an den Administrator, um den Treiber zu installieren, bevor Sie sich erneut anmelden.
    12.07.2007      12:58:12      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""RAS-Verbindungsverwaltung"" befindet sich jetzt im Status ""Ausgeführt""."
    12.07.2007      12:58:12      Print      Informationen      Keine      2      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Drucker ""IBS-01 HP LaserJet 2200 Series PCL 6 auf ibs-server (von DT-MKO) in Sitzung 1"" wurde erstellt."
    12.07.2007      12:58:12      Print      Informationen      Keine      9      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Drucker ""IBS-01 HP LaserJet 2200 Series PCL 6 auf ibs-server (von DT-MKO) in Sitzung 1"" wurde eingerichtet."
    12.07.2007      12:58:11      Service Control Manager      Informationen      Keine      7035      SUS-SRV-01\Administrator      SUS-SRV-01      "Der Steuerbefehl ""starten"" wurde erfolgreich an den Dienst ""RAS-Verbindungsverwaltung"" gesendet."
    12.07.2007      12:58:11      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""Telefonie"" befindet sich jetzt im Status ""Ausgeführt""."
    12.07.2007      12:58:11      TermServDevices      Fehler      Keine      1111      Nicht zutreffend      SUS-SRV-01      Der für den Drucker !!ibs-server!IBS-03 HP Officejet Pro K850 erforderliche Treiber HP Officejet Pro K850 Series ist unbekannt. Wenden Sie sich an den Administrator, um den Treiber zu installieren, bevor Sie sich erneut anmelden.
    12.07.2007      12:58:11      TermServDevices      Fehler      Keine      1111      Nicht zutreffend      SUS-SRV-01      Der für den Drucker SnagIt 7 erforderliche Treiber SnagIt 7 Printer ist unbekannt. Wenden Sie sich an den Administrator, um den Treiber zu installieren, bevor Sie sich erneut anmelden.
    12.07.2007      12:58:10      TermServDevices      Fehler      Keine      1111      Nicht zutreffend      SUS-SRV-01      Der für den Drucker Microsoft Office Document Image Writer erforderliche Treiber Microsoft Office Document Image Writer Driver ist unbekannt. Wenden Sie sich an den Administrator, um den Treiber zu installieren, bevor Sie sich erneut anmelden.
    12.07.2007      12:58:10      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""Netzwerkverbindungen"" befindet sich jetzt im Status ""Ausgeführt""."
    12.07.2007      12:58:10      Service Control Manager      Informationen      Keine      7035      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Steuerbefehl ""starten"" wurde erfolgreich an den Dienst ""Netzwerkverbindungen"" gesendet."
    12.07.2007      12:58:10      TermServDevices      Fehler      Keine      1111      Nicht zutreffend      SUS-SRV-01      Der für den Drucker Acrobat PDFWriter erforderliche Treiber Acrobat PDFWriter ist unbekannt. Wenden Sie sich an den Administrator, um den Treiber zu installieren, bevor Sie sich erneut anmelden.
    12.07.2007      12:58:09      TermServDevices      Fehler      Keine      1111      Nicht zutreffend      SUS-SRV-01      Der für den Drucker Acrobat Distiller erforderliche Treiber AdobePS Acrobat Distiller ist unbekannt. Wenden Sie sich an den Administrator, um den Treiber zu installieren, bevor Sie sich erneut anmelden.
    12.07.2007      12:58:09      Print      Informationen      Keine      42      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      Die Veröffentlichung des Druckers HP LaserJet 6P Lokal (von DT-MKO) in Sitzung 1 wurde zurückgezogen.
    12.07.2007      12:58:09      Print      Informationen      Keine      9      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Drucker ""HP LaserJet 6P Lokal (von DT-MKO) in Sitzung 1"" wurde eingerichtet."
    12.07.2007      12:58:09      Print      Informationen      Keine      9      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Drucker ""HP LaserJet 6P Lokal (von DT-MKO) in Sitzung 1"" wurde eingerichtet."
    12.07.2007      12:58:09      Print      Informationen      Keine      9      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Drucker ""HP LaserJet 6P Lokal (von DT-MKO) in Sitzung 1"" wurde eingerichtet."
    12.07.2007      12:58:09      Print      Informationen      Keine      2      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Drucker ""HP LaserJet 6P Lokal (von DT-MKO) in Sitzung 1"" wurde erstellt."
    12.07.2007      12:58:09      Print      Informationen      Keine      9      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Drucker ""HP LaserJet 6P Lokal (von DT-MKO) in Sitzung 1"" wurde eingerichtet."
    12.07.2007      12:57:58      TermServLicensing      Warnung      Keine      21      Nicht zutreffend      SUS-SRV-01      "Der Terminalserver-Lizenzserver SUS-SRV-01 verfügt über keine permanenten Lizenzen für das Produkt ""Windows Server 2003 -Terminalserver-CAL-Token (pro Gerät)"". Aufgrund dieses Problems wurden dem Terminalserver ""SUS-SRV-01"" Lizenzen des Typs"" Windows Server 2003 -Terminalserver-CAL-Token (pro Gerät)"" verweigert."
    12.07.2007      12:55:43      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""Intelligenter Hintergrundübertragungsdienst"" befindet sich jetzt im Status ""Ausgeführt""."
    12.07.2007      12:55:43      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""Terminaldienste"" befindet sich jetzt im Status ""Ausgeführt""."
    12.07.2007      12:55:43      Service Control Manager      Informationen      Keine      7035      NT-AUTORITÄT\SYSTEM      SUS-SRV-01      "Der Steuerbefehl ""starten"" wurde erfolgreich an den Dienst ""Intelligenter Hintergrundübertragungsdienst"" gesendet."
    12.07.2007      12:55:43      Service Control Manager      Informationen      Keine      7036      Nicht zutreffend      SUS-SRV-01      "Dienst ""NLA (Network Location Awareness)"" befindet sich jetzt im Status ""Ausgeführt""."



Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 14:02:00
Auf einem Terminal Server kannst Du den WSUS nicht installieren. Und wenn ich das LOG richtig interpretiere, dann ist das ein Terminalserver. Beim W2K mußte man vorher in den Installationsmodus umschalten, beim W2K3 weiß ich nicht wie das geht.

Beim W2K3 kannst Du via MSTSC.exe auch direkt auf die Konsole vom Server gehen:
Pfad_zur_MSTXC.EXE /v:SERVER /console

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 14:55:47
Das ist kein Terminalserver, Keine Ahnung warum das zusätzlich installiert war.
Habe den Terminalserver und die Terminalserverlizensierung deinstalliert.
Nun gibts hier natürlich auch keine Fehlermeldung im Event Log.
Das Update weigert sich aber auch weiterhin beharrlich die Datenbank zu erkennen!!


Das war es also nicht!

(Weiterhin geht der Zugriff über Remotdesk aber auch noch !)

Gruß Mike

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 15:41:21
OK, das ist ja schonmal was. ;)

2007-07-12 12:58:30  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed. Assuming it is not... (Error 0x80070002: Das System kann die angegebene Datei nicht finden.)

Schau mal ob Dir dieser Thread, bzw. die Lösung auch weiterhelfen könnte:   (Du musst Dich Einloggen oder Registrieren

Virtuelle Maschine aufsetzen, WSUS installieren und den Rest wie beschrieben machen.

Ich weiß leider nicht genau, welche Datei das System sucht und nicht findet, Du kannst, wenn Du magst, den ProcessMonitor von MS mitlaufen lassen, evtl. findest raus, welche Datei gesucht wird.

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 15:43:20
Was hast Du in diesem Schlüssel alles für Werte drin stehen?
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 12.07.07 um 15:50:31
Das aus dem anderen Thread probier ich morgen aus.
Nun gehts ert mal nahc HAuse!

Hier die Reg Einträge:



    Schlüsselname: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup
    Klassenname: <KEINE KLASSE>
    Letzter Schreibzugriff: 12.07.2007 - 14:45
    Wert 0
     Name: WmsdeInstalled
     Typ: REG_DWORD
     Daten: 0x1

    Wert 1
     Name: PsfsipInstalled
     Typ: REG_DWORD
     Daten: 0x1

    Wert 2
     Name: TargetDir
     Typ: REG_SZ
     Daten: C:\Programme\Update Services

    Wert 3
     Name: ContentDir
     Typ: REG_SZ
     Daten: C:\WSUS

    Wert 4
     Name: CreatedContentDir
     Typ: REG_DWORD
     Daten: 0

    Wert 5
     Name: SqlServerName
     Typ: REG_EXPAND_SZ
     Daten: %computername%\WSUS

    Wert 6
     Name: SqlAuthenticationMode
     Typ: REG_SZ
     Daten: WindowsAuthentication

    Wert 7
     Name: SqlDatabaseName
     Typ: REG_SZ
     Daten: SUSDB

    Wert 8
     Name: SqlUserName
     Typ: REG_SZ
     Daten:

    Wert 9
     Name: SqlEncryptedPassword
     Typ: REG_SZ
     Daten:

    Wert 10
     Name: InstallType
     Typ: REG_DWORD
     Daten: 0x80

    Wert 11
     Name: <KEIN NAME>
     Typ: REG_SZ
     Daten:

    Wert 12
     Name: WsusAdministratorsSid
     Typ: REG_SZ
     Daten: S-1-5-21-4149393115-1223646169-3788265829-1013

    Wert 13
     Name: IISTargetWebSiteIndex
     Typ: REG_DWORD
     Daten: 0x1

    Wert 14
     Name: IISTargetWebSiteCreated
     Typ: REG_SZ
     Daten: False

    Wert 15
     Name: IISUninstallConfigFilePath
     Typ: REG_SZ
     Daten: c:\Programme\Update Services\setup\UninstallSettings.xml

    Wert 16
     Name: IISPreviousInstallRevision
     Typ: REG_SZ
     Daten:

    Wert 17
     Name: IISInstallRevision
     Typ: REG_SZ
     Daten: 5.5.2340

    Wert 18
     Name: IIsDynamicCompression
     Typ: REG_DWORD
     Daten: 0

    Wert 19
     Name: EncryptionKey
     Typ: REG_BINARY
     Daten:
    00000000   01 00 00 00 d0 8c 9d df - 01 15 d1 11 8c 7a 00 c0  ....Ð..ß..Ñ..z.À
    00000010   4f c2 97 eb 01 00 00 00 - 7a 96 33 2d 97 be 48 48  OÂ.ë....z.3-.¾HH
    00000020   a7 19 70 3b 81 ec a4 cd - 04 00 00 00 02 00 00 00  §.p;.ì¤Í........
    00000030   00 00 03 66 00 00 a8 00 - 00 00 10 00 00 00 2b 9b  ...f..¨.......+.
    00000040   19 81 34 ac 3f 76 76 eb - fc 78 db 6e 4e 16 00 00  ..4¬?vvëüxÛnN...
    00000050   00 00 04 80 00 00 a0 00 - 00 00 10 00 00 00 f2 0b  ...... .......ò.
    00000060   a5 7a e8 82 53 58 e2 5e - 65 2a 6b d1 31 ac 20 00  ¥zè.SXâ^e*kÑ1¬ .
    00000070   00 00 78 91 72 0c e4 bd - aa 13 df 0a bd bf 66 6f  ..x.r.佪.ß.½¿fo
    00000080   03 40 d4 10 07 a8 f0 cc - 08 e6 61 dc c6 0d 7d 93  .@Ô..¨ðÌ.æaÜÆ.}.
    00000090   2c f9 14 00 00 00 5c 8b - 0c b8 03 20 2b 0a 80 f2  ,ù....\..¸. +..ò
    8d 04 54 7c b0 4f 42 7c - a1 66                    ..T|°OB|¡f





Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 12.07.07 um 16:58:16
Ist die Datei: Daten: c:\Programme\Update Services\setup\UninstallSettings.xml dort auch zu finden?

Du kannst das ja mal in eine REG kopieren und mit Deinen Angabe ergänzen, evtl. hilfts ja was:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup]
"WmsdeInstalled"=dword:00000001
"PsfsipInstalled"=dword:00000001
"TargetDir"="c:\\Programme\\Update Services\\"
"ContentDir"="C:\\WSUS"
"CreatedContentDir"=dword:00000000
"SqlServerName"=hex(2):25,00,63,00,6f,00,6d,00,70,00,75,00,74,00,65,00,72,00,\
 6e,00,61,00,6d,00,65,00,25,00,5c,00,4d,00,49,00,43,00,52,00,4f,00,53,00,4f,\
 00,46,00,54,00,23,00,23,00,53,00,53,00,45,00,45,00,00,00
"SqlAuthenticationMode"="WindowsAuthentication"
"SqlDatabaseName"="SUSDB"
"SqlUserName"=""
"SqlEncryptedPassword"=""
"InstallType"=dword:00000001
"EncryptionKey"=hex:01,00,00,00,d0,8c,9d,df,01,15,d1,11,8c,7a,00,c0,4f,c2,97,\
 eb,01,00,00,00,3d,7b,d5,95,83,bb,f7,4d,b1,1e,94,25,27,f6,70,a4,04,00,00,00,\
 02,00,00,00,00,00,03,66,00,00,a8,00,00,00,10,00,00,00,97,dc,b9,46,90,67,ad,\
 29,69,6b,b8,62,19,57,1b,39,00,00,00,00,04,80,00,00,a0,00,00,00,10,00,00,00,\
 3b,f0,3f,1e,16,f7,a4,36,0d,22,98,25,ea,e4,23,85,20,00,00,00,ec,10,da,a8,4e,\
 31,f7,7e,ad,44,1a,f2,e2,9f,ab,2e,c8,a7,5a,1c,4f,b5,39,1b,76,50,91,c4,09,3b,\
 ef,2e,14,00,00,00,c9,db,f5,d0,31,42,eb,cb,50,63,38,c3,74,f5,25,d1,37,49,45,\
 20
@=""
"Version"=dword:00000003
"VersionString"="3.0.6000.374"
"ConfigurationSource"=dword:00000000
"ServicePackLevel"=dword:00000000
"EnableRemoting"=dword:00000001
"WsusAdministratorsSid"=""
"WSUSReportersSid"=""
"SqlInstanceIsRemote"=dword:00000000
"wYukonInstalled"=dword:00000001
"IISInstallRevision"="3.0.6000.374"
"IISPreviousInstallRevision"=""
"IISUninstallConfigFilePath"="c:\\Programme\\Update Services\\setup\\UninstallSettings.xml"
"IISTargetWebSiteCreated"="False"
"IISTargetWebSiteIndex"=dword:00000001
"SmtpUserPassword"=""
"ProxyPassword"=""
"PortNumber"=dword:00000050
"IIsDynamicCompression"=dword:00000000


Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 13.07.07 um 10:10:25
Hi Sunni,
ja die XML Datei ist dort:
<?xml version="1.0" ?>
- <IISSetup>
- <IISComputer>
- <Settings>
 <maxbandwidth>-1</maxbandwidth>
 </Settings>
 <Config />
 </IISComputer>
- <IISWebService>
- <Settings>
 <aspbufferingon>True</aspbufferingon>
 </Settings>
- <Config>
 <enableasp.net>1</enableasp.net>
 </Config>
 </IISWebService>
- <IISWebServer>
- <Settings>
 <aspbufferingon>True</aspbufferingon>
 </Settings>
 <Config />
 </IISWebServer>
 </IISSetup>

und das steh drinn.

Deinen REg Key habe ich auch asuprobiert.
Und
SqlServerName und CreatedContentDir von mir eingetragen.
Gleicher Erfolg ---> vehlgeschhlagen.
Ich tippe mittlerweile immer mehr auf dei MSDE Datenbank.
Weil das Update ja immer dort abbricht:

Haste dazu vielleicht ne Idee??
Habe schon versucht mich über osql -E mit der Datenbank zu verbinden, aber das geht auch nicht!!!

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 13.07.07 um 11:03:21
OK, da wird wohl nur noch die Brechstange helfen. Deinstalliere wenn es geht via Systemsteuerung > Software die evtl. noch vorhandenen Reste vom WSUS 2.0. Und wenn vorhanden, auch die MSDE. Schlägt das mit der MSDE fehl, mußt Du selbst Hand anlegen:
How to manually remove SQL Server 2000 default, named, or virtual instance
  (Du musst Dich Einloggen oder Registrieren

Kontrolliere bitte anschließend ob wirklich alles weg ist. Wenn ja, dann deinstalliere auch den IIS komplett und lösch auch evtl. die dafür extra angelegten User.

Neustart. .Net Framework 2.0 und die MMC 3.0 sowie den ReportViewer hast Du schon installiert? Wenn ja, dann fang jetzt wieder von vorne an. IIS installieren > Neustart > WSUS installieren. Ich drück dir die Daumen. ;)

Alternativ könntest Du auch eine Reparatur Installation vom Server machen, keine Gewähr. Was läuft eigentlich alles auf der Maschine? Nur WSUS?

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von ke_mi am 13.07.07 um 11:47:25
Schade das auch du nun kapitulieren musst :-) HAb ich aber auch schon befürchtet.
JA deinstallieren und neu installation klappt. Das hatte ich gestern schon mal gemacht. Dann sint allerdings die ganzen Einstellungen und Daten weg.
Is aber nicht ganz so schlimm. Die Gruppen und so ziehe ich dann wieder nach.

Auf der Mühle läuft auch nur der WSUS.

Aber noch mal 1000Dank für den Versuch  ;D

Gruß Mike

Titel: Re: Update auf WSUS 3.0 funzt nicht
Beitrag von Sunny am 13.07.07 um 12:13:45

ke_mi schrieb am 13.07.07 um 11:47:25:

JA deinstallieren und neu installation klappt. Das hatte ich gestern schon mal gemacht. Dann sint allerdings die ganzen Einstellungen und Daten weg.
Is aber nicht ganz so schlimm. Die Gruppen und so ziehe ich dann wieder nach.


Wenn es nicht viele Clients + Gruppen sind, sollte das in ein oder zwei Tagen wieder wie gewohnt aussehen und laufen. Hast Du gleich den 3er installiert?



eisenmann schrieb am 13.07.07 um 11:33:17:
Aber noch mal 1000Dank für den Versuch  ;D


Bitte, gern geschehen. ;)

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.