WSUS.DE
Windows Server Update Services >> Installation und Konfiguration >> Installation WSUS 3 auf W2003 SP1
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1184250763

Beitrag begonnen von markus_herbert am 12.07.07 um 16:32:42

Titel: Installation WSUS 3 auf W2003 SP1
Beitrag von markus_herbert am 12.07.07 um 16:32:42
Nachdem ich massive Probleme nach der Installation von WSUS 3 bekommen habe, versuche ich die Probleme in einer virtuellen Umgebung (VMWare) nachzustellen.

W2003 SP1 und WSUS 3 Neuinstallation funktioniert, wobei der W2003 Server ein Member Server ist.

W2003 SP1 und WSUS 3 Neuinstallation: es können sich keine Clients in WSUS registrieren, wobei der W2003 ein Active Directory Domain Controller ist. Aus der MS Knowledgebase  habe ich mittels 332097 (DCPROMO behält Berechtigungen für einige IIS-Ordner nicht bei) die Berechtigungen gesetzt, was aber auch nicht geholfen hat.

Fehlermeldung der Clients:
WARNING: Cached cookie has expired or new PID is available
Initializing simple targeting cookie, clientId = 4eba7a25-c222-4ef2-9a7e-6284eb90955e, target group = http://wsus3, DNS name = wsus3.test1.local
 Server URL =   (Du musst Dich Einloggen oder Registrieren
WARNING: GetAuthorizationCookie failure, error = 0x8024400E, soap client error = 7, soap error code = 400, HTTP status code = 200
WARNING: SOAP Fault: 0x000190
WARNING:     faultstring:System.Web.Services.Protocols.SoapException: Fault occurred
  bei Microsoft.UpdateServices.Internal.SoapUtilities.ThrowException(ErrorCode errorCode, String message)
  bei Microsoft.UpdateServices.Internal.SimpleAuthImplementation.GetAuthorizationCookie(String clientId, String[] targetGroupNames, IPrincipal client, String dnsName, String ipAddress)
  bei Microsoft.UpdateServices.Internal.SimpleAuth.GetAuthorizationCookie(String clientId, String targetGroupName, String dnsName)
WARNING:     ErrorCode:InternalServerError(5)
WARNING:     Message:(null)
WARNING:     Method:"   (Du musst Dich Einloggen oder Registrieren"
WARNING:     ID:90c1a1b4-ff1e-4069-a48d-2f5e25b01b0c
WARNING: Failed to initialize Simple Targeting Cookie: 0x8024400e
WARNING: PopulateAuthCookies failed: 0x8024400e
WARNING: RefreshCookie failed: 0x8024400e
WARNING: RefreshPTState failed: 0x8024400e
WARNING: PTError: 0x8024400e
WARNING: Reporter failed to upload events with hr = 8024400e.

Ein direkter Aufruf von   (Du musst Dich Einloggen oder Registrieren über den Internet Explorer liefert ein vernünftiges Ergebnis.

Kann jemand helfen?

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von Sunny am 12.07.07 um 17:05:47

markus_herbert schrieb am 12.07.07 um 16:32:42:

Nachdem ich massive Probleme nach der Installation von WSUS 3 bekommen habe, versuche ich die Probleme in einer virtuellen Umgebung (VMWare) nachzustellen.


Lobenswert. ;)


markus_herbert schrieb am 12.07.07 um 16:32:42:

W2003 SP1 und WSUS 3 Neuinstallation funktioniert, wobei der W2003 Server ein Member Server ist.

W2003 SP1 und WSUS 3 Neuinstallation: es können sich keine Clients in WSUS registrieren, wobei der W2003 ein Active Directory Domain Controller ist. Aus der MS Knowledgebase  habe ich mittels 332097 (DCPROMO behält Berechtigungen für einige IIS-Ordner nicht bei) die Berechtigungen gesetzt, was aber auch nicht geholfen hat.


Du hast das so gemacht wie hier beschrieben?
  (Du musst Dich Einloggen oder Registrieren


markus_herbert schrieb am 12.07.07 um 16:32:42:

Fehlermeldung der Clients:
WARNING: Cached cookie has expired or new PID is available
Initializing simple targeting cookie, clientId = 4eba7a25-c222-4ef2-9a7e-6284eb90955e, target group = http://wsus3, DNS name = wsus3.test1.local


Lass das Script laufen:   (Du musst Dich Einloggen oder Registrieren
Und ändere unbedingt den Gruppennamen ab! Target Group sollte kein HTTP enthalten. Mit Target Group ist die von Dir angelegte Gruppe auf dem WSUS gemeint, Du mußt hier nicht den Servernamen nochmals angeben.

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von markus_herbert am 13.07.07 um 14:38:18
> Du hast das so gemacht wie hier beschrieben?
>   (Du musst Dich Einloggen oder Registrieren

Nein, da ich WSUS3 auf einem frisch installierten W2003 Server SP1 teste. Hier meine Installationsreihenfolge:

1.) W2003 SP1 ohne IIS frisch installiert.
2.) DCPROMO
3.) IIS nachinstalliert
4.) MMC 3.0 installiert (wg. SP1)
5.) .NET 2.0 installiert
6.) Report Viewer installiert
7.) WSUS3setupx86.EXE ausgeführt

> Lass das Script laufen:
>   (Du musst Dich Einloggen oder Registrieren
> Und ändere unbedingt den Gruppennamen ab! Target Group sollte kein HTTP enthalten.
> Mit Target Group ist die von Dir angelegte Gruppe auf dem WSUS gemeint, Du mußt hier nicht den Servernamen nochmals angeben.

Scipt habe ich ausgeführt, brachte aber keine Verbesserung. Habe die Gruppe Server angelegt, was aber auch nichts gebracht hat

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von Sunny am 13.07.07 um 14:52:41

markus_herbert schrieb am 13.07.07 um 14:38:18:

Nein, da ich WSUS3 auf einem frisch installierten W2003 Server SP1 teste. Hier meine Installationsreihenfolge:

1.) W2003 SP1 ohne IIS frisch installiert.
2.) DCPROMO
3.) IIS nachinstalliert
4.) MMC 3.0 installiert (wg. SP1)
5.) .NET 2.0 installiert
6.) Report Viewer installiert
7.) WSUS3setupx86.EXE ausgeführt


OK, bei einem frisch installierten Server ist die Reihenfolge in Ordnung.


markus_herbert schrieb am 13.07.07 um 14:38:18:

Scipt habe ich ausgeführt, brachte aber keine Verbesserung. Habe die Gruppe Server angelegt, was aber auch nichts gebracht hat


Das Script hast Du auf dem Client laufen lassen, der sich nicht zum WSUS verbindet? Anschließend den Client neu gestartet? Bzw. mind. ein gpupdate /force auf dem Client ausgeführt? Mach auch mal ein wuauclt /detectnow auf dem Client.

Hast Du den Gruppennamen auf dem WSUS und in der GPO geändert? Ist der WSUS auf Port 80 oder 8530 installiert?

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von Sunny am 13.07.07 um 14:54:15
Auf dem Client ausführen:

  (Du musst Dich Einloggen oder Registrieren
  (Du musst Dich Einloggen oder Registrieren

Bei welchem Link kommt ein Downloadfenster?

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von markus_herbert am 16.07.07 um 15:23:56
gpupdate /force ist klar für die sofortige Wirksamkeit der Richtlinien.

Bei   (Du musst Dich Einloggen oder Registrieren kommt ein Downloadfenster.
Bei   (Du musst Dich Einloggen oder Registrieren kommt: die Seite kann nicht angezeigt werden.

Interessant ist auch, wenn ich   (Du musst Dich Einloggen oder Registrieren
aufrufe erhalte ich die Seite:
SimpleAuth
The following operations are supported. For a formal definition, please review the Service Description.
- GetAuthorizationCookie
- Ping

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von markus_herbert am 16.07.07 um 15:28:29
> Hast Du den Gruppennamen auf dem WSUS und in der GPO geändert? Ist der WSUS auf Port 80 oder 8530 installiert?

Der WSUS ist auf dem Port 80 installiert. Da sonst nichts weiteres auf diesem Server installiert ist, gehe ich davon aus, dass der Port frei ist.

Bei dem Gruppennamen ändern stehe ich irgendwie auf dem Schlauch. Wo kann ich dies ändern?

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von Sunny am 16.07.07 um 16:33:39

markus_herbert schrieb am 16.07.07 um 15:28:29:

Der WSUS ist auf dem Port 80 installiert. Da sonst nichts weiteres auf diesem Server installiert ist, gehe ich davon aus, dass der Port frei ist.


Nachdem ja auch der Test mit diesem Aufruf   (Du musst Dich Einloggen oder Registrieren und dem Download auf Port 80 klappt ist das OK so.


markus_herbert schrieb am 16.07.07 um 15:28:29:

Bei dem Gruppennamen ändern stehe ich irgendwie auf dem Schlauch. Wo kann ich dies ändern?


Du hast doch bestimmt eine Policy erstellt, in der Du die Einstellungen für den WSUS verteilst an die Clients im Netz. Dort kann man den Gruppennamen angeben. Oder wie sollen sich sonst die Clients zum WSUS verbinden?

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von markus_herbert am 17.07.07 um 16:33:15
In der Default Domain Policy habe ich folgendes eingestellt:

Computerkonfiguration -> Administrative Vorlagen -> Windows-Komponenten -> Windows Update:

Interner Pfad für den MS Updatedienst angeben
- Aktiviert
- Interner Updatedienst zum Ermitteln von Updates: http://WSUS3
- Intranet Server für die Statistiken: http://WSUS3

Clientseitige Zielzuordnung aktivieren
- Aktiviert
- Zielgruppenname für diesen Computer: http://WSUS3

Dies funktioniert bei dem anderen Server (ohne DCPROMO) auch ohne Probleme.

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von Sunny am 17.07.07 um 22:26:41

markus_herbert schrieb am 17.07.07 um 16:33:15:

In der Default Domain Policy habe ich folgendes eingestellt:


Mööp! Schlechtester Ort für eine GPO. In der DDP solltest Du maximal eine Kennwortrichtlinie definieren. Sonst nichts! Leg eine eigene GPO für den WSUS an und verlinke diese nur auf die entsprechenden OUs.


markus_herbert schrieb am 17.07.07 um 16:33:15:

Computerkonfiguration -> Administrative Vorlagen -> Windows-Komponenten -> Windows Update:

Interner Pfad für den MS Updatedienst angeben
- Aktiviert
- Interner Updatedienst zum Ermitteln von Updates: http://WSUS3
- Intranet Server für die Statistiken: http://WSUS3

Clientseitige Zielzuordnung aktivieren
- Aktiviert
- Zielgruppenname für diesen Computer: http://WSUS3

Dies funktioniert bei dem anderen Server (ohne DCPROMO) auch ohne Probleme.


Ja und viel Anwender haben mit einer PFW auch lange keine Probleme gehabt. Ändere den Gruppennamen auf dem WSUS und natürlich auch in der GPO ab. Ich sprech aus Erfahrung. ;)

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von markus_herbert am 24.07.07 um 08:19:30
Vielen Dank für deine Hilfe. Ich habe die

Clientseitige Zielzuordnung aktivieren in der GPO wie folgt geändert:
- Aktiviert
- Zielgruppenname für diesen Computer: Server;XP;W2K;Test

Nun funktioniert alles. Die entsprechenden Rechte für den IIS beim Domänencontroller hatte ich vorher schon per Hand nachgetragen.

Titel: Re: Installation WSUS 3 auf W2003 SP1
Beitrag von Sunny am 24.07.07 um 08:47:20
Na super, freut mich für Dich und Danke für die Rückmeldung. ;)

Nochmal für alle anderen die diesen Thread mal lesen. Keinerlei http:// Gedöhns sollte im Gruppennamen sein, der WSUS verschluckt sich damit.

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.