WSUS.DE
Windows Server Update Services >> Installation und Konfiguration >> WSUS 3 installiert - und nu?
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1189070251

Beitrag begonnen von bass06 am 06.09.07 um 11:17:30

Titel: WSUS 3 installiert - und nu?
Beitrag von bass06 am 06.09.07 um 11:17:30
Hi @ all!

Ich habe endlich auch einmal die Zeit gefunden WSUS 2 auf WSUS 3.0 zu aktualisieren. Habe die Installationsdatei von wsus.de runtergeladen und er hat auch schon gleich gefragt ob ich aktualisieren will. Nachdem er die Datenbank aktualisiert hat, kam die Meldung das Upgrade sei erfolgreich. Dann konnte ich auf "fertig stellen" klicken. So weit, so gut!

Ich habe einen Einrichtungsassi erwartet oder ein Symbol auf dem Desktop oder sonstiges (ein Neustart hat nicht geholfen). Auch unter Start-Programme-Verwaltung ist nichts zu sehen von WSUS 3.0. Dort ist nur der "normale" Link zum alten WSUS (Version 2), aber der dürfte doch auch eigentlich nicht mehr da sein?! Wenn ich ihn öffne kommt die Meldung "Überprüfen Sie die Serverkonfiguration."

Wie gehe ich nun vor bzw. wo finde ich irgendeine Verknüpfung oder sonstiges um auf die Bedienoberfläche vom WSUS 3 zu kommen? Habe schon vor einer Woche den Virenscanner deinstalliert, weil ich hier gelesen habe, damit könnte es Probleme geben und der WSUS 2 hat vorher auch einwandfrei funktioniert.

Hier noch die "WindowsUpdate.log" von heute:

2007-09-06      08:40:27:103       776      358      AU      AU found 0 updates for install at shutdown
2007-09-06      08:40:27:149      2540      348      Misc      ===========  Logging initialized (build: 7.0.6000.374, tz: +0200)  ===========
2007-09-06      08:40:27:149      2540      348      Misc        = Process: C:\WINDOWS\Explorer.EXE
2007-09-06      08:40:27:149      2540      348      Misc        = Module: C:\WINDOWS\system32\wuaueng.dll
2007-09-06      08:40:27:149      2540      348      Shutdwn      Install at shutdown: no updates to install
2007-09-06      08:40:36:525       320      db0      Misc      ===========  Logging initialized (build: 7.0.6000.374, tz: +0200)  ===========
2007-09-06      08:40:36:525       320      db0      Misc        = Process: \??\C:\WINDOWS\system32\winlogon.exe
2007-09-06      08:40:36:525       320      db0      Misc        = Module: C:\WINDOWS\system32\wuaueng.dll
2007-09-06      08:40:36:525       320      db0      Shutdwn      FATAL: WUAutoUpdateAtShutdown failed, hr=8024A000
2007-09-06      08:40:42:759       776      5e8      AU      ###########  AU: Uninitializing Automatic Updates  ###########
2007-09-06      08:40:46:634       776      5e8      Service      *********
2007-09-06      08:40:46:634       776      5e8      Service      **  END  **  Service: Service exit [Exit code = 0x240001]
2007-09-06      08:40:46:634       776      5e8      Service      *************
2007-09-06      08:41:39:328       756      5a8      Misc      ===========  Logging initialized (build: 7.0.6000.374, tz: +0200)  ===========
2007-09-06      08:41:39:359       756      5a8      Misc        = Process: C:\WINDOWS\System32\svchost.exe
2007-09-06      08:41:39:359       756      5a8      Misc        = Module: C:\WINDOWS\system32\wuaueng.dll
2007-09-06      08:41:39:328       756      5a8      Service      *************
2007-09-06      08:41:39:359       756      5a8      Service      ** START **  Service: Service startup
2007-09-06      08:41:39:359       756      5a8      Service      *********
2007-09-06      08:41:40:312       756      5a8      Agent        * WU client version 7.0.6000.374
2007-09-06      08:41:40:328       756      5a8      Agent        * Base directory: C:\WINDOWS\SoftwareDistribution
2007-09-06      08:41:40:390       756      5a8      Agent        * Access type: No proxy
2007-09-06      08:41:40:421       756      5a8      Agent        * Network state: Connected
2007-09-06      08:42:25:864       756      5a8      Agent      ***********  Agent: Initializing Windows Update Agent  ***********
2007-09-06      08:42:25:864       756      5a8      Agent      ***********  Agent: Initializing global settings cache  ***********
2007-09-06      08:42:25:864       756      5a8      Agent        * WSUS server: http://wsus-server
2007-09-06      08:42:25:864       756      5a8      Agent        * WSUS status server: http://wsus-server
2007-09-06      08:42:25:864       756      5a8      Agent        * Target group: (Unassigned Computers)
2007-09-06      08:42:25:864       756      5a8      Agent        * Windows Update access disabled: No
2007-09-06      08:42:26:535       756      5a8      DnldMgr      Download manager restoring 0 downloads
2007-09-06      08:42:26:551       756      5a8      AU      ###########  AU: Initializing Automatic Updates  ###########
2007-09-06      08:42:26:551       756      5a8      AU        # WSUS server: http://wsus-server
2007-09-06      08:42:26:551       756      5a8      AU        # Detection frequency: 22
2007-09-06      08:42:26:551       756      5a8      AU        # Approval type: Pre-install notify (Policy)
2007-09-06      08:42:26:551       756      5a8      AU        # Auto-install minor updates: No (User preference)
2007-09-06      08:42:26:551       756      5a8      AU      AU finished delayed initialization
2007-09-06      08:42:26:551       756      5a8      Report      ***********  Report: Initializing static reporting data  ***********
2007-09-06      08:42:26:551       756      5a8      Report        * OS Version = 5.2.3790.2.0.196880
2007-09-06      08:42:28:408       756      5a8      Report        * Computer Brand = VMware, Inc.
2007-09-06      08:42:28:408       756      5a8      Report        * Computer Model = VMware Virtual Platform
2007-09-06      08:42:28:440       756      5a8      Report        * Bios Revision = 6.00
2007-09-06      08:42:28:440       756      5a8      Report        * Bios Name = PhoenixBIOS 4.0 Release 6.0    
2007-09-06      08:42:28:440       756      5a8      Report        * Bios Release Date = 2006-04-17T00:00:00
2007-09-06      08:42:28:440       756      5a8      Report        * Locale ID = 1031


MfG
bass06

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von Sunny am 06.09.07 um 11:21:40
Auf dem Server in dieses Verzeichnis navigieren und die WSUS.MSC mit Doppelklick öffnen:
"C:\Programme\Update Services\administrationsnapin\wsus.msc"

Auf einem Client kannst Du auch die MMC installieren, einfach das Setup vom WSUS erneut aufrufen und nur die Verwaltungskonsole installieren.

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von bass06 am 06.09.07 um 13:36:12
Den Ordner "administrationsnapin" gibt's gar nicht. Auch ein Suchen von "wsus.msc" auf dem gesamten Rechner ergab nichts. Irgendwas ist hier gar nicht gut...

In "Update Services" sind nur folgende Ordner:

administration, Common, database, documentation, LogFiles, service, Setup, Tools, WebServices

btw: hab den gesamten Upgrade-Vorgang (dank einfacher Wiederherstellung durch vmware) schon zwei mal durchgeführt. Jeweils das gleiche Ergebnis (wie oben beschrieben).

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von WSUS.DE-Admin am 06.09.07 um 13:43:09
Bist du dir sicher, dass du den WSUS 3.0 auch installiert hast?!  :-/
Kannst du denn noch die Admin-Webseite vom WSUS 2.0 öffnen?
Was steht denn unter Systemsteuerung -> Software ?
2.0 oder 3.0 ?!

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von Sunny am 06.09.07 um 13:49:57

bass06 schrieb am 06.09.07 um 13:36:12:

Den Ordner "administrationsnapin" gibt's gar nicht. Auch ein Suchen von "wsus.msc" auf dem gesamten Rechner ergab nichts. Irgendwas ist hier gar nicht gut...


Das befürchte ich auch. Du hast auch sicher den WSUS 3.0 installiert? Die MMC 3.0 ist auch installiert? Gibts eine lokale Gruppe WSUS-Reporters?


bass06 schrieb am 06.09.07 um 13:36:12:

In "Update Services" sind nur folgende Ordner:

administration, Common, database, documentation, LogFiles, service, Setup, Tools, WebServices



Sieht die Installation so wie hier aus?
  (Du musst Dich Einloggen oder Registrieren

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von bass06 am 06.09.07 um 14:54:43
Ich habe den Screenshot der ersten Seite der Installation angehängt. Die Installation läuft durch bis Bild 10 auf deiner Seite Sunny, danach nichts mehr. Auf meinem Desktop ist auch die Installationsdatei zu sehen (WSUS3Setupx86.exe). Das müsste auf jeden Fall WSUS 3 sein!

Lokale Gruppen gibt's nur IUSR_WSUS-Server und IWAM_WSUS-Server.

Die MMC 3 hab ich schon vorher installiert. Genau wie den Report Viewer, .Net 2.0 usw..

Auf die Website vom WSUS 2 komm ich noch, da steht wie gesagt "Überprüfen Sie die Serverkonfiguration..... ".

Und unter Software steht nur:
"Microsoft Windows Server Update Services Service Pack 1"
wsus_005.jpg ( 153 KB | Downloads )

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von Sunny am 06.09.07 um 14:59:06
Kann es sein, daß noch ein SUS 1.0 zusätzlich installiert ist? Den mußt Du vorher deinstallieren.

Deinstalliere mal die vorherige Version in der Systemsteuerung > Software. Gehts dann? Sehr komisch ist das schon.

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von bass06 am 06.09.07 um 15:25:21
Deinstallieren funktioniert nicht. Er sagt mir: "ungültige Befehlszeilenparameter" und ich soll in die "WSUSSetup.log" schauen

Da steht dann folgendes drin:
2007-09-06 15:17:56  Error     MWUSSetup          Wsus 2.0 is installed. The only possible setup action is upgrade (Error 0x80041453)
2007-09-06 15:17:57  Error     MWUSSetup          DoInstall: ParseCommandLine failed (Error 0x80041453)

Also kann ich anscheinend nur upgraden und nicht löschen?!


Wenn ich statt "entfernen" auf "ändern" klicke, will er automatisch auf WSUS 3.0 aktualisieren....

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von Sunny am 06.09.07 um 16:01:11
Ist das ein 64BIT OS? Hast Du auch die passende Setup.exe gewählt?

Hol sie dir hier nochmal bitte:   (Du musst Dich Einloggen oder Registrieren

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von bass06 am 10.09.07 um 09:03:50
Kein 64 Bit OS und mit der neuen Setup.exe ist es das gleiche...

Alternative wäre wohl den WSUS 2 weiter zu benutzen oder eine gänzliche Neuinstallation des WSUS 3, wobei dann ja Einstellungen usw. nicht mit übernommen werden oder?  :-/

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von Sunny am 10.09.07 um 09:47:02

bass06 schrieb am 10.09.07 um 09:03:50:

Alternative wäre wohl den WSUS 2 weiter zu benutzen oder eine gänzliche Neuinstallation des WSUS 3, wobei dann ja Einstellungen usw. nicht mit übernommen werden oder?  :-/


Du könntest auch in einer virtuellen Maschine einen weiteren WSUS 2.0 installieren und den zum Downstream des ersten machen. Dann hast Du sämtliche Einstellungen gesichert.

Jetzt den alten WSUS 2.0 komplett rückstandsfrei deinstallieren, incl. WMSDE. Auf der virtuellen Maschine dann auf 3.0 upgraden und den Server wieder zum Upstream machen. Jetzt erst auf der alten Maschine den 3er installieren und mit dem anderen synchronisieren.

Da morgen abend wieder Patchday ist, solltest Du entweder die GPO für die Clients anpassen oder warten bis die Clients up2date sind.

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von bass06 am 05.10.07 um 09:32:06
Sooo, habe mal wieder etwas Zeit mit WSUS weiterzumachen..

Ich habe jetzt den zweiten WSUS 2.0 installiert und bei der Installation als Downstream festgelegt. Ich versuche als nächstes diesen neuen Server auf Version 3 zu bringen.. aber wie mache ich einen Downstream zum Upstream? Ich kann diese Einstellmöglichkeit nicht finden..

MfG
bass06

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von Sunny am 05.10.07 um 10:08:43

bass06 schrieb am 05.10.07 um 09:32:06:

Ich habe jetzt den zweiten WSUS 2.0 installiert und bei der Installation als Downstream festgelegt. Ich versuche als nächstes diesen neuen Server auf Version 3 zu bringen..


OK.


bass06 schrieb am 05.10.07 um 09:32:06:

aber wie mache ich einen Downstream zum Upstream? Ich kann diese Einstellmöglichkeit nicht finden..


Beim 3er findest Du das in den Optionen: Assistent für die WSUS-Serverkonfiguration.

Beachte bitte! Nur beim 3er gibts diese Möglichkeit so in der Form. Beim 2er mußt Du den Weg über eine Deinstallation gehen.

Titel: Re: WSUS 3 installiert - und nu?
Beitrag von bass06 am 10.10.07 um 14:59:43
Ok, es hat alles geklappt... endlich!  ;D

Hat nach Sunnys Tipp funktioniert: Hab einen zweiten WSUS 2 (als Downstream) installiert. Nach der Synchronisation mit dem Upstream habe ich den Upstream vollständig deinstalliert. Dann WSUS 3 installiert und den zweiten WSUS auf die Version 3 gebracht damit die Einstellungen kopiert werden konnten. Dann nur noch den eigentlichen WSUS als Downstream deklarieren und den anderen in die Tonne kloppen.

Danke nochmals für die Hilfe!

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.