WSUS.DE
Windows Server Update Services >> Troubleshooting >> Update wird auf Clienten nicht installiert
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1190282009

Beitrag begonnen von OnkelTom am 20.09.07 um 11:53:27

Titel: Update wird auf Clienten nicht installiert
Beitrag von OnkelTom am 20.09.07 um 11:53:27
Hallo zusammen.

Ich habe folgendes Phänomen und hoffe, das mir jemand einen Tip geben kann:

- WSUS 3 neu installiert
- per Gruppenrichtlinie diverse Clienten ( XP, 2k3, 2000, Vista ) auf den WSUS konfiguriert
- alle Clienten melden sich auch brav beim WSUS

hier nun das Problem:
WSUS meldet für einen 2k3 terminal server
---
1 Update wurde nicht installiert
50 Updates wurden installiert
913 Updates sind nicht zutreffend
---
Wenn ich mir nun den Bericht dieses Clienten im WSUS anschaue dann sagt er mir, das es das "Microsoft .NET Framework 3.0: x86 (KB928416)" ist was nicht installiert ist.

Das wäre ja noch ok, ABER der Client zeigt mir KEINE Updates zum Installieren an, kein Icon unten in der Taskleiste.
Wenn ich den Windowsupdate von Hand auf dem Clienten anstosse ( wuauclt /detectnow ) dann findet der aber KEINE Updates.
Hier der Log Auszug

2007-09-20      10:03:46:880       944      259c      Agent        * Found 0 updates and 35 categories in search; evaluated appl. rules of 618 out of 850 deployed entities
2007-09-20      10:03:46:990       944      259c      Agent      *********
2007-09-20      10:03:46:990       944      259c      Agent      **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2007-09-20      10:03:46:990       944      259c      Agent      *************
2007-09-20      10:03:46:990       944      3098      AU      >>##  RESUMED  ## AU: Search for updates [CallId = {5F27071F-3C59-4712-AB58-3492084265B6}]
2007-09-20      10:03:46:990       944      3098      AU        # 0 updates detected
2007-09-20      10:03:47:005       944      3098      AU      #########
2007-09-20      10:03:47:005       944      3098      AU      ##  END  ##  AU: Search for updates [CallId = {5F27071F-3C59-4712-AB58-3492084265B6}]
2007-09-20      10:03:47:005       944      3098      AU      #############
2007-09-20      10:03:47:005       944      3098      AU      AU setting next detection timeout to 2007-09-20 11:19:35
2007-09-20      10:03:51:990       944      259c      Report      REPORT EVENT: {90C8E1AC-674F-46B5-AA13-530871AF168B}      2007-09-20 10:03:46:990+0200      1      147      101      {00000000-0000-0000-0000-000000000000}      0      0      AutomaticUpdates      Success      Software Synchronization      Windows Update Client successfully detected 0 updates.
2007-09-20      10:03:51:990       944      259c      Report      REPORT EVENT: {DCEDBF33-6900-4E45-81B2-D7EC388397BC}      2007-09-20 10:03:46:990+0200      1      156      101      {00000000-0000-0000-0000-000000000000}      0      0      AutomaticUpdates      Success      Pre-Deployment Check      Reporting client status.
2007-09-20      10:13:33:447       944      259c      Report      Uploading 2 events using cached cookie, reporting URL =   (Du musst Dich Einloggen oder Registrieren
2007-09-20      10:13:33:462       944      259c      Report      Reporter successfully uploaded 2 events.


Was kann ich tuen?

Gruß

Thomas

Titel: Re: Update wird auf Clienten nicht installiert
Beitrag von Sunny am 20.09.07 um 12:38:09
Habt ihr mehrere TS-Server? Sind die evtl. geklont worden? Kontrollier mal die angegebene IP-Adresse.

Wie sieht die Policy für den TS aus? Option 4 eingestellt mit passender Uhrzeit?

Titel: Re: Update wird auf Clienten nicht installiert
Beitrag von OnkelTom am 20.09.07 um 12:54:24
Hi Sunny,

wir haben zwei TS im Einsatz, ja.
Und die sind nicht geklont worden, sind unterschiedliche Hardware und zeitlich versetzt gekommen.

IPs sind in Ordnung, es handelt sich wirklich um den zweiten Server der die "Probleme" macht.

Die haben beide die gleiche Policy, allerdings nicht 4 mit Uhrzeit sondern 3! -Will keine automatische Installation auf den beiden Terminsalservern. Und beim ersten Server gehts ja auch alles sauber.

Ne Idee?
Ich habe den zweiten auch schonmal aus dem WSUS gelöscht und den neu "anmelden" lassen, selbes Ergebnis.

Gruß

Thomas

Titel: Re: Update wird auf Clienten nicht installiert
Beitrag von Sunny am 20.09.07 um 14:47:13
OK, dann wirf ihn nochmals aus der WSUS Konsole raus. Gleichzeitig bitte die SIDs auf dem TS löschen, die hier genannt sind:   (Du musst Dich Einloggen oder Registrieren

Was genau steht in der Registry unter den Policies?
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate

Siehst Du einen Unterschied zum funktionierenden TS? Wenn ja, dann ist vermutlich die GPO defekt. Ja, wir hatten das schon des öfteren hier im Forum und/oder in den MS-NGs. Du kannst mal folgendes probieren: Den TS in eine OU verschieben, auf der *KEINE* GPO verlinkt ist. Neustart und in der Registry kontrollieren, daß auch wirklich nichts mehr von GPOs vorhanden ins:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\
Jetzt eine neue GPO für den WSUS erstellen und auf die OU verlinken. Neustart vom Server und wieder kontrollieren. Ist der Wert jetzt korrekt? Wenn ja, dann verschieb ihn wieder in die richtige OU retour. Lösch die alte WSUS-GPO und verlink die neue drauf. Neustart und wieder kontrollieren. Wenns jetzt passt ist ja alles wieder OK. ;)

Titel: Re: Update wird auf Clienten nicht installiert
Beitrag von OnkelTom am 21.09.07 um 11:23:20
Hi,

danke für die Tips.
Aber es hat nichts gebracht.

Ich hab alles so gemacht und hab auch mal die Reg Einträge geschaut, die sind auf beiden Maschinen gleich. Vorher wie nachher.

Und nun ist der zweite TS wieder drin und zeigt mir auf dem Server wieder nichts zu installieren an, im Log stehen 0 Updates und auf dem WSUS wieder "1 Update heruntergeladen aber nicht installiert".

Und nun?

Gruß

Thomas

PS: ach ja, es ist immernoch das gleiche Update ".NET Framework" was er nicht installiert hat / will

Titel: Re: Update wird auf Clienten nicht installiert
Beitrag von Sunny am 21.09.07 um 11:49:02
Kannst Du es denn manuell installieren? Wenn es nicht klappt, könnte das hier helfen:

Falls .NET Framework 1.1 SP1 sich nicht installieren lässt. Kommt folgende Fehlermeldung:

Die Anwendung hat einen Ausnahmefehler verursacht, der nicht verarbeitet werden konnte.
Prozess = ID= 0x97c(2428), Thread - ID= 0x980 (2432)
Der registrierte JIT Debugger ist nicht verfügbar
Cordbg.exe ! a 0x97c"

soll man folgendes machen:
start/ausführen


C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\caspol.exe -s off

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\caspol.exe

Anschließend die Installation noch mal durchführen.

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.