WSUS.DE
Windows Server Update Services >> Troubleshooting >> Computer meldet sich nicht beim Server an
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1191826650

Beitrag begonnen von _Neo_ am 08.10.07 um 08:57:29

Titel: Computer meldet sich nicht beim Server an
Beitrag von _Neo_ am 08.10.07 um 08:57:29
Hallo!

Mir ist durchaus bewusst das dieses Thema schon häufig zur Sprache kam in diesem Forum. Doch die Problematik ist nicht immer zwangsläufig die Gleiche. Somit erstelle ich einen neuen Thread dazu:

Ich habe den WSUS 3.0 auf einem Windows Server 2003 installiert und konfiguriert. Zunächst einmal soll sich der Server selbst mit Updates versorgen. Doch bereits daran scheitert es. Denn der Computer wird erst gar nicht aufgeführt. Ich habe die Einstellungen in den Gruppenrichtlinien vorgenommen und auch ein Update dieser Einstellungen forciert. Die angegebene Bezugsquelle für die Updates ist auch korrekt. Zunächst hatte ich es über die IP und den Port versucht, doch dann bin ich auf den Computernamen und Port umgestiegen.

Der Server wurde auch schon neu gestartet und der WSUS 3.0 ist schon seit einigen Tagen installiert. Somit habe ich nicht wirklich Hoffnung das „er sich auf einmal selbst findet“^^

Um noch ein wenig mehr Informationen zu geben hier ein Auszug aus dem UpdateLog:

2007-10-08      08:11:15:828      1948      5e8      PT      WARNING: PTError: 0x80244017
2007-10-08      08:11:15:828      1948      5e8      PT      WARNING: GetConfig_WithRecovery failed: 0x80244017
2007-10-08      08:11:15:828      1948      5e8      PT      WARNING: RefreshConfig failed: 0x80244017
2007-10-08      08:11:15:828      1948      5e8      PT      WARNING: RefreshPTState failed: 0x80244017
2007-10-08      08:11:15:828      1948      5e8      PT      WARNING: Sync of Updates: 0x80244017
2007-10-08      08:11:15:828      1948      5e8      PT      WARNING: SyncServerUpdatesInternal failed: 0x80244017
2007-10-08      08:11:15:828      1948      5e8      Agent        * WARNING: Failed to synchronize, error = 0x80244017
2007-10-08      08:11:16:125      1948      5e8      Agent        * WARNING: Exit code = 0x80244017
2007-10-08      08:11:16:125      1948      5e8      Agent      *********
2007-10-08      08:11:16:125      1948      5e8      Agent      **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2007-10-08      08:11:16:125      1948      5e8      Agent      *************
2007-10-08      08:11:16:125      1948      5e8      Agent      WARNING: WU client failed Searching for update with error 0x80244017
2007-10-08      08:11:16:125      1948      440      AU      >>##  RESUMED  ## AU: Search for updates [CallId = {EFC405C1-0090-4259-9342-1FBFBF3FDE3A}]
2007-10-08      08:11:16:125      1948      440      AU        # WARNING: Search callback failed, result = 0x80244017
2007-10-08      08:11:16:125      1948      440      AU        # WARNING: Failed to find updates with error code 80244017
2007-10-08      08:11:16:125      1948      440      AU      #########
2007-10-08      08:11:16:125      1948      440      AU      ##  END  ##  AU: Search for updates [CallId = {EFC405C1-0090-4259-9342-1FBFBF3FDE3A}]
2007-10-08      08:11:16:125      1948      440      AU      #############
2007-10-08      08:11:16:125      1948      440      AU      AU setting next detection timeout to 2007-10-08 07:10:38
2007-10-08      08:11:16:141      1948      440      AU      Setting AU scheduled install time to 2007-10-09 01:00:00
2007-10-08      08:11:21:125      1948      5e8      Report      REPORT EVENT: {253F73E7-D4DB-4D6F-A17E-BFF97F99CD27}      2007-10-08 08:11:16:125+0200      1      148      101      {00000000-0000-0000-0000-000000000000}      0      80244017      AutomaticUpdates      Failure      Software Synchronization      Windows Update Client failed to detect with error 0x80244017.
2007-10-08      08:12:15:203      1948      14a4      AU      AU received policy change subscription event
2007-10-08      08:12:29:406      1948      14a4      AU      AU received policy change subscription event
2007-10-08      08:13:12:625      1948      14a4      AU      AU received policy change subscription event

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von Sunny am 08.10.07 um 09:28:11
  (Du musst Dich Einloggen oder Registrieren ist für die Fehlernummer relevant.

Zeig doch mal ein ipconfig /all vom Server. Ist das ein DC? Fehlermeldungen im Ereignisprotokoll?

Kommt die GPO auf dem Server korrekt an? RSOP.MSC zeigt dir das.

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von _Neo_ am 08.10.07 um 10:34:39
Die GPO kommt korrekt an und scheint auch nicht das Problem zu sein. Bei dem Server handelt es sich auch nicht um einen DC. Im Ereignisprotokoll finde ich folgende Fehlermeldungen (Codes): 13042 und 13051 – Diese beiden Meldungen nehmen direkten Bezug auf die Clients und scheinen relevant zu sein. Des Weiteren befinden sich noch einige andere Fehlermeldungen der Kategorie „Web Services“ im Protokoll. Falls es weiterhilft kann ich auch dazu noch einen Screenshot posten.

Der Screen von der IP-Config ist im Anhang…

edit: Nun geht's mit dem Anhang;)
Server_IP-Config.JPG (Anhang gelöscht)

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von Sunny am 08.10.07 um 10:50:16
Das mit dem Anhang mußt Du wohl nochmal üben. ;)

Es wird wohl an Berechtigungen fehlen. Der NETZWERKDIENST braucht mind. Leserechte auf die Root und auf das Content Verzeichnis.

  (Du musst Dich Einloggen oder Registrieren
  (Du musst Dich Einloggen oder Registrieren

Bei welchem Link kommt ein Download?
  (Du musst Dich Einloggen oder Registrieren
  (Du musst Dich Einloggen oder Registrieren
WSUS mußt Du durch den richtigen Servernamen ersetzen.

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von _Neo_ am 08.10.07 um 13:21:05
Für mich ergibt sich in diesem Thema einfach kein Sinn. Im IIS ist sowohl auf Port 80, als auch auf Port 8530 die Seite „Selfupdate“ vorhanden und der anonyme Zugriff wird gestattet. Die Seiten verweisen auf das richtige Verzeichnis (C:\Programme\Update Services\Selfupdate).

Bei dem „Gesundheitscheck“ des WSUS werden dem Ereignisprotokoll wiederum die gleichen Fehler hinzugefügt. Welche ich als Screenshot wieder in den Anhang packe.

Ein Download erfolgt bei mir unter keiner der von Dir genannten Adressen. Ich bekomme in beiden Fällen einen Firewall- oder Proxyfehler, zumindest wenn ich es über den Computernamen versuche. Wenn ich allerdings die IP des Servers benutze, dann kann ich die Datei über beide Pfade downloaden. Wobei ich mich bei dem Pfad ohne die Portnummer authentifizieren muss.

Ereignisanzeige.JPG (Anhang gelöscht)

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von Sunny am 08.10.07 um 13:33:27

_Neo_ schrieb am 08.10.07 um 13:21:05:

Für mich ergibt sich in diesem Thema einfach kein Sinn. Im IIS ist sowohl auf Port 80, als auch auf Port 8530 die Seite „Selfupdate“ vorhanden und der anonyme Zugriff wird gestattet. Die Seiten verweisen auf das richtige Verzeichnis (C:\Programme\Update Services\Selfupdate).


Entscheide dich für einen Port. Der muß natürlich auch in der GPO angegeben sein, wenn <> 80.


_Neo_ schrieb am 08.10.07 um 13:21:05:

Ein Download erfolgt bei mir unter keiner der von Dir genannten Adressen. Ich bekomme in beiden Fällen einen Firewall- oder Proxyfehler, zumindest wenn ich es über den Computernamen versuche. Wenn ich allerdings die IP des Servers benutze, dann kann ich die Datei über beide Pfade downloaden. Wobei ich mich bei dem Pfad ohne die Portnummer authentifizieren muss.


Du bist sicher, daß die Ausgabe von ipconfig /all korrekt ist? Die DNS-Server sind einer komplett anderen Range. Ich bin nicht der Sezialist für sowas, ich frag ja nur. ;)

Auf welchem Port ist denn der WSUS installiert? Wird denn ein Proxy benutzt?

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von _Neo_ am 08.10.07 um 13:44:22
Der WSUS ist auf dem Port 8530 installiert! Also kann ich die Seite vom 80er Port löschen? In der GPO ist ebenfalls der Port 8530 angegeben.

Der Server greift über einen Proxy auf das externe Netz zu, welcher eigentlich nur nachts aktiv ist und ihm lediglich die Synchronisation mit Microsoft Update erlauben soll. Doch momentan habe ich den Proxy auch laufen, um zu testen.

Im Bezug auf die Adresse des DNS Servers:
Ich bin auch kein Experte auf dem Gebiet, doch mir kommt das auch merkwürdig vor. Denn scheinbar liegt das Problem bei der Namensauflösung.

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von Sunny am 08.10.07 um 14:49:51
Selfupdate sollte auf Port 80 laufen:
  (Du musst Dich Einloggen oder Registrieren
  (Du musst Dich Einloggen oder Registrieren

So seh ich das auch. Du kannst ja in der HOSTS einen entsprechenden Eintrag machen, um zu testen.

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von _Neo_ am 08.10.07 um 14:54:17
Wie ich eben gerade festgestellt habe gab es ein Problem mit meinem Profil. Unter diesem Profil wurde auch der WSUS 3.0 aufgesetzt. Nun wurde das Profil zurückgesetzt. Aus diesem Grund bin ich gerade dabei die Anwendung noch mal zu installieren. Ich werde anschließend posten ob es etwas gebracht hat…

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von _Neo_ am 09.10.07 um 10:45:06
So,

nun hat der Server sich auch selber erkannt! Sofern ich das beurteilen kann lag es an folgender Situation:

Der Server war Mitglied einer Domäne, war aber nicht der DC dieser Domäne. Die GPO wurden von mir allerdings lokal auf dem Server eingestellt. Dies schien eine Unstimmigkeit hervor zu rufen. Nachdem ich den Server aus der Domäne entfernt hatte funktionierte die Erkennung sofort. Leider war es mir nicht möglich das Problem anders zu lösen. Da ich keine Administrationsrechte auf dem DC habe :/

Interessant wäre nun zu wissen ob dies wirklich der einzige Weg war um das Problem zu lösen. Ehrlich gesagt kann ich mir das nicht vorstellen. Des Weiteren habe ich noch einen weiteren Server zu seinen "Clients" hinzugefügt, welcher wiederum in der Domäne ist und sich trotzdem über die lokale GPO beim Server einfand.

Bitte um Klärung  :P

Titel: Re: Computer meldet sich nicht beim Server an
Beitrag von Sunny am 09.10.07 um 11:50:31

_Neo_ schrieb am 09.10.07 um 10:45:06:

Der Server war Mitglied einer Domäne, war aber nicht der DC dieser Domäne. Die GPO wurden von mir allerdings lokal auf dem Server eingestellt. Dies schien eine Unstimmigkeit hervor zu rufen. Nachdem ich den Server aus der Domäne entfernt hatte funktionierte die Erkennung sofort. Leider war es mir nicht möglich das Problem anders zu lösen. Da ich keine Administrationsrechte auf dem DC habe :/


Mann oh Mann, sowas blödes gibts doch gar nicht.  >:( Sorry, aber das mußte raus.

Wenn man einen Server in die Domain aufnimmt, sollte man schon auch etwas über lokale GPOs und Domain GPOs wissen. Wenn Du eine lokale Richtlinie erstellst, wird sie von der Domain GPO überschrieben.

Evtl. hättest Du dich mit dem zuständigen Admin in Verbindung setzen sollen, er kann den Server in eine eigenen OU packen und dir entsprechende Rechte darauf geben. Dann kannst Du eine GPO für den Server erstellen, die dann auch nur auf die OU wirkt.



_Neo_ schrieb am 09.10.07 um 10:45:06:

Interessant wäre nun zu wissen ob dies wirklich der einzige Weg war um das Problem zu lösen. Ehrlich gesagt kann ich mir das nicht vorstellen. Des Weiteren habe ich noch einen weiteren Server zu seinen "Clients" hinzugefügt, welcher wiederum in der Domäne ist und sich trotzdem über die lokale GPO beim Server einfand.


Ich vermute ein DNS-Problem. Ich kenn die Struktur nicht, kann dazu also nichts sagen. In meiner Domain gibts 2 GPOs für den WSUS. Eine für die Clients und eine für die Server. Die sind auf die entsprechenden OUs verlinkt, in der sich die passenden Objekte befinden. Mich dünkt, Du hast Schulungsbedarf. Du kennst gruppenrichtlinien.de? Nein, dann schau dich dort mal ein bisschen um. ;)

BTW: Wenn ich von GPO spreche, ist immer von Domain GPOs die Rede. Warum sollte ich in einer Domain etwas lokal konfigurieren?

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.