WSUS.DE
Windows Server Update Services >> Troubleshooting >> WSUS erzeugt Netzlast
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1196241422

Beitrag begonnen von knixs am 28.11.07 um 10:17:00

Titel: WSUS erzeugt Netzlast
Beitrag von knixs am 28.11.07 um 10:17:00
Hallo zusammen,

ich baue derzeit eine WSUS Infrastruktur auf. Diese soll aus 1 WSUS bestehen, der sich die Updates bei MS abholt und 2 weiteren WSUS Replica Servern die sich in den Aussenstellen befinden.

Der Master und ein Replicaserver sind bereits im Einsatz und arbeiteten bis gestern zufriedenstellend. Jetzt habe ich einen 2 Replicaserver bereitgestellt und seitdem hab ich ein riesiges Problem.

Ich musste gestern die Master neu starten und wenn er wieder am Netz ist erzeugt er zur Aussenstelle so eine hohe Netzlast (ping bei 2000 ms) dass ein arbeiten nicht mehr möglich ist.
Das seltsame ist, in der Aussenstelle steht das Replicat, welches bis jetzt funktionierte.
(Ich habe keine Updates oder sonstige Änderungen an Master oder Replicat vorgenomme, ausser das ich ein zweiten Replikatserver bereitgestellt habe)
Hat jemand einen Tip für mich woran das liegen kann?

Vielen Dank

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 28.11.07 um 10:22:51
Was macht der Master in der Zeit? Synchronisiert er sich mit dem Replica?

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 28.11.07 um 10:52:04
Sync von Master -> MS startet nachts um 1
Sync von Master -> Replica 1 nachts um 2
Sync von Master -> Replica 2 nachts um 3

Allerdings muss der Master was machen, denn wenn ich das Kabel ziehe geht der Ping sofort runter, stecke ich das Kabel wieder ein geht's wieder rauf.
In den Logdateien sehe ich nicht wirklich ob er sich syncronisiert.
(Ich hab im Eventlog einen Eintrag, die Katalogsynchronisierung funktioniert ordnungsgemäß. 5 Miniuten nach dem Sync. Im WSUS Snap-In ist auch alles grün)



Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 28.11.07 um 11:30:59
Welcher Prozess verursacht die Last? ProcessExplorer von MS sollte helfen. Kontrollier mal die Einstellungen für Sprache + den Rest der Replica Server mit dem Master.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 28.11.07 um 12:51:14
Die Einstellungen passen.
Systemlast erzeugt kein Prozess wirklich. Ich hab mittlerweiler den Server wieder am Netz.
Es steigt nur die Netzlast wenn ich den Update Service auf dem Master starte und sinkt wieder auf normale Werte zurück wenn ich den Dienst beende.

Ich hab auch zwischen dem Replicat und dem Master nichts verändert. Ich hab nur einen zweiten Replicatservier hinzugefügt.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 28.11.07 um 13:58:19

knixs schrieb am 28.11.07 um 12:51:14:

Es steigt nur die Netzlast wenn ich den Update Service auf dem Master starte und sinkt wieder auf normale Werte zurück wenn ich den Dienst beende.


Der Update Service nutzt den BITS. Den kannst Du via GPO anpassen, damit nicht die komplette Bandbreite benutzt wird.


knixs schrieb am 28.11.07 um 12:51:14:

Ich hab auch zwischen dem Replicat und dem Master nichts verändert. Ich hab nur einen zweiten Replicatservier hinzugefügt.


Und der zweite Replicat Server hat sich schon erfolgreich mit dem Master synchronisiert? Auf dem Replik sind keinerlei Änderungen vorgenommen worden?

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 28.11.07 um 15:07:18

Sunny schrieb am 28.11.07 um 13:58:19:

knixs schrieb am 28.11.07 um 12:51:14:

Es steigt nur die Netzlast wenn ich den Update Service auf dem Master starte und sinkt wieder auf normale Werte zurück wenn ich den Dienst beende.


Der Update Service nutzt den BITS. Den kannst Du via GPO anpassen, damit nicht die komplette Bandbreite benutzt wird.



knixs schrieb am 28.11.07 um 12:51:14:

Ich hab auch zwischen dem Replicat und dem Master nichts verändert. Ich hab nur einen zweiten Replicatservier hinzugefügt.


Und der zweite Replicat Server hat sich schon erfolgreich mit dem Master synchronisiert? Auf dem Replik sind keinerlei Änderungen vorgenommen worden?


Laut Log haben sich heute nacht beide Server erfolgreich mit dem Master abgeglichen. Der Replicat, der nun Probleme macht hat die letzten 4 Monate ordentlich gearbeitet.

Aber die BITS Einstellungen werd ich trotzdem kontrollieren.
Stößt der Replicatserver den Abgleich an oder geht das von dem Master aus? (Den Einstellungen nach gehe ich von dem Replicatserver aus)

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 28.11.07 um 15:23:00

knixs schrieb am 28.11.07 um 15:07:18:

Laut Log haben sich heute nacht beide Server erfolgreich mit dem Master abgeglichen. Der Replicat, der nun Probleme macht hat die letzten 4 Monate ordentlich gearbeitet.


Trotzdem ist es möglich, daß jemand Einstellungen verändert hat. Insbesonders die Sprachen sind zu kontrollieren. Hatten wir hier schon ab und an mal.


knixs schrieb am 28.11.07 um 15:07:18:

Stößt der Replicatserver den Abgleich an oder geht das von dem Master aus? (Den Einstellungen nach gehe ich von dem Replicatserver aus)


Ich hab keine Replica Server hier, ich geh aber davon aus, das der Replicat Server sich mit dem Master synchronisieren will.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 28.11.07 um 16:30:56
Es ist bald zum heulen  :-?
Einstellungen sind unverändert.

BITS hab auf 10 KB/s gestellt und dann den Update Service auf dem Master gestartet.
Es dauert etwas länger aber der ping geht dann doch wieder hoch und fängt sich erst, wenn ich auf dem Master den Dienst stoppe.
(Das stoppen auf dem Replicat ändert nichts)
Aber es scheint an BITS zu liegen, denn wenn ich den Dienst beende ist alles wieder im grünen Bereich.

Ich bin jetzt so vorgegangen, dass ich den BITS auf allen 3 Systemen eingeschränkt habe und bis jetzt bleibt's ruhig an der ping-front ::)

Testweise abe ich ein Syncvorgang angestoßen und der ist innerhalb einer Minute beendet. Was machen die Server denn danach noch?

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 28.11.07 um 17:26:50

knixs schrieb am 28.11.07 um 16:30:56:

Ich bin jetzt so vorgegangen, dass ich den BITS auf allen 3 Systemen eingeschränkt habe und bis jetzt bleibt's ruhig an der ping-front ::)


Hmm, normal ist das nicht.  :(


knixs schrieb am 28.11.07 um 16:30:56:

Testweise abe ich ein Syncvorgang angestoßen und der ist innerhalb einer Minute beendet. Was machen die Server denn danach noch?


Nach der Synchronisation sollten sie eigentlich nichts mehr machen. Starte doch auf dem Master den Serverbereinigungsassisten mal. Auch kannst Du den WSUS-Konfig-Assi auf dem Master nochmal durchlaufen lassen.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 29.11.07 um 08:35:27

Sunny schrieb am 28.11.07 um 17:26:50:

Hmm, normal ist das nicht.  :(

Da muss ich dir (leider) zustimmen.
Heute morgen übrigens wieder das gleiche Spiel ...
Ich denke da schiesst mir irgendetwas anderes im Netz quer, denn wie gesagt das ganze lief ja bis vorgestern.
Vielleicht liegt der Hund ja auch darin begraben, dass der Master auf ner VM liegt .... ich bin ratlos. :-/


Sunny schrieb am 28.11.07 um 17:26:50:

Nach der Synchronisation sollten sie eigentlich nichts mehr machen. Starte doch auf dem Master den Serverbereinigungsassisten mal. Auch kannst Du den WSUS-Konfig-Assi auf dem Master nochmal durchlaufen lassen.

Das dachte ich eigentlich auch. Der Serverbereinigungsassistent hatte ich schon laufen lassen.
Vielleicht sollte ich den WSUS Assi wirklich mal laufen lassen.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 29.11.07 um 08:56:32

knixs schrieb am 29.11.07 um 08:35:27:

Da muss ich dir (leider) zustimmen.
Heute morgen übrigens wieder das gleiche Spiel ...
Ich denke da schiesst mir irgendetwas anderes im Netz quer, denn wie gesagt das ganze lief ja bis vorgestern.


Dann solltest Du versuchen, rauszubekommen, was zu dem Zeitpunkt geändert wurde.


knixs schrieb am 29.11.07 um 08:35:27:

Vielleicht liegt der Hund ja auch darin begraben, dass der Master auf ner VM liegt .... ich bin ratlos. :-/


Nein, dann hätten andere das Problem auch.


knixs schrieb am 29.11.07 um 08:35:27:

Das dachte ich eigentlich auch. Der Serverbereinigungsassistent hatte ich schon laufen lassen.
Vielleicht sollte ich den WSUS Assi wirklich mal laufen lassen.


Yepp, mach das, evtl. hilfts ja was.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 29.11.07 um 09:42:33
Es hilft leider alles nix. Ich hab jetzt alle drei Server abgeschaltet.
Da ich's ja nicht lassen konnte hab ich den Master wieder gestartet. Hier mal ein kleiner Mitschnitt des ping.
Master am Netz, die beiden Replica sind aus.

Antwort von <IP>: Bytes=32 Zeit=14ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=15ms TTL=128
-->WSUS am Netzt
Antwort von <IP>: Bytes=32 Zeit=939ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1273ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1388ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1339ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1326ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1352ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1393ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1431ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1359ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1335ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1309ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1135ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1168ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1233ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1289ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1250ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=1120ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=652ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=160ms TTL=128
--> WSUS vom Netz getrennt
Antwort von <IP>: Bytes=32 Zeit=16ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=15ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=17ms TTL=128
Antwort von <IP>: Bytes=32 Zeit=13ms TTL=128


Der Ping geht auf den DC der Aussenstelle in der auch der Replica steht.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 29.11.07 um 11:00:31
Außer einer sauberen Deinstallation mit anschließender Neuinstallation wüßte ich jetzt nichts mehr. Dazu müßte man direkt auf dem Server arbeiten können.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 29.11.07 um 11:59:02

Sunny schrieb am 29.11.07 um 11:00:31:
Außer einer sauberen Deinstallation mit anschließender Neuinstallation wüßte ich jetzt nichts mehr. Dazu müßte man direkt auf dem Server arbeiten können.

Ich spiele schon mit dem Gedanken, da ich absolut keinen Zusammenhang finde warum die Netzwerkverbindung zusammenbricht wenn der WSUS per BITS seine Updates zieht.
Und es liegt definitiv daran, denn stoppe ich den Dienst und den Update Service rennt die Verbindung wieder.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 29.11.07 um 12:53:10
Laß mal wenn möglich einen Sniffer mitlaufen und checkhealth + healthmonitoring kann auch nicht schaden:
  (Du musst Dich Einloggen oder Registrieren

Such mal hier im Forum nach BITSADMIN und schau mit WinBITS den Inhalt vom BITS an:   (Du musst Dich Einloggen oder Registrieren  
Evtl. hängt irgendein Download.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 29.11.07 um 13:46:19
Hmm, gesund ist der Server ...

Den BITS hab ich mir schon angesehen, (mit bitsadmin /LIST /ALLUSERS)
Es hängen 10 Jobs. Ich werd heute abend mal versuchen ob ich die beenden kann. Alle nach windowsupdate.

Bleibt für mich aber noch das Mysterium. Warum bläst er die Leitung zur Aussenstelle zu?

Vielen Dank für WinBITS, ist schon angenehmer als über die Konsole  :)

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 29.11.07 um 14:33:30

knixs schrieb am 29.11.07 um 13:46:19:

Hmm, gesund ist der Server ...


Na wenigstens etwas. ;)


knixs schrieb am 29.11.07 um 13:46:19:

Den BITS hab ich mir schon angesehen, (mit bitsadmin /LIST /ALLUSERS)
Es hängen 10 Jobs. Ich werd heute abend mal versuchen ob ich die beenden kann. Alle nach windowsupdate.


Geht mit BITSADMIN /RESET /ALLUSERS AFAIR. ;)



knixs schrieb am 29.11.07 um 13:46:19:

Bleibt für mich aber noch das Mysterium. Warum bläst er die Leitung zur Aussenstelle zu?


Evtl. wird versucht darüber an WU zu kommen.




knixs schrieb am 29.11.07 um 13:46:19:

Vielen Dank für WinBITS, ist schon angenehmer als über die Konsole  :)


Ich weiß. ;)

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 30.11.07 um 08:34:38
So, heute nacht hat der Server noch ein wenig für Traffic auf der LEitung gesorgt und nun ist alles wieder in Bester Ordnung.

Problem:
BITS hat im Hintergund einiges gezogen, warum er neue Updates gezogen hat ist mir jedoch noch nicht so klar. Da werd ich mal die Doku zu rate ziehen und ggf. neu psoten. Das Thema mit der Bandbreite hat sich auch geklärt. Da deine Vermutung in vorhergehnden Post zutreffend ist. Derzeit laüft die Aussenstelle über dieselbe Leitung wie die Internetanbindung ... (ne aktualisierte Doku wäre schön gewesen  >:()
Der BITS äuft bei mir im Vordergrund, da sonst die Firewall Downloads bei Windowsupdate nicht passieren lässt.

Sunny Vielen Dank für deinen Beistand und deine Tips.

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 30.11.07 um 09:46:27

knixs schrieb am 30.11.07 um 08:34:38:

So, heute nacht hat der Server noch ein wenig für Traffic auf der LEitung gesorgt und nun ist alles wieder in Bester Ordnung.


Super, freut mich und Danke für die Rückmeldung. ;)


knixs schrieb am 30.11.07 um 08:34:38:

BITS hat im Hintergund einiges gezogen, warum er neue Updates gezogen hat ist mir jedoch noch nicht so klar. Da werd ich mal die Doku zu rate ziehen und ggf. neu psoten.


Welche Updates waren das denn? Evtl. waren es ja auch neue Revisionen. Was hast Du in den Optionen > Automatische Genehmigungen eingestellt?



knixs schrieb am 30.11.07 um 08:34:38:

Das Thema mit der Bandbreite hat sich auch geklärt. Da deine Vermutung in vorhergehnden Post zutreffend ist. Derzeit laüft die Aussenstelle über dieselbe Leitung wie die Internetanbindung ... (ne aktualisierte Doku wäre schön gewesen  >:()


Jetzt kannst Du die Doku ja aktualisieren. ;)


knixs schrieb am 30.11.07 um 08:34:38:

Sunny Vielen Dank für deinen Beistand und deine Tips.


Bitte, gern geschehen. ;)

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 30.11.07 um 10:12:10

Sunny schrieb am 30.11.07 um 09:46:27:



knixs schrieb am 30.11.07 um 08:34:38:

BITS hat im Hintergund einiges gezogen, warum er neue Updates gezogen hat ist mir jedoch noch nicht so klar. Da werd ich mal die Doku zu rate ziehen und ggf. neu psoten.


Welche Updates waren das denn? Evtl. waren es ja auch neue Revisionen. Was hast Du in den Optionen > Automatische Genehmigungen eingestellt?

Wir haben hier ein mehrstufiges Konzept wie Software und Updates verteilt werden. Ich hab einfach nur der nächsten Stufe die Updates genehmigt.
Die Updates sind eigentlich alle schon auf dem Server, da sie ja schon and die Testgruppe und die Key-Usern verteilt wurden.

Im Syncprotokoll stehen auch drei hüsche Nullen, deswegen weiß ich ehrlich gesagt gar nicht was er da läd.
Da die Leitung schon wieder dicht ist vermute ich, dass der Master alle Updates erneut zieht um diese dann dem neuen Replicatserver schickt.
Eine andere Erklärung hab ich derzeit nicht und in der Deploymentdoku ist es ähnlich beschrieben.
(Spracheinstellungen sind auf allen Systemen identisch)

Naja, das macht das Patchmanagment recht mühselig.  :(


Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 30.11.07 um 10:43:20

knixs schrieb am 30.11.07 um 10:12:10:

Im Syncprotokoll stehen auch drei hüsche Nullen, deswegen weiß ich ehrlich gesagt gar nicht was er da läd.


In welchem Protokoll?


knixs schrieb am 30.11.07 um 10:12:10:

Da die Leitung schon wieder dicht ist vermute ich, dass der Master alle Updates erneut zieht um diese dann dem neuen Replicatserver schickt.
Eine andere Erklärung hab ich derzeit nicht und in der Deploymentdoku ist es ähnlich beschrieben.
(Spracheinstellungen sind auf allen Systemen identisch)


Dann muß auf dem Replica etwas verändert worden sein. Das hatten wir auch hier im Forum schon ab und an.


knixs schrieb am 30.11.07 um 10:12:10:

Naja, das macht das Patchmanagment recht mühselig.  :(


Verständlich, aber wohl eher hausgemacht. ;)

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 30.11.07 um 11:47:09

Sunny schrieb am 30.11.07 um 10:43:20:

knixs schrieb am 30.11.07 um 10:12:10:

Im Syncprotokoll stehen auch drei hüsche Nullen, deswegen weiß ich ehrlich gesagt gar nicht was er da läd.


In welchem Protokoll?

Syncronisierungen


Sunny schrieb am 30.11.07 um 10:43:20:


knixs schrieb am 30.11.07 um 10:12:10:

Da die Leitung schon wieder dicht ist vermute ich, dass der Master alle Updates erneut zieht um diese dann dem neuen Replicatserver schickt.
Eine andere Erklärung hab ich derzeit nicht und in der Deploymentdoku ist es ähnlich beschrieben.
(Spracheinstellungen sind auf allen Systemen identisch)

Dann muß auf dem Replica etwas verändert worden sein. Das hatten wir auch hier im Forum schon ab und an.

Das geht eigentlich nicht, da der Replica das übernimmt was auf dem Master vorgegeben wird.  :-[


Sunny schrieb am 30.11.07 um 10:43:20:


knixs schrieb am 30.11.07 um 10:12:10:

Naja, das macht das Patchmanagment recht mühselig.  :(


Verständlich, aber wohl eher hausgemacht. ;)

Naja, wenn sich herausstellt, das er den den Inhalt für den Replica erneut von MS zieht, dann ist es nicht wirklich hausgemacht.  ::)

Schönes Wochenede  :D


Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 30.11.07 um 12:15:41

knixs schrieb am 30.11.07 um 11:47:09:

Das geht eigentlich nicht, da der Replica das übernimmt was auf dem Master vorgegeben wird.  :-[/quote]

Doch das geht. Kontrollier das mal in den Optionen des Replica. Insbesonders die Spracheinstellungen.


knixs schrieb am 30.11.07 um 11:47:09:

Naja, wenn sich herausstellt, das er den den Inhalt für den Replica erneut von MS zieht, dann ist es nicht wirklich hausgemacht.  ::)


Ich trau mich schon fast wetten. :D

[quote author=knixs link=1196241422/15#22 date=1196419629]
Schönes Wochenede  :D


Danke, Dir auch. ;)

Titel: Re: WSUS erzeugt Netzlast
Beitrag von knixs am 04.12.07 um 16:41:14

Sunny schrieb am 30.11.07 um 12:15:41:


Ich trau mich schon fast wetten. :D



:-[ Ok, es waren wohl die Sprachen ....
Ich hab kein Häkchen bei den Sprachen gemacht. Ich war der Überzeugung, dass er nur das übernimmt was auf dem Master vorgegeben ist und alles was ich zusätzlich will muss ich anwählen.

War wohl nen Trugschluss :-[

Wie bekomme ich die Sprachen jetzt wieder weg? Sind immerhin 14 GB die ich zuviel hab.  ::)

Titel: Re: WSUS erzeugt Netzlast
Beitrag von Sunny am 04.12.07 um 23:48:36

knixs schrieb am 04.12.07 um 16:41:14:

:-[ Ok, es waren wohl die Sprachen ....


;D Wußte ich es doch!  ;)


knixs schrieb am 04.12.07 um 16:41:14:

Ich hab kein Häkchen bei den Sprachen gemacht. Ich war der Überzeugung, dass er nur das übernimmt was auf dem Master vorgegeben ist und alles was ich zusätzlich will muss ich anwählen.

War wohl nen Trugschluss :-[/quote]

Jepp, Stolperstein Nummer 1 beim WSUS. Die Spracheneinstellung. Aber mach dir nix draus, Du bist nicht der erste und der einzigste, da sind schon ganz andere drüber gestolpert. ;) Wenn Du bei der Ersteinrichtung von einem Replica andere Sprachen als beim Master auswählst, synchronisiert der Replica diese Information zum Master und der holt sich die fehlenden beim MS direkt. So einfach ist das, wenn man es weiß. ;)


[quote author=knixs link=1196241422/15#24 date=1196782874]
Wie bekomme ich die Sprachen jetzt wieder weg? Sind immerhin 14 GB die ich zuviel hab.  ::)


Spracheinstellungen korrigieren und Serverbereinigungsassi laufen lassen sollte helfen.

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.