WSUS.DE
Windows Server Update Services >> Troubleshooting >> .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1201788690

Beitrag begonnen von PatPowerMan am 31.01.08 um 15:11:29

Titel: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von PatPowerMan am 31.01.08 um 15:11:29
Wir haben heute testweise "Visual Basic 2008 Express Edition" (auf deutsch) und darin als Teilkomponente .NET 3.5 installiert. Kaum den Entwickler-Test-PC neu gestartet, wurde auch schon das "Microsoft .NET Framework 3.0: x86 Language Pack (KB928416)" heruntergeladen.

Leider schlug die Installation fehl (was ja eigentlich nachvollziehbar ist, wenn ein 3.0 über ein 3.5 installiert werden soll).

Meine Fragen sind nun:

a) Kann jemand von Euch diesen Umstand nachvollziehen/bestätigen?

b) Was macht Ihr einem solchen Fall?
(Setzt Ihr den z.B. den Status von "KB928416" auf "ablehnen" oder "nicht installieren"?)

c) Versucht die Zielmaschine nun "ewig" diesen KB928416 zu installieren, oder gibt WSUS das irgendwann selber auf? Wenn ja, nach was für einem Prinzip?

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von Sunny am 31.01.08 um 17:21:30

PatPowerMan schrieb am 31.01.08 um 15:11:29:

Wir haben heute testweise "Visual Basic 2008 Express Edition" (auf deutsch) und darin als Teilkomponente .NET 3.5 installiert. Kaum den Entwickler-Test-PC neu gestartet, wurde auch schon das "Microsoft .NET Framework 3.0: x86 Language Pack (KB928416)" heruntergeladen.

Leider schlug die Installation fehl (was ja eigentlich nachvollziehbar ist, wenn ein 3.0 über ein 3.5 installiert werden soll).


Für mich nicht ganz, es soll ja nur das Language Pack installiert werden. Ist denn kein .Net Framework 3.0 installiert? Wenn nein, nacholen, dann dürfte der Rest auch kein Problem mehr darstellen.



PatPowerMan schrieb am 31.01.08 um 15:11:29:

a) Kann jemand von Euch diesen Umstand nachvollziehen/bestätigen?


Nein, kein VS 2008 am Start. ;)


PatPowerMan schrieb am 31.01.08 um 15:11:29:

b) Was macht Ihr einem solchen Fall?
(Setzt Ihr den z.B. den Status von "KB928416" auf "ablehnen" oder "nicht installieren"?)


.Net Framework 3.0 würde ich installieren. ;)


PatPowerMan schrieb am 31.01.08 um 15:11:29:

c) Versucht die Zielmaschine nun "ewig" diesen KB928416 zu installieren, oder gibt WSUS das irgendwann selber auf? Wenn ja, nach was für einem Prinzip?


Der WSUS macht gar nix, der stellt das ja nur zur Verfügung. Das ist alles die Zielmaschine. Du mußt für die korrekte Vorrausetzung sorgen.


Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von PatPowerMan am 31.01.08 um 17:38:44
Danke für Deine wie immer schnelle Antwort! :)


Sunny schrieb am 31.01.08 um 17:21:30:
Für mich nicht ganz, es soll ja nur das Language Pack installiert werden. Ist denn kein .Net Framework 3.0 installiert? Wenn nein, nacholen, dann dürfte der Rest auch kein Problem mehr darstellen.


Doch ".NET Fw 3.0" war/ist installiert - vor der VB-Installation waren auch keine Updates mehr pendent.
Müsste es denn nicht ein Language Pack 3.5 geben?

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von Sunny am 31.01.08 um 19:54:25
OK, dann rück mal mit der Fehlermeldung aus der WindowsUpdate.log raus.

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von PatPowerMan am 01.02.08 um 07:59:27
Ein offensichtlicher Grund springt mir aufgrund dieser Zeilen leider nicht ins Gesicht:

Code (]2008-01-31      14:48:52:172       936      92c      AU      AU received install approval from client for 1 updates
2008-01-31      14:48:52:172       936      92c      AU      #############
2008-01-31      14:48:52:172       936      92c      AU      ## START ##  AU: Install updates
2008-01-31      14:48:52:172       936      92c      AU      #########
2008-01-31      14:48:52:172       936      92c      AU        # Initiating manual install
2008-01-31      14:48:52:172       936      92c      AU        # Approved updates = 1
2008-01-31      14:48:52:172       936      92c      AU      <<## SUBMITTED ## AU: Install updates / installing updates [CallId = {F30D7032-2C63-460C-A4BA-1012FF1C3D15}):


2008-01-31      14:48:52:172       936      f54      Agent      *************
2008-01-31      14:48:52:172       936      f54      Agent      ** START **  Agent: Installing updates [CallerId = AutomaticUpdates]
2008-01-31      14:48:52:172       936      f54      Agent      *********
2008-01-31      14:48:52:172       936      f54      Agent        * Updates to install = 1
2008-01-31      14:48:52:172       936      f54      Agent        *   Title = Microsoft .NET Framework 3.0: x86 Language Pack (KB928416)
2008-01-31      14:48:52:172       936      f54      Agent        *   UpdateId = {662280C8-A9F9-4E0A-B936-AF3E53BC3F91}.103
2008-01-31      14:48:52:172       936      f54      Agent        *     Bundles 1 updates:
2008-01-31      14:48:52:172       936      f54      Agent        *       {35AA1EED-2E33-47E5-BE7C-06C06D84386B}.103
2008-01-31      14:49:11:816       936      f54      Handler      Attempting to create remote handler process as FIRMA\Kurzzeichen in session 0
2008-01-31      14:49:13:597       936      f54      DnldMgr      Preparing update for install, updateId = {35AA1EED-2E33-47E5-BE7C-06C06D84386B}.103.
2008-01-31      14:49:15:988      3764      b28      Misc      ===========  Logging initialized (build: 7.0.6000.381, tz: +0100)  ===========
2008-01-31      14:49:15:988      3764      b28      Misc        = Process: C:\WINDOWS\system32\wuauclt.exe
2008-01-31      14:49:15:988      3764      b28      Misc        = Module: C:\WINDOWS\system32\wuaueng.dll
2008-01-31      14:49:15:988      3764      b28      Handler      :::::::::::::
2008-01-31      14:49:15:988      3764      b28      Handler      :: START ::  Handler: Command Line Install
2008-01-31      14:49:15:988      3764      b28      Handler      :::::::::
2008-01-31      14:49:15:988      3764      b28      Handler        : Updates to install = 1
2008-01-31      14:49:37:646      3764      b28      Handler        : WARNING: Command line install completed. Return code = 0x000013ec, Result = Failed, Reboot required = false
2008-01-31      14:49:37:646       936      a74      AU      >>##  RESUMED  ## AU: Installing update [UpdateId = {662280C8-A9F9-4E0A-B936-AF3E53BC3F91}]
2008-01-31      14:49:37:646       936      a74      AU        # WARNING: Install failed, error = 0x80070643 / 0x000013EC
2008-01-31      14:49:37:646      3764      b28      Handler        : WARNING: Exit code = 0x8024200B
2008-01-31      14:49:37:646      3764      b28      Handler      :::::::::
2008-01-31      14:49:37:646      3764      b28      Handler      ::  END  ::  Handler: Command Line Install
2008-01-31      14:49:37:646      3764      b28      Handler      :::::::::::::
2008-01-31      14:49:37:771       936      a74      AU      Install call completed.
2008-01-31      14:49:37:771       936      a74      AU        # WARNING: Install call completed, reboot required = No, error = 0x00000000
2008-01-31      14:49:37:771       936      a74      AU      #########
2008-01-31      14:49:37:771       936      a74      AU      ##  END  ##  AU: Installing updates [CallId = {F30D7032-2C63-460C-A4BA-1012FF1C3D15}]
2008-01-31      14:49:37:771       936      a74      AU      #############

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von Sunny am 01.02.08 um 10:16:25
Kannst Du denn das Update manuell installieren? Oder taucht es in Software [X] Updates anzeigen auf?

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von Ralli64 am 08.02.08 um 12:27:23
Hallo,

Da ich nicht weiss, ob ihr schon weiter gekommen seit...

Das Problem .net3.5 und WSUS (KB KB928416) kann ich bestätigen.

Es tritt hier auf einen PC auf, der manuell installiert wurde. XP-SP2 dann per WSUS alle Updates bis heute. Dann, zum Test, das Framework 3.5 installiert... Kurze Zeit später wollte der PC das KB928416 wieder haben. Installieren lassen. Ergebnis : fehlgeschlagen... Und das Update kam immer wieder!

Unsere, bisher Einzige, praktikable Lösung :

1. Deinstallieren Framework 3.5
2. Deinstallieren Framework 3.0
3. Neustart des PC
4. Löschen "Softwaredistribution"
5. Updates wieder installieren lassen

Jetzt ist wieder Ruhe... :-)

Irgenwo im Internet habe ich gelesen, das dieses Problem bekannt ist und der Grund dafür ist, dass Framework 3.5 etwas mitbringt, was eigentlich im Framework 3.0 enthalten ist. Da aber das Framework 3.5 kein WSUS-Bestandteil ist, scheitert irgendeine Erkennungsroutine für das Ermitteln erforderlicher Updates.....


Gruss Ralf


Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von PatPowerMan am 08.02.08 um 14:59:48
Interessant Ralli64! Danke für die Rückmeldung.
Hast Du allenfalls noch die Internetquelle zum nachlesen/beobachten?

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von Ralli64 am 11.02.08 um 07:30:29
Hallo,

Leider finde ich "genau den" Artikel nicht mehr <grummel>...

Ich habe nur noch die hier :

  (Du musst Dich Einloggen oder Registrieren

  (Du musst Dich Einloggen oder Registrieren

  (Du musst Dich Einloggen oder Registrieren


Gruss Ralf


Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von PatPowerMan am 03.03.08 um 17:16:41
Leider gibts anscheinend in dieser Sache noch keine News, oder?

Was gibt es in WSUS eigentlich für Möglichkeiten, in einer solchen Situation den fehlerhaften Patch "zurückzuziehen"?

Mir geht es um die störende Tatsache, dass ich möglichst keine roten Einträge mit Fehlerhaften Updates/Computern in den Statistiken haben möchte. Vorallem aber keine, die ich nicht selber beeinflussen kann, weil ich direkt abhängig von MS und deren Korrektur bin.

Wie macht Ihr das?

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von sb3 am 05.03.08 um 14:05:55
Hi,

auch ich habe an einem Client genau dieses Problem; bis jetzt hat es meistens geholfen, den Windows Installerdienst mit msiexec /regserver neu zu registrieren. In diesem Fall haben wir zwar schon mal die Deinstallation des .Net 3.5 und 3.0 gemacht, das hat aber auch nichts geholfen. Ich fürchte, man muss wirklich alle .Net Komponenten von dem betroffenen Rechner kratzen (in unserem Fall 1.1 SP1 und 2.0) und danach noch mal sauber neu installieren (lassen  ;))

Gruß
Harry

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von PatPowerMan am 05.03.08 um 18:52:04

sb3 schrieb am 05.03.08 um 14:05:55:
...msiexec /regserver neu zu registrieren..
Das check ich nicht ganz: Warum soll das neu registrieren bei unserem Problem helfen?

Verstehe ich Dich richtig, NACH dem neu registrieren wurde bei Dir das .NET 3.0-Language Pack ohne Fehler installiert?

Titel: Re: .NET 3.5 zieht .NET 3.0 Language Pack an - funktioniert aber nicht
Beitrag von sb3 am 06.03.08 um 07:21:52
Nein, nicht ganz
ich wollte damit sagen, dass ich auch des öfteren den Fehler WARNING: Install failed, error = 0x80070643
bei der Aktualisierung von .Net Komponenten habe und mir dann die Neuregistierung des Installers schon oft geholfen hat (frag' jetzt aber bitte nicht , warum  ::))
In unserem Fall gehe ich davon aus, dass wirklich nur die völlige Deinstallation und Neuinstallation ALLER .NEt-Komponenten helfen kann...

Gruß
Harry

WSUS.DE » Powered by YaBB 2.6.11!
YaBB Forum Software © 2000-2016. Alle Rechte vorbehalten.