Heißes Thema (mehr als 10 Antworten) Update von Wsus 2 auf 3 - Probleme (Gelesen: 14341 mal)
webactivity
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 5
Standort: Hannover
Mitglied seit: 27.05.07
Update von Wsus 2 auf 3 - Probleme
27.05.07 um 02:41:21
Beitrag drucken  
Hallo zusammen!

So wie es aussieht habe ich ein Problem.. bisher setzte ich wsus 2 ein auf MS Server 2003 standard ger. Darin eingebunden 40 x clients XP SP2 von der Verkaufsabteilung. Alles bene, keine Probleme.

Habe nun upgedatet auf v.3. Die Prozedur stiess ich an über Windows Update per web. Zuerst .Net 2, danach wsus3... alles in allem lief das so ca 60min. Vor dem Start des setups von wsus 3 wurde wsus 2 von mir nicht angefasst, lief ja alles.

Tja.. und was nun? So wie es aussieht ist die Datenbank autom. migriert worden. Aber wenn ich nun in die Admin-Konsole gehe von WSUS3 sehe ich NIX wo ich was tun könnte!

Nur verbinden mit server ist da zu sehen..  klar, der ist localhost denk ich..
aber nix geht, auf keinem der Ports. Ich sehe nix.
Sollte es nicht so sein dass alle settings von der alten wsus 2 installation übernommen wurden? Denn die hat einwandfrei funktioniert..
Ein blick in die Logfiles zeigt folgendes das nach dem Reboot der Maschine und dem start des wsus-dienstes angezeigt wurde:

Event-id: 12052
Der DSS-Authentifizierungswebdienst funktioniert nicht.

Event-id: 12042
Der SimpleAuth-Webdienst funktioniert nicht.

Event-id: 12022
Der Clientwebdienst funktioniert nicht.

Event-id: 12032
Der Serversynchronisierungs-Webdienst funktioniert nicht.

Event-id: 12012
Der API-Remoting-Webdienst funktioniert nicht.

Event-id: 12002
Der Berichterstattungswebdienst funktioniert nicht.

Event-id: 10032
Der Server kann einige Updates nicht herunterladen.

Event-id: 13042
Selbstupdate funktioniert nicht.

Was mach ich jetzt? Was übersehen ? Weiss jemand Rat?

Viele Gruesse + vielen Dank schon mal

Tom
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Antwort #1 - 28.05.07 um 14:53:20
Beitrag drucken  
webactivity schrieb on 27.05.07 um 02:41:21:
Habe nun upgedatet auf v.3. Die Prozedur stiess ich an über Windows Update per web. Zuerst .Net 2, danach wsus3... alles in allem lief das so ca 60min. Vor dem Start des setups von wsus 3 wurde wsus 2 von mir nicht angefasst, lief ja alles.


Schlechte Strategie. Solche Updates macht man nicht über Windows Update. Alle benötigten Files downloaden, und wenn möglich den Server vorher einmal sauber neu starten.

webactivity schrieb on 27.05.07 um 02:41:21:
Tja.. und was nun? So wie es aussieht ist die Datenbank autom. migriert worden. Aber wenn ich nun in die Admin-Konsole gehe von WSUS3 sehe ich NIX wo ich was tun könnte!

Nur verbinden mit server ist da zu sehen..  klar, der ist localhost denk ich..
aber nix geht, auf keinem der Ports. Ich sehe nix.
Sollte es nicht so sein dass alle settings von der alten wsus 2 installation übernommen wurden? Denn die hat einwandfrei funktioniert..


Du benutzt aber schon die MMC, die vom WSUS 3 mit installiert wurde?

webactivity schrieb on 27.05.07 um 02:41:21:
Event-id: 12052
Der DSS-Authentifizierungswebdienst funktioniert nicht.
Event-id: 12042
Der SimpleAuth-Webdienst funktioniert nicht.
Event-id: 12022
Der Clientwebdienst funktioniert nicht.
Event-id: 12032
Der Serversynchronisierungs-Webdienst funktioniert nicht.
Event-id: 12012
Der API-Remoting-Webdienst funktioniert nicht.
Event-id: 12002
Der Berichterstattungswebdienst funktioniert nicht.
Event-id: 10032
Der Server kann einige Updates nicht herunterladen.
Event-id: 13042
Selbstupdate funktioniert nicht.


Ist das ein SBS? Hast Du das WhitePaper zur Installation auf dem SBS gelesen?

Wenn Du den SMTP-Dienst nicht benötigst kannst Du ihn deaktivieren.

Hast Du den Windows Scripting Host installiert? Wenn nein, hol es nach: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Hast Du auch den ReportViewer 2005 incl. SP1 installiert? Vermutlich nicht: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
webactivity
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 5
Standort: Hannover
Mitglied seit: 27.05.07
Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Antwort #2 - 29.05.07 um 19:33:00
Beitrag drucken  
Hallo,

vielen Dank zuerst mal. Heute habe ich WSUS3 wieder deinstalliert und danach neu Installiert, Ohne Erfolg, er läuft immer noch nicht.

Zu deinen Fragen.

Es ist kein sbs. Das System ist auf W2K3 SP2, MMC v.3 ist drauf,
ReportViewer 2005, .Net 2, IIS-6...

Die WSUS 3 De-Installation verlief reibungslos. Die ursprünglich beim Update migrierten WSUS 2 DB Datensätze sind nun natürlich weg.

Die anschliessende Neuinstallation velief ebenso reibungslos.
Die Probleme beginnen wenn der WSUS Setup-Wizard anstartet.
Dies resultiert in angehängter Fehlermeldung.
Der direkte Aufruf des Wizards unter:

LW:\Programme\Update Services\administrationsnapin\
microsoft.updateservices.ui.oobewizard.exe

mit dem selben Ergebnis. Im Snapin kann ich nach wie vor nur auf
"Verbindung mit dem Server herstellen! was aber Fehler erzeugt dass
auf den Server nicht zugegriffen werden kann.

Woran könnts liegen?



[img][/img]
  

001.gif (Anhang gelöscht)
Zum Seitenanfang
 
webactivity
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 5
Standort: Hannover
Mitglied seit: 27.05.07
Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Antwort #3 - 29.05.07 um 19:37:34
Beitrag drucken  
Hier noch zwei Shots:
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). 003.gif (Anhang gelöscht)
Zum Seitenanfang
 
webactivity
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 5
Standort: Hannover
Mitglied seit: 27.05.07
Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Antwort #4 - 29.05.07 um 19:38:58
Beitrag drucken  
Hab alles durchprobiert.. Weiss jemand Rat?

Gruesse

Tom
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). 004.gif (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Antwort #5 - 29.05.07 um 21:31:41
Beitrag drucken  
[quote author=webactivity link=1180226482/0#2 date=1180459980]
vielen Dank zuerst mal. Heute habe ich WSUS3 wieder deinstalliert und danach neu Installiert, Ohne Erfolg, er läuft immer noch nicht.
[/quote]

Warum deinstalliert eigentlich jeder den WSUS wieder, wenn es Probleme gibt?

[quote author=webactivity link=1180226482/0#2 date=1180459980]
Es ist kein sbs. Das System ist auf W2K3 SP2, MMC v.3 ist drauf,
ReportViewer 2005, .Net 2, IIS-6...
[/quote]

Was läuft denn sonst noch so alles auf dem Server? Könntest Du den IIS auch mal komplett deinstallieren und den Server rebooten? Oder als Alternative einen virtuellen Server nur für den WSUS installieren?


[quote author=webactivity link=1180226482/0#2 date=1180459980]
Die WSUS 3 De-Installation verlief reibungslos. Die ursprünglich beim Update migrierten WSUS 2 DB Datensätze sind nun natürlich weg.
[/quote]

Das Contentverzeichnis hast Du aber behalten, oder?

[quote author=webactivity link=1180226482/0#2 date=1180459980]
Die anschliessende Neuinstallation velief ebenso reibungslos.
Die Probleme beginnen wenn der WSUS Setup-Wizard anstartet.
Dies resultiert in angehängter Fehlermeldung.
[/quote]

Der WSUS erzeugt beim installieren ein Logfile im Tempverzeichnis. Bevor Du die Installation abbrichst, sichere mal das Logfile und poste es hier.

Welche Einträge hast Du im EventLog auf dem Server?
  
Zum Seitenanfang
 
webactivity
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 5
Standort: Hannover
Mitglied seit: 27.05.07
Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Antwort #6 - 31.05.07 um 08:12:14
Beitrag drucken  
[quote] Was läuft denn sonst noch so alles auf dem Server? [/quote]

File, Print und DHCP Services


[quote] Könntest Du den IIS auch mal komplett deinstallieren und den Server rebooten [/quote]

Deinstallieren nein, rebooten ja.. schon passiert, Effekt 0

[quote] Oder als Alternative einen virtuellen Server nur für den WSUS installieren? [/quote]

Nein, derzeit keine Testmaschine verfügbar.

[quote] Das Contentverzeichnis hast Du aber behalten, oder?[/quote]

Nein, ich wollte einnen Schnitt machen und alles neu ziehen.


[quote]
Der WSUS erzeugt beim installieren ein Logfile im Tempverzeichnis. Bevor Du die Installation abbrichst, sichere mal das Logfile und poste es hier.[/quote]

Wie heisst das Log?

[quote] Welche Einträge hast Du im EventLog auf dem Server?[/quote]

Siehe mein erster Beitrag..

Event-id: 12052
Der DSS-Authentifizierungswebdienst funktioniert nicht.

Event-id: 12042
Der SimpleAuth-Webdienst funktioniert nicht.

Event-id: 12022
Der Clientwebdienst funktioniert nicht.

Event-id: 12032
Der Serversynchronisierungs-Webdienst funktioniert nicht.

Event-id: 12012
Der API-Remoting-Webdienst funktioniert nicht.

Event-id: 12002
Der Berichterstattungswebdienst funktioniert nicht.

Event-id: 10032
Der Server kann einige Updates nicht herunterladen.

Event-id: 13042
Selbstupdate funktioniert nicht.


Also langsam nervt dieses WSUS...

Gruesse

Tom
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von Wsus 2 auf 3 - Nix geht mehr!?
Antwort #7 - 31.05.07 um 10:14:59
Beitrag drucken  
[quote author=webactivity link=1180226482/0#6 date=1180591934]
File, Print und DHCP Services
[/quote]

Sonst nichts?

[quote author=webactivity link=1180226482/0#6 date=1180591934]
Deinstallieren nein, rebooten ja.. schon passiert, Effekt 0
[/quote]

Warum den IIS nicht deinstallieren? Was läuft noch im IIS?

[quote author=webactivity link=1180226482/0#6 date=1180591934]
Nein, derzeit keine Testmaschine verfügbar.
[/quote]

Für einen virtuellen Server brauchts keine Testmaschine. Virtual Server 2005 ist kostenlos von MS und eine W2K3 Server-CD hast Du bestimmt auch noch. W2K3 Server in der virtuellen Maschine installieren, den WSUS installieren und testen.


[quote author=webactivity link=1180226482/0#6 date=1180591934]
Wie heisst das Log?
[/quote]

Liegt im Temp-Verzeichnis: *.log. Genaueres hab ich jetzt nicht zur Hand. Schau dort rein, bevor Du den Assi beendest.

[quote author=webactivity link=1180226482/0#6 date=1180591934]
Also langsam nervt dieses WSUS...
[/quote]

Auf Deinem Server ist irgendwas nicht in Ordnung, das hat mit dem WSUS nix zu tun. Ist auf dem Server eine Virenscanner Managment Konsole installiert? Wenn ja, läuft die im IIS? Ist das Laufwerk komprimiert?
  
Zum Seitenanfang
 
Galban
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 1
Standort: Hamburg
Mitglied seit: 14.06.07
Geschlecht: männlich
Re: Update von Wsus 2 auf 3 - Probleme
Antwort #8 - 14.06.07 um 10:36:24
Beitrag drucken  
Hallo,

prinzipiell ein ResolverProblem - Der Name wird als IPv6 aufgelöst! Und
somit wird die Verbindung zum IIS via IPv6 hergestellt mit dem offensichtlich der IIS mit dem WSUS Aufsatz nicht umgehen kann!

Für mich war die Lösung den IPv6 Stack komplett zu entfernen!
(Stack aus der Netzwerkverbindungen->Eigenschaften LAN-Verbindung -> IPv6 .. entfernen. )
Danach waren die Fehlermeldungen komplett verschwunden und der Zugriff war wieder unproblematisch möglich.

Nicht untersucht habe ich:
- Es reicht vielleicht auch den IPv6 Eintrag aus der /windows/system32/drivers/etc/hosts zu löschen oder die Reihenfolge zu ändern
- Eventuell den Nameserver anpassen
- ein IPv4-IPv6 Gateway

Wer also mit den letzten Punkten rumprobiert hat ich würde mich über Kommentare dazu freuen!

Gruß
Galban
  
Zum Seitenanfang
 
Doquentin
WSUS Junior Member
*
Offline


I Love WSUS

Beiträge: 26
Mitglied seit: 25.07.06
Re: Update von Wsus 2 auf 3 - Probleme
Antwort #9 - 14.06.07 um 15:55:02
Beitrag drucken  
Hi,

du hast die Datenbank mitgenommen, den Content aber gelöscht?
Ob das so gut ist..

Kam WSUS 3 mit dem Umstand klar? Was zeigt er nun für Updates an?
  
Zum Seitenanfang
 
AdminTrainee
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 1
Standort: münchen
Mitglied seit: 10.07.07
Re: Update von Wsus 2 auf 3 - Probleme
Antwort #10 - 10.07.07 um 18:53:35
Beitrag drucken  
Ich habe auf einem Kundenserver exakt das gleiche Problem.
Mittlerweile bin ich auch bei einer frischen WSUS 3.0 Installation angekommen, konsole und alles geht, nur kann sich kein client connecten.
Im Eventlog habe ich die gleichen Einträge.
IP6 ist nicht installiert.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von Wsus 2 auf 3 - Probleme
Antwort #11 - 10.07.07 um 23:21:41
Beitrag drucken  
Fehlermeldungen in der WindowsUpdate.log auf den Clients? Die Datei liegt im Windows Verzeichnis.
  
Zum Seitenanfang
 
immelmann
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 16
Standort: B
Mitglied seit: 07.06.07
Geschlecht: männlich
Re: Update von Wsus 2 auf 3 - Probleme
Antwort #12 - 13.07.07 um 13:09:19
Beitrag drucken  
die 12xxx Ereignisse rühren daher, dass der Dienst "Update Services" nicht gestartet ist.

Beim Installieren von WSUS 3 kann ausgewählt werden, ob Standardport oder ein anderer, in diesem Fall 8530.
Diesen kennen aber die Clients nicht und sollten per Gruppenrichtlinie (ihr habt ja alle einen Server) bekannt gemacht werden.
Gruppenrichtlinie-Computerkonfig.-Administrative Vorlagen-Windows Komponenten-Windows Update  und dort den "internen Pfad..." bearbeiten, z.B. http://EuerServer:8530
Dann sollten die Clients den WSUS finden.

Gruß Torsten
  

Gruß Torsten
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden