Seitenindex umschalten Seiten: [1]  Thema versendenDrucken
Heißes Thema (mehr als 10 Antworten) Update von 2.0 auf 3.0 läuft nicht (Gelesen: 4580 mal)
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Update von 2.0 auf 3.0 läuft nicht
23.07.07 um 15:04:03
Beitrag drucken  
Hallo@Alle!
Will unseren WSUS 2.0 auf 3.0 upgraden. Nach Start der Installation bekomme ich die Meldung "Failed to connect to SQL Server %servername\WSUS. This Database cannot be upgraded by WSUS 3.0. Click Back to try another database configuration."
Eine andere kann ich nicht auswählen, beim Klick auf Back lande ich wieder bei der Lizenz.
Auf dem Server läuft ein SQLServer Service Manager, der den selben Servernamen zeigt wie die Meldung.
Habe alle Beiträge zum Update von 2.0 auf 3.0 hier im Forum schon durchsucht, aber nichts passendes gefunden. Kann es sein, das hier MSDE installiert ist? Bin nicht fit mit MSSQL. Kann ich mich per cmd mit der Datenbank verbinden?
Bin für jeden Tip dankbar!!

H. Stecher
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #1 - 23.07.07 um 15:53:06
Beitrag drucken  
Ist das ein Windows 2000 Server oder schon ein W2K3-Server? Ist auf dem Server ein SQL-Server 2000 installiert?
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #2 - 23.07.07 um 16:00:58
Beitrag drucken  
Hi!
Sorry, hätte ich gleich schreiben können...
Das ist ein Server 2003 mit Service pack 2; kein SQL Server, "nur" MSDE2000.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #3 - 23.07.07 um 16:05:54
Beitrag drucken  
Die MSDE ist manuell installiert worden? Welches SP hat die MSDE?
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #4 - 23.07.07 um 16:08:42
Beitrag drucken  
MSDE wurde wohl im zuge der WSUS Installation mitinstalliert; Versionsnummer ist 8.00.884
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #5 - 23.07.07 um 16:18:38
Beitrag drucken  
Ist das eine MSDE oder eine WMSDE? Und welches SP hat die Version installiert? Wurde die separat installiert oder mit dem WSUS 2.0? Ist das ein WSUS 2.0 incl. SP1?
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #6 - 23.07.07 um 16:34:47
Beitrag drucken  
Also, das Ding taucht unter Software als Microsoft SQL Server Desktop Engine (WSUS) auf mit der unten stehenden Versionsnummer. Er wurde zusammen mit dem WSUS 2.0 installiert (leider ohne irgendwas dokumentiert zu haben)
Der WSUS ist ohne Servicepack die Version 2.0.0.2340
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #7 - 23.07.07 um 17:02:03
Beitrag drucken  
Hmm, ich vermute es ist nur die MSDE, mit der das AFAIK nicht geht. Du kannst trotzdem auf WSUS 2.0 SP1 upgraden, nach einer vernünftigen Datensicherung.

Ich finde jetzt grad den Link nicht mehr, dort konnte man feststellen, ob und wenn ja welches SP installiert war. Und auch ob es die MSDE oder WMSDE ist, die auf dem Server installiert ist.

Ganz anders gefragt. Wieviele Clients/Server mit wie vielen Updates sind auf dem WSUS? Eine komplette Neuinstallation ist keine Option?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #8 - 24.07.07 um 00:20:14
Beitrag drucken  
HStecher schrieb on 23.07.07 um 15:04:03:
Will unseren WSUS 2.0 auf 3.0 upgraden. Nach Start der Installation bekomme ich die Meldung "Failed to connect to SQL Server %servername\WSUS. This Database cannot be upgraded by WSUS 3.0. Click Back to try another database configuration."


Unter welchem Konto läuft der SQL-Server? Fehlermeldung incl. EventID + Source aus dem Ereignisprotokoll?
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #9 - 24.07.07 um 08:45:58
Beitrag drucken  
Hallo!
Habe grad das SP1 für WSUS 2.0 installieren wollen. Im ersten Teil hab ich die Einstellungen und die Datenbank nicht entfernen lassen.
Der zweite Teil bricht dann ab, wenn auf die vorhandene Datenbank zugegriffen werden soll.
Die Fehlermeldung im Log sieht so aus:
2007-07-24 08:33:41  Error     CustomActions.Dll  SQL command is returning error (Error 0x80004005: Unspecified error)
Danach macht die Installation alles rückgängig und ich stehe ohne WSUS da.
Frage: Wenn ich die ganze Aktion mit einer neuen leeren Datenbank starte, kann ich die alte Datenbank dann importieren oder sonstwie zurückholen?

Besten Dank,
H. Stecher
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #10 - 24.07.07 um 08:55:11
Beitrag drucken  
Nachtrag: Habe in einer anderen Logdatei den eintrag gefunden:
Database 'SUSDB' has invalid schema.

Wie gestern schon erwähnt, hab ich keinen Plan von MSSQL, aber das klingt nicht gut.

Erwäge langsam eine komplette Neuinstallation...

Besten Dank,
H.Stecher
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #11 - 24.07.07 um 08:56:05
Beitrag drucken  
HStecher schrieb on 24.07.07 um 08:45:58:
Habe grad das SP1 für WSUS 2.0 installieren wollen. Im ersten Teil hab ich die Einstellungen und die Datenbank nicht entfernen lassen.
Der zweite Teil bricht dann ab, wenn auf die vorhandene Datenbank zugegriffen werden soll.
Die Fehlermeldung im Log sieht so aus:
2007-07-24 08:33:41  Error     CustomActions.Dll  SQL command is returning error (Error 0x80004005: Unspecified error)


Mehr steht nicht im Log? War vorher bzw. ist vielleicht noch der SUS 1.0 installiert auf diesem Server?

HStecher schrieb on 24.07.07 um 08:45:58:
Danach macht die Installation alles rückgängig und ich stehe ohne WSUS da.
Frage: Wenn ich die ganze Aktion mit einer neuen leeren Datenbank starte, kann ich die alte Datenbank dann importieren oder sonstwie zurückholen?


Die alte Datenbank sowie das Content Verzeichnis wird bestimmt nicht gelöscht. Die DB lautet SUSDB.mdf + SUSDB.ldf. Such mal danach, das wird normalerweise nicht gelöscht.

Läuft ein Virenscanner auf dem Server? Sind Ordner oder Laufwerke komprimiert?

Wenn Du den harten Weg gehen willst, dann solltest Du wirklich von vorne anfangen, alle Einträge unter Systemsteuerung > Software die mit WSUS oder SQL-Server zu tun haben unbedingt deinstallieren. Die Datenbanken und das Contentverzeichnis vorher wegsichern, geht am besten mit ntbackup.exe, und danach alles neu installieren. Die alte DB könnte man vielleicht wieder anhängen, da reichen meine Kenntnisse aber nicht aus, um dir dabei weiter zu helfen.

Backing Up Windows Server Update Services 3.0:
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Das gilt auch für den WSUS 2.0.

Wie möchtest Du nun vorgehen? Wieviele Clients hast Du am WSUS angebunden?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #12 - 24.07.07 um 08:58:49
Beitrag drucken  
HStecher schrieb on 24.07.07 um 08:55:11:
Database 'SUSDB' has invalid schema.


Hier gibts weitere Infos zum Upgrade aus WSUS 2.0 SP1: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

HStecher schrieb on 24.07.07 um 08:55:11:
Erwäge langsam eine komplette Neuinstallation...


Das wäre bestimmt keine schlechte Idee.
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #13 - 24.07.07 um 09:19:17
Beitrag drucken  
Also, um hinten anzufangen:
160 Clients hängen dran.

Die Datenbank und das Content hatte ich vor der ganzen Aktion mit ntbackup gesichert

Virenscanner ist installiert, aber inaktiv. Einmal in der Woche läuft sonntags ein scheduled scan über alle Platten.

Laufwerke sind nicht komprimiert.

SUSDB.mdf und die .ldf sind noch vorhanden; habe ich von Hand nochmal kopiert.

Im Log steht noch eine Menge mehr, aber ich wollte den ganzen Text nicht hier einfügen.

SUS 1.0 war noch nie installiert

Besten Dank!

H. Stecher 
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #14 - 24.07.07 um 09:31:15
Beitrag drucken  
HStecher schrieb on 24.07.07 um 09:19:17:
160 Clients hängen dran.


OK, und da der nächste Patchday ja noch in weiter Ferne ist, könntest Du alles vom alten WSUS rückstandsfrei deinstallieren und gleich auf den 3er upgraden und komplett neu anfangen. Das mußt Du für dich selbst entscheiden, das kann ich dir nicht abnehmen.

HStecher schrieb on 24.07.07 um 09:19:17:
Die Datenbank und das Content hatte ich vor der ganzen Aktion mit ntbackup gesichert


Lobenswert. Zwinkernd

HStecher schrieb on 24.07.07 um 09:19:17:
Virenscanner ist installiert, aber inaktiv. Einmal in der Woche läuft sonntags ein scheduled scan über alle Platten.


Dann deinstallier ich mal rückstandsfrei. Die sind IMMER aktiv, Dienste laufen und vermutlich hat der Virenscanner auch die WSUS-DB geschrottet. Auf eine SQL-Server-DB sollte ein Virenscanner keinen Zugriff haben. Welche NTFS-Rechte sind auf dem Verzeichnis, in der die SUSDB liegt?

HStecher schrieb on 24.07.07 um 09:19:17:
Laufwerke sind nicht komprimiert.


OK.

HStecher schrieb on 24.07.07 um 09:19:17:
SUSDB.mdf und die .ldf sind noch vorhanden; habe ich von Hand nochmal kopiert.


Gut.

HStecher schrieb on 24.07.07 um 09:19:17:
Im Log steht noch eine Menge mehr, aber ich wollte den ganzen Text nicht hier einfügen.


Du kannst hier auch TXT-Dateien anhängen oder irgendwo online stellen.

HStecher schrieb on 24.07.07 um 09:19:17:
SUS 1.0 war noch nie installiert


OK, das ist gut.

So, wie möchtest Du nun vorgehen?
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #15 - 24.07.07 um 09:46:07
Beitrag drucken  
Denke, es ist das beste, alles zu deinstallieren und mit 3.0 neu anzufangen. Wäre natürlich klasse, die alte Datenbank importieren zu können...

Was muss ich bei der Deinstallation alles beachten?

Sollte ich den Mcafee auch deinstallieren? Oder reicht es, den Scanner deaktiviert zu lassen und die WSUS Ordner vom Scannen auszuschliessen?

Besten Dank!

H. Stecher
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #16 - 24.07.07 um 09:59:41
Beitrag drucken  
HStecher schrieb on 24.07.07 um 09:46:07:
Denke, es ist das beste, alles zu deinstallieren und mit 3.0 neu anzufangen. Wäre natürlich klasse, die alte Datenbank importieren zu können...


Das hab noch nie so in der Art machen dürfen/können. Ich weiß nicht ob die alte DB mit Windows Internal Database kompatibel ist und wie eine Übernahme/importieren funktionier würde. Wenn dann, würde ich das auf einer virtuellen Maschine testen.

HStecher schrieb on 24.07.07 um 09:46:07:
Was muss ich bei der Deinstallation alles beachten?

Sollte ich den Mcafee auch deinstallieren? Oder reicht es, den Scanner deaktiviert zu lassen und die WSUS Ordner vom Scannen auszuschliessen?


Deinstalliere den Mcafee *RÜCKSTANDSFREI*, alle Virenscanner machen da vermutlich Probleme.

Deinstalliere den WSUS auch via Systemsteuerung > Software, möglicherweise wirst Du gefragt, ob Du das Content Verzeichnis und die DB behalten möchtest, Du kannst ja mal JA sagen. Ebenfalls via Software den Eintrag für den SQL-Server so deinstallieren. Neustart. .Net Framework 2.0 + die MMC 3.0 und den ReportViewer 2005 incl. SP1 auf dem Server installieren. Diese Komponenten benötigst Du auch auf einem administrativen Client.

Wenn soweit alles geklappt hat und Du die 1. Synchronisation durch hast, Gruppen anlegen und warten bis die Clients kommen. Hast Du XPSP2 im Einsatz oder noch W2KSP4? Verteilst Du Office Updates auch via WSUS?
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #17 - 24.07.07 um 10:42:49
Beitrag drucken  
Nochmal von hinten:
Office Updates werden nicht verteilt

Habe noch ca. 20 W2K Clients, rest ist XPSP2.

Die Einstellungen auf den Clients sollten nicht geändert werden müssen, solange ich den Server nicht umbenenne, oder? Die Einstellungen werden per wuau.adm gemacht (Richtlinien für lokaler Computer)

Besten Dank,

H. Stecher
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #18 - 24.07.07 um 10:53:54
Beitrag drucken  
HStecher schrieb on 24.07.07 um 10:42:49:
Habe noch ca. 20 W2K Clients, rest ist XPSP2.


OK, ich hab wegen der Updates nach dem SP2 für XP und in dem Fall auch für die Updates für W2K nach dem SP4 gefragt. Das was zeitlich davor ist, brauchst Du bei einer Neuinstallation vom WSUS nicht neu zum installieren freizugeben.

HStecher schrieb on 24.07.07 um 10:42:49:
Die Einstellungen auf den Clients sollten nicht geändert werden müssen, solange ich den Server nicht umbenenne, oder? Die Einstellungen werden per wuau.adm gemacht (Richtlinien für lokaler Computer)


Nein, brauchst Du nicht. Das Ereignisprotokoll auf den Clients wird Fehlermeldungen auswerfen und die WindowsUpdate.log hat dann auch sehr viele Fehler.

Hmm, Du hast keine Domain? Turnschuhadministration?
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #19 - 24.07.07 um 11:13:06
Beitrag drucken  
Neuinstallation läuft....
Habe Spannung im Herzen...
Melde mich wieder
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #20 - 24.07.07 um 11:22:05
Beitrag drucken  
HStecher schrieb on 24.07.07 um 11:13:06:
Neuinstallation läuft....
Habe Spannung im Herzen...
Melde mich wieder


Das merkt man. Zwinkernd Dokumentierst Du bitte mit und postest hier den Ablauf etc.? Danke.
  
Zum Seitenanfang
 
HStecher
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 12
Standort: Iserlohn
Mitglied seit: 23.07.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #21 - 24.07.07 um 13:33:35
Beitrag drucken  
Also...
1. Habe den ganzen WSUS Ordner in einen "Sicher" Ordner kopiert
2. WSUS und MSDE/SQL deinstalliert
3. McAfee deinstalliert
4. Aus der Registry alles von WSUS/SQL/McAfee entfernt (vorher die    Einträge exportiert!)
5. Installation vom WSUS3.0 gestartet, die alten Pfade wieder eingetragen
6. Config Wizard ausgeführt -> Erfolg!
7. Erste Synchronisation -> Erfolg!

Im Moment tröpfeln so langsam die Clients ein und werden von Hand in die von mir erstellten Gruppen XP und W2K verschoben

Was mich wundert: ich habe im ConfigWizard angegeben, nur SecurityUpdates für W2K und XP hben zu wollen. Nach der Synch sind nun 550 Updates aus allen möglichen Kategorien zum Auswählen da. Also auch ServicePacks, Updates für Office, Viewer usw.
Die alle abzulehnen ist scheinbar ein langwieriger Job...
Hat da jmd vielleicht einen Tip?

Besten Dank für die Hilfe!

H. Stecher
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Update von 2.0 auf 3.0 läuft nicht
Antwort #22 - 24.07.07 um 13:59:49
Beitrag drucken  
HStecher schrieb on 24.07.07 um 13:33:35:
Was mich wundert: ich habe im ConfigWizard angegeben, nur SecurityUpdates für W2K und XP hben zu wollen. Nach der Synch sind nun 550 Updates aus allen möglichen Kategorien zum Auswählen da. Also auch ServicePacks, Updates für Office, Viewer usw.
Die alle abzulehnen ist scheinbar ein langwieriger Job...


Schau mal in den Optionen welche Klassifizierungen angehakt sind.

Danke für die Doku und viel Erfolg weiterhin mit dem WSUS. Zwinkernd
  
Zum Seitenanfang
 
Seitenindex umschalten Seiten: [1] 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden