Seitenindex umschalten Seiten: 1 [2] 3  Thema versendenDrucken
Sehr heißes Thema (mehr als 25 Antworten) Clients holen sich keine Updates (Gelesen: 20988 mal)
prinzeso
WSUS Junior Member
*
Offline


Mmmhhhh, donuts!

Beiträge: 33
Standort: Bad Waldsee
Mitglied seit: 29.06.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #15 - 31.07.07 um 09:53:40
Beitrag drucken  
Kann jemand mit dieser Fehlermeldung was anfangen:

2007-07-23      09:10:16:297       880      ca8      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:10:37:227       880      504      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:10:58:267       880      d80      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:11:19:287       880      ca8      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:11:40:316       880      e20      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:12:01:256       880      ca8      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:12:22:276       880      504      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:12:43:306       880      e20      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
2007-07-23      09:13:04:245       880      ca8      DnldMgr      Error 0x80072efd occurred while downloading update; notifying dependent calls.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #16 - 31.07.07 um 10:51:38
Beitrag drucken  
Na klar, auf wsus.de gibts Fehlercodes:
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). > 0x80072efd führt zu:
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
prinzeso
WSUS Junior Member
*
Offline


Mmmhhhh, donuts!

Beiträge: 33
Standort: Bad Waldsee
Mitglied seit: 29.06.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #17 - 31.07.07 um 11:29:32
Beitrag drucken  
Der Microsoft Artikel behandelt aber doch gar nicht das Thema WSUS sondern nur, wenn ich auf die Update-Seite von MS möchte, oder?

Wie sieht die Problemlösung in diesem Fall dann aus? Firewalländerungen machen hier doch keinen Sinn, oder?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #18 - 31.07.07 um 12:11:23
Beitrag drucken  
Vorm Prinzip her hast Du Recht, aber Du bekommst nunmal diese Fehlermeldung, und einen weiteren Artikel gibt es nicht dazu.

Hast Du die Empfehlung für Anwender in Unternehmensnetzwerken gelesen?
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
prinzeso
WSUS Junior Member
*
Offline


Mmmhhhh, donuts!

Beiträge: 33
Standort: Bad Waldsee
Mitglied seit: 29.06.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #19 - 31.07.07 um 13:59:07
Beitrag drucken  
Habe das Problem gelöst. Das Update funktioniert nun, nachdem ich folgendes gemacht habe:

- Dienst für automatische Updates gestoppt
- Ordner C:\Windows\SoftwareDistribution gelöscht
- Dienst für automatische Updates gestartet
- per WSUS_detect_now_2.0_ger.exe neue ID vergeben

Allerdings habe ich all das als Administrator gemacht. Als User (trotz lokaler Adminrechte) hat dieses Vorgehen nicht funktioniert.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #20 - 31.07.07 um 14:07:33
Beitrag drucken  
Na siehste, geht doch. Zwinkernd Hmm, daß Du das als lokaler Admin nicht machen konntest, deutet auf gefummelte Rechte hin. In den Eigenschaften der Deinste, wer steht da als User drin? Im Reiter Anmelden zu finden.

EDIT: Oder der User hat doch keine lokalen Adminrechte, sondern evtl. nur Hauptbenutzerrechte. Das wäre aber auch schon zu viel an Rechten.
  
Zum Seitenanfang
 
prinzeso
WSUS Junior Member
*
Offline


Mmmhhhh, donuts!

Beiträge: 33
Standort: Bad Waldsee
Mitglied seit: 29.06.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #21 - 31.07.07 um 14:14:00
Beitrag drucken  
Da steht lokales Systemkonto drin.

Ich schau mal, was beim nächsten Patch day passiert. Vielleicht funktioniert es jetzt reibungslos.

Vielen Dank für eure Hilfe.
  
Zum Seitenanfang
 
vita
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 10
Standort: Leverkusen
Mitglied seit: 19.07.07
Re: Clients holen sich keine Updates
Antwort #22 - 02.08.07 um 14:21:59
Beitrag drucken  
Hallo, ich habe ein ähnliches Problem. Habe nun von WSUS 2.0 auf 3.0 aufgerüstet. Installation und Einrichtung lief problemlos, da alle Einstellungen schon vorkonfiguriert bzw vom 2.0er übernommen wurden.

Nun wollen meine Testclients aber nicht updaten seit ich den 3.0er drauf habe. Habe schon so ziemlich alles probiert was hier im Thread bereits gesagt wurde, aber immernoch das gleiche Problem.

Aus der WindowsUpdate.log werde ich auch nicht richtig schlau. Ganz am Anfang steht ein Fehlercode, den ich auf der WSUS.de Homepage nicht finden konnte und auf der Microsoft Seite bin ich aus der Erklärung leider nicht schlau geworden.
Ich poste die WindowsUpdate.log einfach mal:
  
Zum Seitenanfang
 
vita
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 10
Standort: Leverkusen
Mitglied seit: 19.07.07
Re: Clients holen sich keine Updates
Antwort #23 - 02.08.07 um 14:22:34
Beitrag drucken  
2007-08-02      13:58:13:921      1088      670      AU      ###########  AU: Uninitializing Automatic Updates  ###########
2007-08-02      13:58:16:421      1088      b38      Agent        * WARNING: Exit code = 0x8024000B
2007-08-02      13:58:16:421      1088      b38      Agent      *********
2007-08-02      13:58:16:421      1088      b38      Agent      **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2007-08-02      13:58:16:421      1088      b38      Agent      *************
2007-08-02      13:58:16:421      1088      b38      Agent      WARNING: WU client failed Searching for update with error 0x8024000b
2007-08-02      13:58:16:452      1088      670      Report      REPORT EVENT: {AB4CC10A-74D8-4FD9-AF54-8A9089BC739A}      2007-08-02 13:57:46:941+0200      1      202      102      {00000000-0000-0000-0000-000000000000}      0      0      AutomaticUpdates      Success      Content Install      Reboot completed.
2007-08-02      13:58:16:452      1088      670      Service      *********
2007-08-02      13:58:16:452      1088      670      Service      **  END  **  Service: Service exit [Exit code = 0x240001]
2007-08-02      13:58:16:452      1088      670      Service      *************
2007-08-02      13:58:25:920      1088      9a0      Misc      ===========  Logging initialized (build: 7.0.6000.374, tz: +0200)  ===========
2007-08-02      13:58:25:920      1088      9a0      Misc        = Process: C:\WINDOWS\System32\svchost.exe
2007-08-02      13:58:25:920      1088      9a0      Misc        = Module: C:\WINDOWS\system32\wuaueng.dll
2007-08-02      13:58:25:920      1088      9a0      Service      *************
2007-08-02      13:58:25:920      1088      9a0      Service      ** START **  Service: Service startup
2007-08-02      13:58:25:920      1088      9a0      Service      *********
2007-08-02      13:58:25:920      1088      9a0      Agent        * WU client version 7.0.6000.374
2007-08-02      13:58:25:920      1088      9a0      Agent        * Base directory: C:\WINDOWS\SoftwareDistribution
2007-08-02      13:58:25:920      1088      9a0      Agent        * Access type: No proxy
2007-08-02      13:58:25:920      1088      9a0      Agent        * Network state: Connected
2007-08-02      13:58:42:214      1088      95c      Agent      ***********  Agent: Initializing Windows Update Agent  ***********
2007-08-02      13:58:42:214      1088      95c      Agent      ***********  Agent: Initializing global settings cache  ***********
2007-08-02      13:58:42:214      1088      95c      Agent        * WSUS server: http://server-test-01
2007-08-02      13:58:42:214      1088      95c      Agent        * WSUS status server: http://server-test-01
2007-08-02      13:58:42:214      1088      95c      Agent        * Target group: Gruppe_2
2007-08-02      13:58:42:214      1088      95c      Agent        * Windows Update access disabled: No
2007-08-02      13:58:42:558      1088      9a0      Report      ***********  Report: Initializing static reporting data  ***********
2007-08-02      13:58:42:558      1088      9a0      Report        * OS Version = 5.1.2600.2.0.65792
2007-08-02      13:58:42:698      1088      9a0      Report        * Computer Brand = VMware, Inc.
2007-08-02      13:58:42:698      1088      9a0      Report        * Computer Model = VMware Virtual Platform
2007-08-02      13:58:42:714      1088      9a0      Report        * Bios Revision = 6.00
2007-08-02      13:58:42:714      1088      9a0      Report        * Bios Name = PhoenixBIOS 4.0 Release 6.0    
2007-08-02      13:58:42:714      1088      9a0      Report        * Bios Release Date = 2006-04-17T00:00:00
2007-08-02      13:58:42:714      1088      9a0      Report        * Locale ID = 1031
2007-08-02      13:58:45:151      1472      acc      Misc      ===========  Logging initialized (build: 7.0.6000.374, tz: +0200)  ===========
2007-08-02      13:58:45:151      1472      acc      Misc        = Process: C:\WINDOWS\system32\wuauclt.exe
2007-08-02      13:58:45:151      1472      acc      Misc        = Module: C:\WINDOWS\system32\wuaueng.dll
2007-08-02      13:58:45:151      1472      acc      DtaStor      Default service for AU is {00000000-0000-0000-0000-000000000000}
2007-08-02      13:58:45:229      1472      acc      DtaStor      Default service for AU is {9482F4B4-E343-43B6-B170-9A65BC822C77}
2007-08-02      13:58:45:229      1088      95c      Agent      WARNING: Failed to read the service id for re-registration 0x80070002
2007-08-02      13:58:45:229      1088      95c      Agent      WARNING: Missing service entry in the backup data store; cleaning up
2007-08-02      13:58:45:245      1088      95c      DnldMgr      Download manager restoring 0 downloads
2007-08-02      13:58:45:245      1088      95c      AU      ###########  AU: Initializing Automatic Updates  ###########
2007-08-02      13:58:45:245      1088      95c      AU        # WSUS server: http://server-test-01
2007-08-02      13:58:45:245      1088      95c      AU        # Detection frequency: 4
2007-08-02      13:58:45:245      1088      95c      AU        # Target group: Gruppe_2
2007-08-02      13:58:45:245      1088      95c      AU        # Approval type: Scheduled (Policy)
2007-08-02      13:58:45:245      1088      95c      AU        # Scheduled install day/time: Every day at 16:00
2007-08-02      13:58:45:245      1088      95c      AU        # Auto-install minor updates: Yes (Policy)
2007-08-02      13:58:45:276      1088      95c      AU      Setting AU scheduled install time to 2007-08-02 14:00:00
2007-08-02      13:58:45:276      1088      95c      AU      AU finished delayed initialization
2007-08-02      13:58:45:276      1088      9a0      AU      #############
2007-08-02      13:58:45:276      1088      9a0      AU      ## START ##  AU: Search for updates
2007-08-02      13:58:45:276      1088      9a0      AU      #########
2007-08-02      13:58:45:276      1088      9a0      AU      <<## SUBMITTED ## AU: Search for updates [CallId = {50D97F7A-47B3-47DE-A860-E6F981B88047}]
2007-08-02      13:58:45:276      1088      e18      Agent      *************
2007-08-02      13:58:45:276      1088      e18      Agent      ** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
2007-08-02      13:58:45:276      1088      e18      Agent      *********
2007-08-02      13:58:45:276      1088      e18      Agent        * Online = No; Ignore download priority = No
2007-08-02      13:58:45:276      1088      e18      Agent        * Criteria = "IsHidden=0 and IsInstalled=0 and DeploymentAction='Installation' and IsAssigned=1 or IsHidden=0 and IsPresent=1 and DeploymentAction='Uninstallation' and IsAssigned=1 or IsHidden=0 and IsInstalled=1 and DeploymentAction='Installation' and IsAssigned=1 and RebootRequired=1 or IsHidden=0 and IsInstalled=0 and DeploymentAction='Uninstallation' and IsAssigned=1 and RebootRequired=1"
2007-08-02      13:58:45:276      1088      e18      Agent        * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}
2007-08-02      13:58:45:276      1088      95c      AU      Triggering AU detection through DetectNow API
2007-08-02      13:58:45:276      1088      95c      AU      Will do the detection after current detection completes
2007-08-02      13:58:45:510      1088      e18      Agent        * Found 0 updates and 0 categories in search; evaluated appl. rules of 0 out of 0 deployed entities
2007-08-02      13:58:45:526      1088      e18      Agent      *********
2007-08-02      13:58:45:526      1088      e18      Agent      **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2007-08-02      13:58:45:526      1088      e18      Agent      *************
2007-08-02      13:58:45:526      1088      424      AU      >>##  RESUMED  ## AU: Search for updates [CallId = {50D97F7A-47B3-47DE-A860-E6F981B88047}]
2007-08-02      13:58:45:526      1088      424      AU        # 0 updates detected
2007-08-02      13:58:45:526      1088      424      AU      #########
2007-08-02      13:58:45:526      1088      424      AU      ##  END  ##  AU: Search for updates [CallId = {50D97F7A-47B3-47DE-A860-E6F981B88047}]
2007-08-02      13:58:45:526      1088      424      AU      #############
2007-08-02      13:58:45:526      1088      424      AU      Setting AU scheduled install time to 2007-08-02 14:00:00
2007-08-02      13:58:45:526      1088      9a0      AU      #############
2007-08-02      13:58:45:526      1088      9a0      AU      ## START ##  AU: Search for updates
2007-08-02      13:58:45:526      1088      9a0      AU      #########
2007-08-02      13:58:45:542      1088      9a0      AU      <<## SUBMITTED ## AU: Search for updates [CallId = {E5E1503F-65C0-41E9-BEC4-76E82A458E43}]
2007-08-02      13:58:45:542      1088      e18      Agent      *************
2007-08-02      13:58:45:542      1088      e18      Agent      ** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
2007-08-02      13:58:45:542      1088      e18      Agent      *********
2007-08-02      13:58:45:542      1088      e18      Agent        * Online = Yes; Ignore download priority = No
2007-08-02      13:58:45:542      1088      e18      Agent        * Criteria = "IsHidden=0 and IsInstalled=0 and DeploymentAction='Installation' and IsAssigned=1 or IsHidden=0 and IsPresent=1 and DeploymentAction='Uninstallation' and IsAssigned=1 or IsHidden=0 and IsInstalled=1 and DeploymentAction='Installation' and IsAssigned=1 and RebootRequired=1 or IsHidden=0 and IsInstalled=0 and DeploymentAction='Uninstallation' and IsAssigned=1 and RebootRequired=1"
2007-08-02      13:58:45:542      1088      e18      Agent        * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}
2007-08-02      13:58:59:337      1088      e18      Misc      Validating signature for C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wuident.cab:
2007-08-02      13:58:59:524      1088      e18      Misc       Microsoft signed: Yes
2007-08-02      13:58:59:711      1088      e18      Misc      Validating signature for C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wsus3setup.cab:
2007-08-02      13:58:59:727      1088      e18      Misc       Microsoft signed: Yes
2007-08-02      13:58:59:758      1088      e18      Setup      ***********  Setup: Checking whether self-update is required  ***********
2007-08-02      13:58:59:774      1088      e18      Setup        * Inf file: C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wsus3setup.inf
2007-08-02      13:58:59:790      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\cdm.dll: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:790      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wuapi.dll: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:805      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wuapi.dll.mui: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:805      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wuauclt.exe: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:805      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wuaucpl.cpl: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:805      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wuaucpl.cpl.mui: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:821      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wuaueng.dll: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:821      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wuaueng.dll.mui: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:821      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wucltui.dll: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:821      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wucltui.dll.mui: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:821      1088      e18      Setup      Update NOT required for C:\WINDOWS\system32\wups.dll: target version = 7.0.6000.374, required version = 7.0.6000.374
2007-08-02      13:58:59:821      10
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #24 - 02.08.07 um 14:44:54
Beitrag drucken  
Mach doch bitte das nächste Mal einen eigenen Thread dafür auf. Danke. Zwinkernd

Was genau hast Du schon probiert? Melden sich die Clients denn überhaupt im WSUS? Installiere auf dem virtuellen Testclient doch mal den aktuellen WU-Agent mit der Option /wuforce drüber.

Und lösch die 3 SIDs auf dem Client: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Laufen die 3 erforderlichen Dienste? Automatische Updates + BITS + Kryptografiedienst?

In diesem Thread gibts ganz unten einen Lösungsweg: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Sag bitte Bescheid ob und was genau dann zum Erfolg geführt hat. Bitte einzeln die Schritte probieren. Danke. Zwinkernd
  
Zum Seitenanfang
 
vita
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 10
Standort: Leverkusen
Mitglied seit: 19.07.07
Re: Clients holen sich keine Updates
Antwort #25 - 03.08.07 um 13:41:01
Beitrag drucken  
Script habe ich ausgeführt und es war auch allem Anschein nach erfolgreich.
Was mir bei dem Client, dessen Windowsupdate.log ich oben gepostet habe aufgefallen ist, ist dass er sich eine falsche Gruppenrichtlinie zieht. Es soll die angewendet werden, die ich lokal eingestellt habe, jedoch zieht er die Domänenrichtlinie der lokalen vor, was ihn dazu zwingt zu einem anderen WSUS Server zu connecten.
Um das Problem lösen zu können muss ich allerdings auf meinen Chef warten (Urlaub), da ich darauf leider keinen Zugriff habe.

Ein anderer Client verwendet aber die richtige Richtlinie und versucht auch zum richtigen WSUS Server zu connecten. Da habe ich keine Ahnung wie ich weiter vorgehen soll. Dieser hatte auch mehrere SID's gehabt.
Habe das Script, was du gepostet hast ausgeführt und danach die "WSUS_detect_now_2.0_ger.exe" ausgeführt, wobei das glaube ich doppelt gemoppelt war.
Jedenfalls nach der Ausführung dieses Tools kam eine neue Fehlermeldung, nämlich:
WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0x80004015

Das was hier ( (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).) angesprochen wird ist wohl auch nicht das Problem, da das Skript fehlerfrei ausgeführt wurde.

Lediglich eine Fehlermeldung stimmt mit der überein, die S1!c3r in dem Forum gepostet hat, nämlich diese:
WARNING: Failed to read the service id for re-registration 0x80070002

Zwar habe ich diesen Fehlercode über den Link auf der WSUS.de Homepage finden können, jedoch waren die Einstellungen, die man da machen sollte bei mir schon eingestellt. Habe dennoch alles erneuert.

Insgesamt habe ich folgende Fehlermeldungen:
WARNING: Failed to read the service id for re-registration 0x80070002
WARNING: Missing service entry in the backup data store; cleaning up
WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0x80004015
WARNING: Cached cookie has expired or new PID is available

Zusätzlich sagt die WindowsUpdate.log (glaube ich), dass die Maschine keine Updates benötigt bzw. keine gefunden hat, der Server allerdings behauptet das Gegenteil.

Hier noch meine WindowsUpdate.log
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). WindowsUpdate1_001.log (Anhang gelöscht)
Zum Seitenanfang
 
vita
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 10
Standort: Leverkusen
Mitglied seit: 19.07.07
Re: Clients holen sich keine Updates
Antwort #26 - 03.08.07 um 14:19:03
Beitrag drucken  
Ach ja, was mir gerade noch aufgefallen ist:

Muss einer der 3 benötigten Dienste "BITS" heißen, oder steht da "Intelligenter Hintergrundübertragungsdienst"?

Das ist mir gerade aufgefallen, nachdem ich dieses Skript ausgeführt hatte:
Code
@echo off
Echo Diese Batchdatei setzt Service Object Security für WUAUSERV & BITS.

@echo off
sc sdset bits "D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)" >>C:\SetServiceObjectSecurity.log

sc sdset wuauserv "D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)" >>C:\SetServiceObjectSecurity.log

@echo off
Echo Oeffnen sie die Datei services.msc und ueberpruefen sie ob die Dienste gestartet sind.
Pause 



Daraufhin spuckt er mir die folgende meldung aus:
Der Befehl "Bits" ist entweder falsch geschrieben oder konnte nicht gefunden werden.
Öffnen sie die Datei services.msc und überprüfen sie ob die Dienste gestartet sind.

Nachdem ich das gemacht habe ist mir aufgefallen, dass ich keinen Dienst namens "BITS" habe, sondern nur den Intelligenten Hintergrundübertragungsdienst. Aber das sollte doch eigentlich das gleiche sein, oder? Zumindest von der englischen Übersetzung her :/
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients holen sich keine Updates
Antwort #27 - 03.08.07 um 14:21:39
Beitrag drucken  
vita schrieb on 03.08.07 um 13:41:01:
Script habe ich ausgeführt und es war auch allem Anschein nach erfolgreich. Was mir bei dem Client, dessen Windowsupdate.log ich oben gepostet habe aufgefallen ist, ist dass er sich eine falsche Gruppenrichtlinie zieht. Es soll die angewendet werden, die ich lokal eingestellt habe, jedoch zieht er die Domänenrichtlinie der lokalen vor, was ihn dazu zwingt zu einem anderen WSUS Server zu connecten.


Das ist aber ganz normal. Eine Domain GPO hat immer Vorrang vor lokalen Policies. Beispiel: Ein Anwender ist warum auch immer, lokaler Admin und deaktiviert einen wichtigen Dienst via gpedit.msc. Du als DomaAdmin möchtest das der Dienst gestartet ist, also wird er auch wieder gestartet.

Sorry, aber ich vermute Du solltest dir schleunigst Kenntnisse in Bezug auf GPOs und AD aneignen. Das kann ansonsten böse ins Auge gehen.

vita schrieb on 03.08.07 um 13:41:01:
Um das Problem lösen zu können muss ich allerdings auf meinen Chef warten (Urlaub), da ich darauf leider keinen Zugriff habe.


Dann entferne den Client aus der Domain und schon zieht die lokale Einstellung. Hast Du keine Zugriff aufs AD? Nachdem was Du weiter oben geschrieben hast, ist das glaub auch besser so.

vita schrieb on 03.08.07 um 13:41:01:
Ein anderer Client verwendet aber die richtige Richtlinie und versucht auch zum richtigen WSUS Server zu connecten. Da habe ich keine Ahnung wie ich weiter vorgehen soll. Dieser hatte auch mehrere SID's gehabt.
Habe das Script, was du gepostet hast ausgeführt und danach die "WSUS_detect_now_2.0_ger.exe" ausgeführt, wobei das glaube ich doppelt gemoppelt war.
Jedenfalls nach der Ausführung dieses Tools kam eine neue Fehlermeldung, nämlich:
WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0x80004015


Hier gibts doch eine Lösung: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Sind die erforderlichen Dienste gestartet? Das hab ich schon im letzten Posting gefragt.

vita schrieb on 03.08.07 um 13:41:01:
Insgesamt habe ich folgende Fehlermeldungen:
WARNING: Failed to read the service id for re-registration 0x80070002
WARNING: Missing service entry in the backup data store; cleaning up
WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0x80004015
WARNING: Cached cookie has expired or new PID is available


Ist das jetzt ein anderer Client? Können wir uns darauf einigen, einen nach dem anderen zu machen? Lösch auf diesem Client auch die SIDs und kontrolliere ob die Dienste laufen!
  
Zum Seitenanfang
 
vita
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 10
Standort: Leverkusen
Mitglied seit: 19.07.07
Re: Clients holen sich keine Updates
Antwort #28 - 06.08.07 um 10:26:27
Beitrag drucken  
Quote:
Sorry, aber ich vermute Du solltest dir schleunigst Kenntnisse in Bezug auf GPOs und AD aneignen. Das kann ansonsten böse ins Auge gehen.

Da hast du recht Zunge. Ich stehe gerade am Beginn meiner Ausbildung und habe mich vorher im privaten Rahmen nie mit Richtlinien, Domänen und AD beschäftigt. Ich muss das aber so oder so irgendwie lernen, weil das in meinen Ausbildungszielen mit drinsteckt, allerdings erst zu nem späteren Zeitpunkt.

Quote:
Nachdem was Du weiter oben geschrieben hast, ist das glaub auch besser so.

Ja, ist es auch... Aber ich hab generell keine ausreichenden Rechte mich auf irgendwelche Server zu verbinden, weil Azubi halt Smiley

Quote:
Hier gibts doch eine Lösung: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Sind die erforderlichen Dienste gestartet? Das hab ich schon im letzten Posting gefragt.

Alle 3 Dienste sind gestartet, jedoch wie ich schon im Posting davor gesagt habe: Ich habe keinen Dienst namens BITS. Es gibt einen Dienst der sich "Intelligenter Hintergrundübertragungsdienst" nennt. Ich denke mal das ist der Dienst, denn wenn ich versuche BITS auf dem Client zu installieren, sagt er mir, dass es bereits installiert ist.
Wenn ich versuche das Script, was hinter dem Link steckt auszuführen, spuckt er mir folgende Fehlermeldung aus:

Der Befehl "Bits" ist entweder falsch geschrieben oder konnte nicht gefunden werden.
Öffnen sie die Datei services.msc und überprüfen sie ob die Dienste gestartet sind.

Habe auch mal den "Automatische Updates" Dienst beobachtet, während der wuauclt-Prozess lief. Ist aber nicht abgestürzt, oder zumindest wurde es nicht angezeigt. Ich musste den Dienst aber nachher auch nicht neustarten.

Quote:
Ist das jetzt ein anderer Client? Können wir uns darauf einigen, einen nach dem anderen zu machen? Lösch auf diesem Client auch die SIDs und kontrolliere ob die Dienste laufen!

Ja, das ist ein anderer Client. Lass uns doch dann bitte erst diesen hier machen, denn beim Anderen muss ich erst wie gesagt auf meinen Chef warten, damit er mir die Richtlinie da rausnimmt... Der is aber momentan leider nicht da.
  
Zum Seitenanfang
 
vita
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 10
Standort: Leverkusen
Mitglied seit: 19.07.07
Re: Clients holen sich keine Updates
Antwort #29 - 06.08.07 um 12:55:34
Beitrag drucken  
So, einen Schritt weiter bin ich nun. Durch das Löschen der SID's (musste es manuell aus der Registry entfernen, hab da vorher noch nie nachgeschaut) haben sich die Fehlermeldungen auf eine reduziert, die wie folgt lautet:

WARNING: Cached cookie has expired or new PID is available

Zudem habe ich immernoch das Problem, dass der Client sagt, er braucht keine Updates, bzw es wurden keine Updates gefunden, aber WSUS sagt was anderes. Wer hat Recht? Ich habe die Updates alle nochmal declined und dann wieder freigegeben und den Installationszeitpunkt auf gestern gelegt, sodass der Client das Update eigentlich sofort erkennen, runterladen und installieren müsste. Tat er aber nicht, nachdem ich die wuauclt /detectnow ausgeführt habe.

Die komplette WindowsUpdate.log packe ich nochmal als Anhang in den Post mit rein.
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). WindowsUpdate_001.log (Anhang gelöscht)
Zum Seitenanfang
 
Seitenindex umschalten Seiten: 1 [2] 3 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden