Seitenindex umschalten Seiten: 1 [2] 3 4  Thema versendenDrucken
Sehr heißes Thema (mehr als 25 Antworten) Clients finden keine Verbindung (Gelesen: 8946 mal)
NorbertFe
Microsoft MVP
*****
Offline


Ausgezeichnet!

Beiträge: 73
Standort: Potsdam
Mitglied seit: 30.10.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #15 - 31.10.07 um 00:40:01
Beitrag drucken  
Sunny schrieb on 31.10.07 um 00:38:32:
Welcom back in real World.


Du schaust eindeutig zu oft Matrix. Zwinkernd

Bye
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #16 - 31.10.07 um 00:41:28
Beitrag drucken  
NorbertFe schrieb on 31.10.07 um 00:40:01:
Du schaust eindeutig zu oft Matrix. Zwinkernd



Nö, noch nie gesehen. Durchgedreht
  
Zum Seitenanfang
 
NorbertFe
Microsoft MVP
*****
Offline


Ausgezeichnet!

Beiträge: 73
Standort: Potsdam
Mitglied seit: 30.10.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #17 - 31.10.07 um 00:55:13
Beitrag drucken  
Sunny schrieb on 31.10.07 um 00:41:28:
Nö, noch nie gesehen. Durchgedreht


Hmm, dann sollteste den auch gleich noch auf deine Videoausleihliste setzen. Zwinkernd
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #18 - 31.10.07 um 01:02:40
Beitrag drucken  
NorbertFe schrieb on 31.10.07 um 00:55:13:
Hmm, dann sollteste den auch gleich noch auf deine Videoausleihliste setzen. Zwinkernd


Jepp, die wird richtig lang. Bloß gut das der Winter kommt. Durchgedreht
  
Zum Seitenanfang
 
derhoeppi
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 27
Standort: Berlin
Mitglied seit: 23.10.07
Re: Clients finden keine Verbindung
Antwort #19 - 31.10.07 um 07:11:00
Beitrag drucken  
Hey Sunny,
danke für den Tip mit den Optionen --> Computer. Da lag der Fehler - das er genau die falsche Option ausgewählt hat.

Mfg
derhoeppi

Sunny ich habe mal noch eine Frage. Mein Script führt ja eine Veränderung dr Registry durch und ruft dann die wuauclt.exe auf. Problem ist nur, dass er sich dann noch nicht mit dem WSUS verbindet. Nutze ich jedoch das Tool Connect2WSUS funktioniert es ohne Probleme. Meine Frage ist nun, ob der Dienst der die wuauclt.exe verwaltet vorher beendet und nach der Änderung in der Registry neugestartet werden muss? Wenn ja wird die wuaucle.exe mit dem beenden des Dienstes Automatische Updates beendet oder verbirgt sich hinter der exe ein anderer Dienst?

PS: Was muss eigentlich auf einer WinXP pro Version (blanke Installation ohne Updates und Patches) installiert sein, damit es sich zu einem WSUS verbindet?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #20 - 31.10.07 um 12:28:43
Beitrag drucken  
derhoeppi schrieb on 31.10.07 um 07:11:00:
danke für den Tip mit den Optionen --> Computer. Da lag der Fehler - das er genau die falsche Option ausgewählt hat.


Sag ich doch. Danke für die Rückmeldung. Zwinkernd

derhoeppi schrieb on 31.10.07 um 07:11:00:
Sunny ich habe mal noch eine Frage. Mein Script führt ja eine Veränderung dr Registry durch und ruft dann die wuauclt.exe auf. Problem ist nur, dass er sich dann noch nicht mit dem WSUS verbindet.


Dann zeig doch mal das komplette Script. Evtl. als TXT einfach an ein Posting anhängen.


derhoeppi schrieb on 31.10.07 um 07:11:00:
Nutze ich jedoch das Tool Connect2WSUS funktioniert es ohne Probleme.


Super das es funktioniert. Zwinkernd

derhoeppi schrieb on 31.10.07 um 07:11:00:
Meine Frage ist nun, ob der Dienst der die wuauclt.exe verwaltet vorher beendet und nach der Änderung in der Registry neugestartet werden muss? Wenn ja wird die wuaucle.exe mit dem beenden des Dienstes Automatische Updates beendet oder verbirgt sich hinter der exe ein anderer Dienst?


Zeig Dein Scrtipt, und ich werde es dir erläutern, was wann warum nicht funktioniert. OK? Zwinkernd

derhoeppi schrieb on 31.10.07 um 07:11:00:
PS: Was muss eigentlich auf einer WinXP pro Version (blanke Installation ohne Updates und Patches) installiert sein, damit es sich zu einem WSUS verbindet?


Das ist etwas unterschiedlich. Beim WSUS 2.0 reicht ein W2KSP3 aus, bei XP das SP1. Beim WSUS 3.0 sind die etwas höher: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Bei XP muß das SP2 installiert sein, damit der richtige Update Agent vorhanden ist.
  
Zum Seitenanfang
 
derhoeppi
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 27
Standort: Berlin
Mitglied seit: 23.10.07
Re: Clients finden keine Verbindung
Antwort #21 - 31.10.07 um 12:43:47
Beitrag drucken  
Hey Sunny,
das ist eine Unterstützung von Dir, damit hätte ich ehrlich gesagt nicht gerechnet - dafür schon einmal ein Dankeschön  Smiley .
So ich habe mein Script mal angehängt. Ich vermute einfach, dass halt eine Deaktivierung des Dienstes fehlt, damit die Einstellungen auch übernommen werden können. Habe mir nun schon den Wolf im Netz gesucht und auch ein Script zum Beenden eines Dienstes gefunden, aber es funktioniert nicht, obwohl er es ohne Fehler ausführt.

Mfg
derhoeppi
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #22 - 31.10.07 um 13:01:39
Beitrag drucken  
Jetzt ist vieles klarer. Zwinkernd

Vor dem löschen der 3 SIDs mußt Du den Dienst WUAUSERV (Automatische Updates) anhalten. In einer Batch geht das so: net stop wuauserv
Dann kannst Du die SIDs löschen, die Werte für den WSUS importieren, den Ordner SoftwareDistribution in %windir% löschen/leeren. Jetzt wieder WUAUSERV starten. Und der BITS ist natürlich auch wichtig. Der darf nicht deaktiviert sein.

Schau dir mal diese beiden Scripte an: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Im Scriptcenter von MS ist bestimmt einiges zu finden für dich, wenn Du dich damit weiter beschäftigen möchtest: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Vieles davon hab ich in Connect2WSUS integriert, Du kannst dir vorstellen, das war schon ein bisschen mit Arbeit verbunden. Zwinkernd
  
Zum Seitenanfang
 
derhoeppi
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 27
Standort: Berlin
Mitglied seit: 23.10.07
Re: Clients finden keine Verbindung
Antwort #23 - 31.10.07 um 13:18:09
Beitrag drucken  
Ja ich kann mir vorstellen das in dem Programm viel Arbeit steckt. Die möchte ich mir ja auch machen. Das mit dem net stop habe ich auch schon gelesen, hat aber nicht so funktioniert. Vielleicht muss ich das mit sendkeys versuchen, aber mal sehen. Wo finde ich denn den Ordner SoftwareDistribution? Was ist da normaler Weise drin?
Okay ich schau mich mal bei deinen Links um.




Mir ist eben noch eine Frage eingefallen. Ist der wuaserv Dienst ein Teil vom Dienst Automatische Updates? Ich frage deshalb, weil auch wenn ich in der Kommandozeile net stop wuaserv eingebe, sehen ich in den Diensten nicht, dass ich die Automatischen Updates beendet habe.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #24 - 31.10.07 um 14:35:11
Beitrag drucken  
derhoeppi schrieb on 31.10.07 um 13:18:09:
Das mit dem net stop habe ich auch schon gelesen, hat aber nicht so funktioniert.


Wenn Du mit VB-Scripten nicht klar kommst, bleib bei Batch Scripten. Die sind für mich einfacher und übersichtlicher.

derhoeppi schrieb on 31.10.07 um 13:18:09:
Vielleicht muss ich das mit sendkeys versuchen, aber mal sehen.


SendKeys sind böse und unter VISTA wirst Du damit auf die Nase fallen.

derhoeppi schrieb on 31.10.07 um 13:18:09:
Wo finde ich denn den Ordner SoftwareDistribution? Was ist da normaler Weise drin?


Schrub ich doch: %WINDIR%. Mach mal Start > Ausführen > cmd[ENTER] und set [ENTER]. Jetzt ist es klarer, oder? Zwinkernd

derhoeppi schrieb on 31.10.07 um 13:18:09:
Okay ich schau mich mal bei deinen Links um.


Mach das, da ist vieles erklärt. Setz dir am besten einen virtuellen Client auf, da läßt sich schön rumspielen und auch schön schnell wieder auf den Ausgangspunkt zurück gehen. Zwinkernd

derhoeppi schrieb on 31.10.07 um 13:18:09:
Mir ist eben noch eine Frage eingefallen. Ist der wuaserv Dienst ein Teil vom Dienst Automatische Updates? Ich frage deshalb, weil auch wenn ich in der Kommandozeile net stop wuaserv eingebe, sehen ich in den Diensten nicht, dass ich die Automatischen Updates beendet habe.


WUAUSERV ist der Dienst Automatische Updates. Du hattest die Services.msc vorher schon geöffnet, und nach net stop wuauserv nicht die Ansicht aktualisiert? Schau mal in die Eigenschaften des Dienstes in der GUI. Im Reiter Allgemein steht gleich ganz oben der Dienstname. Das ist der den Du in der Comandline verwenden mußt.
  
Zum Seitenanfang
 
derhoeppi
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 27
Standort: Berlin
Mitglied seit: 23.10.07
Re: Clients finden keine Verbindung
Antwort #25 - 01.11.07 um 07:48:26
Beitrag drucken  
Moin Sunny,
endlich wieder auf Arbeit. Bin schon ne gute Stunde dabei an meinem Script zu schreiben. Endlich hat es funktioniert.
Auf den eigentlichen Dienstenamen habe ich nie so genau geachtet und das obwohl man häufiger mal in den Diensten ist und nach bestimmten Dingen sieht, aber mir ist das mit der wuauserv noch nicht aufgefallen. Es hätte sicherlich auch schon gestern funktioniert, denn ich habe unschöne Rechtschreibfehler drin gehabt, aber bis man darauf kommt - zumal mir Syntaxfehler angezeigt werden, aber halt nicht solche wie ich sie begangen habe.
So ich werde das nun mal einbauen, aber ich finde eines komisch. Viele Dinge bei vbs, wie Dienstenamen etc. werden im Deutschen verlangt, aber wenn ich den Starttyp von Automatisch auf Deaktiviert stelle, will er nicht "Deaktiviert", sondern "Disabled". Naja ich habs jetzt und muss mich nur noch um das Leeren von dem Ordner kümmern.

Mfg
derhoeppi
  
Zum Seitenanfang
 
derhoeppi
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 27
Standort: Berlin
Mitglied seit: 23.10.07
Re: Clients finden keine Verbindung
Antwort #26 - 01.11.07 um 12:42:19
Beitrag drucken  
Hallo Sunny,
da jetzt die erste Imageinstallation mit meinem Script funktioniert hat und sich der Client nach einigen Minuten beim Server gemeldet hat, habe ich nun noch eine Frage.
Ich habe meinen WSUS in einer Testumgebung. Auf diesem ist nur Windows2003 Server und halt der WSUS drauf. Komischer weise baut der Server immer wieder Verbindungen nach außen auf, die nichts mit Windows zu tun haben. Der Router der für den INet Zugang ist, lässt aber keine Verbindungen nach innen zu. Da aber eine Menge Daten versendet werden würde ich schon gern wissen welche Daten versendet werden? Ist das nur bei mir so oder auch bei euch?


Mfg
derhoeppi
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #27 - 01.11.07 um 13:17:22
Beitrag drucken  
derhoeppi schrieb on 01.11.07 um 07:48:26:
endlich wieder auf Arbeit. Bin schon ne gute Stunde dabei an meinem Script zu schreiben. Endlich hat es funktioniert.


Na super, freut mich für Dich. Zwinkernd

derhoeppi schrieb on 01.11.07 um 07:48:26:
So ich werde das nun mal einbauen, aber ich finde eines komisch. Viele Dinge bei vbs, wie Dienstenamen etc. werden im Deutschen verlangt, aber wenn ich den Starttyp von Automatisch auf Deaktiviert stelle, will er nicht "Deaktiviert", sondern "Disabled". Naja ich habs jetzt und muss mich nur noch um das Leeren von dem Ordner kümmern.


Genau deshalb arbeite ich nur mit VB oder Batch Dateien, da ist AFAIK alles einheitlich. Zwinkernd
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients finden keine Verbindung
Antwort #28 - 01.11.07 um 13:25:11
Beitrag drucken  
derhoeppi schrieb on 01.11.07 um 12:42:19:
Ich habe meinen WSUS in einer Testumgebung. Auf diesem ist nur Windows2003 Server und halt der WSUS drauf. Komischer weise baut der Server immer wieder Verbindungen nach außen auf, die nichts mit Windows zu tun haben.


Wohin will der Server Verbindungen aufbauen? Ist der WSUS selbst auf sich konfiguriert? Der WSUS will sich auch immer wieder synchronisieren. Ist die Synchronisierung abgeschaltet? Hast Du aktiviert, daß am Programm blabla teilgenommen wird?
  
Zum Seitenanfang
 
derhoeppi
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 27
Standort: Berlin
Mitglied seit: 23.10.07
Re: Clients finden keine Verbindung
Antwort #29 - 30.11.07 um 13:10:55
Beitrag drucken  
Hallo Sunny,
entschuldige das ich dir nicht geantwortet habe. Habe in den letzten drei Wochen etwas anderes zu tun gehabt.
Das mit den Verbindungen hat sich noch nicht gegeben. Es sind aber immer wieder die gleichen IP Adressen, die auf den Rechner zugreifen. Das ist nun aber erstmal nebensächlich.

Ich habe mal eine andere Frage. Ich habe ja mein Script geschrieben. Das funktioniert inzwischen 1a. Ich habe nur ein kleines Problem. Ich will das die Clients nach dem Updaten automatisch ausgehen. Dazu habe ich in das Script den shutdown Befehl geschrieben - funktioniert auch. Aber er fährt die Clients ohne eine Installation der gezogenen Updates herunter. Gibt es da eine andere Möglichkeit?
  
Zum Seitenanfang
 
Seitenindex umschalten Seiten: 1 [2] 3 4 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden