Normales Thema Clients laden Updates nicht mehr (Gelesen: 869 mal)
Fiede
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 3
Standort: Hamburg
Mitglied seit: 29.10.07
Clients laden Updates nicht mehr
29.10.07 um 16:48:09
Beitrag drucken  
Moin,

seit nem viertel Jahr läuft WSUS 3 ohne Probleme. Nun aber laden die Clients keine Updates mehr herunter, es erscheint nur noch der Hinweis "Updates verfügbar" und dann klickt man auf Download und dann hört man nix mehr von den Updates. (Über Policy: Downloaden nachfragen -> Installation nachfragen)

WSUS-Server ist ein SBS2003 SP2.

Inhalt der WindowsUpdate.log (nicht viel, mh?)

Code
2007-10-29	16:35:50:289	3892	f44	Misc	===========  Logging initialized (build: 7.0.6000.374, tz: +0100)  ===========
2007-10-29	16:35:50:289	3892	f44	Misc	  = Process: C:\WINDOWS\system32\wuauclt.exe
2007-10-29	16:35:50:289	3892	f44	AUClnt	Launched Client UI process
2007-10-29	16:35:50:336	3892	f44	Misc	===========  Logging initialized (build: 7.0.6000.374, tz: +0100)  ===========
2007-10-29	16:35:50:336	3892	f44	Misc	  = Process: C:\WINDOWS\system32\wuauclt.exe
2007-10-29	16:35:50:336	3892	f44	Misc	  = Module: C:\WINDOWS\system32\wucltui.dll
2007-10-29	16:35:50:336	3892	f44	CltUI	AU client got new directive = 'Download Approval', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return = 0x00000000
2007-10-29	16:35:50:336	3892	f44	CltUI	AU client creating default WU/WSUS UI plugin
2007-10-29	16:35:57:776	3892	f44	CltUI	AU client got new directive = 'Download Progress', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return = 0x00000000
2007-10-29	16:35:57:776	3892	f44	CltUI	AU client creating default WU/WSUS UI plugin
2007-10-29	16:36:13:329	3892	f44	CltUI	AU client got new directive = 'Shutdown', serviceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, return = 0x00000000
 



Am System wurde meines Wissens nichts geändert (vor meinem Urlaub klappte alles, nun wie gesagt nicht mehr).

In der Ereignisanzeige bei Client oder Server steht nichts weiter....auch das Client Diagnose Tool hat kein Problem (am Client kanns ja auch nicht liegen, ist bei allen Clients das gleiche Problem)....

Hat jemand eine Idee?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients laden Updates nicht mehr
Antwort #1 - 30.10.07 um 16:15:04
Beitrag drucken  
Die Option ist nicht grade die beste. 4 ist bessere. Halte auf einem Client mal den WUAUSERV an und lösch den Inhalt vom Ordner %windir%\softwareDistribution. Neustart des Client machen. Gehts jetzt?
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
Fiede
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 3
Standort: Hamburg
Mitglied seit: 29.10.07
Re: Clients laden Updates nicht mehr
Antwort #2 - 31.10.07 um 09:00:16
Beitrag drucken  
Moin,

danke für deine Antwort.

Ich nehme an, wenn du vom Client sprichst meintest du WUAUCLT, WUAUSERV gibt es nicht auf den Clients. Smiley

Ordner habe ich dann gelöscht, keine Änderung.

WSUS zieht Updates und synct erfolgreich, bekommt auch Statusmeldungen von den Clients...die Übersicht sieht derzeit echt grausam aus...2/3 Clients mit Fehlern, rest scheint einfach die letzten Tage noch nicht auf den Updates-Button geklickt zu haben.

Ich meine im Kopf zu haben, dass ich kurz vor meinem Urlaub am IIS "rumgespielt" hab, hab aber eigentlich alles wieder rückgängig gemacht...könnte da was dran sein?


EDIT:

Okay, hat sich erledigt, geht wieder. Ich bin mir 100%ig sicher, dass ich am IIS NICHT eingestelt habe, das er auf sämtliche Seiten nur den WSUS Server zugriff geben soll und alle anderen IP's aussperren....ziemlich merkwürdig, aber ich hab das nun geändert und nun geht es.....darauf muss man auch erstmal kommen.

Danke für die Hilfe nochmal!
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients laden Updates nicht mehr
Antwort #3 - 31.10.07 um 12:46:20
Beitrag drucken  
Fiede schrieb on 31.10.07 um 09:00:16:
Ich nehme an, wenn du vom Client sprichst meintest du WUAUCLT, WUAUSERV gibt es nicht auf den Clients. Smiley


Natürlich gibts WUAUSERV auf den Clients. Oder wie meinst Du, heißt der Dienst Automatische Updates? Zwinkernd

Fiede schrieb on 31.10.07 um 09:00:16:
Ordner habe ich dann gelöscht, keine Änderung.


Comandline auf dem Client:
net stop WUAUSERV
Ordner löschen
net start WUAUSERV
wuauclt /detectnow (20 - 30 x)


Fiede schrieb on 31.10.07 um 09:00:16:
WSUS zieht Updates und synct erfolgreich, bekommt auch Statusmeldungen von den Clients...die Übersicht sieht derzeit echt grausam aus...2/3 Clients mit Fehlern, rest scheint einfach die letzten Tage noch nicht auf den Updates-Button geklickt zu haben.


Welche Option hast Du eingestellt? Alles andere als die 4 ist für Clients nicht praktibel. Glaubs mir. Du bist für die Sicherheit verantwortlich, kannst aber nicht garantieren, wann die User die Updates installieren. Ergo bist Du schuld, wenn ein User nicht installiert, sich aber Malware einfängt.

Fiede schrieb on 31.10.07 um 09:00:16:
Ich meine im Kopf zu haben, dass ich kurz vor meinem Urlaub am IIS "rumgespielt" hab, hab aber eigentlich alles wieder rückgängig gemacht...könnte da was dran sein?


Wir wissen nicht, was Du alles verändert hast. Zwinkernd


Fiede schrieb on 31.10.07 um 09:00:16:
EDIT:

Okay, hat sich erledigt, geht wieder. Ich bin mir 100%ig sicher, dass ich am IIS NICHT eingestelt habe, das er auf sämtliche Seiten nur den WSUS Server zugriff geben soll und alle anderen IP's aussperren....ziemlich merkwürdig, aber ich hab das nun geändert und nun geht es.....darauf muss man auch erstmal kommen.


Na wunderbar, und wieder mal PICNIC. Durchgedreht Warum muß eigentlich jeder irgendwo rumspielen, anstatt vorher zu fragen? Die default Installation vom WSUS incl. GPO im AD ist vollkommen ausreichend und funktioniert zu 99 % in jeder Umgebung.
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
Fiede
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 3
Standort: Hamburg
Mitglied seit: 29.10.07
Re: Clients laden Updates nicht mehr
Antwort #4 - 31.10.07 um 22:25:52
Beitrag drucken  
Quote:
Welche Option hast Du eingestellt? Alles andere als die 4 ist für Clients nicht praktibel. Glaubs mir. Du bist für die Sicherheit verantwortlich, kannst aber nicht garantieren, wann die User die Updates installieren. Ergo bist Du schuld, wenn ein User nicht installiert, sich aber Malware einfängt.


Nunja, du hast natürlich recht. Ich würde auch lieber die Einstellung so wählen, aber haben leider noch Uralt-Kisten hier stehen, die total in die Knie gehen wenn die Updates sich automatisch installieren und die Kollegen sind dann angenervt und heulen bei mir rum. Da wir nicht so ein großes Unternehmen sind, passt das schon so, ich überprüf in der WSUS-Konsole regelmäßig den Status und habs allen Kollegen eingetrichtert drauf zu klicken. Klappt ganz gut eigentlich. Aber wie gesagt, stimm ich dir natürlich 100% zu bei deiner Aussage.

Quote:
Na wunderbar, und wieder mal PICNIC. Durchgedreht Warum muß eigentlich jeder irgendwo rumspielen, anstatt vorher zu fragen? Die default Installation vom WSUS incl. GPO im AD ist vollkommen ausreichend und funktioniert zu 99 % in jeder Umgebung.


Ich möchte nur klarstellen, dass ich mich nicht wild ausgetobt habe am IIS....also das Wort "rumspielen" war extra in Anführungsstrichen deswegen  Zwinkernd ....und ich bin nach wie vor der Meinung, dass ich niemals dort bei WSUS und Standardwebsite eingetragen habe "Zugriff verweigern: Alle außer "wsus-server"....is ja nich so, dass ich mich überhaupt nicht auskenne...und was für Folgen das gehabt hätte (bzw. gehabt hat  Ärgerlich ) wäre mir schon bewußt gewesen....ein Grund mehr warum ich nie auf die Idee käme so eine destruktive Einstellung im IIS zu machen...

Fange jetzt aber erstmal das rätseln an, wie es dazu kommen konnte...
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients laden Updates nicht mehr
Antwort #5 - 31.10.07 um 23:46:37
Beitrag drucken  
Fiede schrieb on 31.10.07 um 22:25:52:
Nunja, du hast natürlich recht. Ich würde auch lieber die Einstellung so wählen, aber haben leider noch Uralt-Kisten hier stehen, die total in die Knie gehen wenn die Updates sich automatisch installieren und die Kollegen sind dann angenervt und heulen bei mir rum.


Stell doch auf 12.00 Uhr mittags um, da sollten die meisten das nicht merken, und wenn, dann wissen sie das es Zeit ist Mittagspause zu machen. Zwinkernd

Fiede schrieb on 31.10.07 um 22:25:52:
Ich möchte nur klarstellen, dass ich mich nicht wild ausgetobt habe am IIS....also das Wort "rumspielen" war extra in Anführungsstrichen deswegen  Zwinkernd ....und ich bin nach wie vor der Meinung, dass ich niemals dort bei WSUS und Standardwebsite eingetragen habe "Zugriff verweigern: Alle außer "wsus-server"....is ja nich so, dass ich mich überhaupt nicht auskenne...und was für Folgen das gehabt hätte (bzw. gehabt hat  Ärgerlich ) wäre mir schon bewußt gewesen....ein Grund mehr warum ich nie auf die Idee käme so eine destruktive Einstellung im IIS zu machen...


Ich hab dich schon verstanden, Du hast den Smiley dahinter von mir auch gesehen? Kann ja mal passieren, das man sich verklickt. Mein ja nur. Zwinkernd
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden