Seitenindex umschalten Seiten: [1]  Thema versendenDrucken
Heißes Thema (mehr als 10 Antworten) Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe (Gelesen: 2527 mal)
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
11.02.10 um 15:58:39
Beitrag drucken  
Hallo zusammen,

wir haben hier folgendes Problem.

Wir haben den WSUS 3.0 SP2 eingeführt. Die Clients (XP SP3)bekommen per Police den WSUS zugeordnet.

Leider haben wir seitem wir den WSUS 3.0 SP2 (vorher WSUS 3.0 SP1) haben das Problem das sehr viele Clients ca. 100 beim anmeden die CPU Last auf auf 100 % haben durch SVCHOST.exe.

Sobald ich den Windows Update Dienst beende ist alles wieder in ordnung und der Prozess beruhigt sich.

Wir haben auch testweise den Virenscanner deativiert doch leider keine Änderung.

Zur Info die Clients haben als WSUS Agent den 7.4.7600.226.

Habt ich eine Idee wie ich diese Problen lösen kann.

Ich hatte gelesen das es vielleicht ein Windows Bug aber ein Hotfix habe ich dafür nicht gefunden.

Ich für eure Hilfe sehr dankbar.

Gruss Evoco
  
Zum Seitenanfang
 
UMeadow
WSUS Spezialist
*****
Offline


I Love WSUS!

Beiträge: 1337
Standort: Berlin
Mitglied seit: 22.01.08
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #1 - 11.02.10 um 16:08:36
Beitrag drucken  
Evoco schrieb on 11.02.10 um 15:58:39:
Ich hatte gelesen das es vielleicht ein Windows Bug aber ein Hotfix habe ich dafür nicht gefunden.

Du hast gelesen aber nicht gesucht oder?Zwinkernd
Kuck mal hier
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Hier im Forum ist das Thema auch schon behandelt worden, aber ich suche hier jetzt nicht.
  
Zum Seitenanfang
 
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #2 - 11.02.10 um 16:49:54
Beitrag drucken  
Was meinst du mit nicht gesucht und wie ich gesucht habe.

Der Artikel den du mir hier schreibst ist von Februar 2008....außerdem schrieb ich hier das alle Clients schon das SP3 haben...das heißt ich kann das Hotfix KB927891 nicht installieren weil dies schon im SP3 enthalten ist.

Ich suche gerne noch einmal in diesem Forum nur bisweil habe ich hier nichts gefunden was seit WSUS 3.0 SP2 geschrieben wurde. Ich weiss das dieser Fehler in früheren WSUS vor kam dafür war der Hotfix aber seit SP3....habe ich noch kein Hotfix gefunden.

Aber trotzdem danke für dein Tipp
  
Zum Seitenanfang
 
UMeadow
WSUS Spezialist
*****
Offline


I Love WSUS!

Beiträge: 1337
Standort: Berlin
Mitglied seit: 22.01.08
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #3 - 11.02.10 um 17:30:58
Beitrag drucken  
In dem Artikel steht aber auch der Hinweis zum aktuellen Update Agent drin, hast Du mal kontrolliert ob Deine Clients den aktuelle gezogen haben?
  
Zum Seitenanfang
 
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #4 - 11.02.10 um 18:04:52
Beitrag drucken  
Also ich dachte auch erst das ich vielleicht nicht den aktuellen habe aber wie ich oben schon geschrieben habe habe ich schon den aktuellen agent (7.4.7600.226) dieser ist vom 7.8.2009. Größe 6.618 KB...was dabei interessant ist es gibt diesen gleichen Agent, also gleiche Version vom 17.10.2008 dort die Größe 6.071 KB. Und beide findet man auf der Microsoft Seite

ich habe aber den ersteren also den aktuellen.
  
Zum Seitenanfang
 
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #5 - 12.02.10 um 11:44:37
Beitrag drucken  
Also ich habe hier im Forum weiter gesucht und bis dato nichts gefunden in der Konstelation WSUS 3.0 SP2 und XP SP3.

Daher weiterhin die Frage ob jemand hier weiter weiss. Ich habe mal im Anhang ein Log von einem Client der dieses Problem hat.

Vielleicht fällt euch dazu was ein..vielen dank
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). ( 1092 KB | Downloads )
Zum Seitenanfang
 
Blogster
WSUS Profi
****
Offline


I Love WSUS!

Beiträge: 391
Mitglied seit: 12.03.08
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #6 - 12.02.10 um 11:49:48
Beitrag drucken  
Hi,
denke nicht das dir mit dem Log einer helfen kann.
Da sind Einträge vom 17.11.2009 drinn die keinen Interessieren.
Poste bitte noch mal das log aber diesmal nur mit den letzten 50 Zeilen oder 2 - 3 Tagen. Smiley

Des Weiteren lösch mal den Cache auf einem betroffenen Client:

Code
net stop wuauserv
rd /s /q %windir%\SoftwareDistribution
net start wuauserv
wuauclt /resetauthorization /detectnow
wuauclt /detectnow
wuauclt /reportnow
 

  
Zum Seitenanfang
 
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #7 - 12.02.10 um 12:34:34
Beitrag drucken  
Danke hier nur von diesem Tag.

Was mir noch aufgefallen ist das bei neuen Clients mit Dual Core der Prozess maximal 50 % nutzt und nicht ein Prozent mehr so als wäre dort ein sperre da.
Aber bei einem Single Core nutz er den kompletten Prozessor absolut unkontrolliert.

Gibt es denn irgendwo ein Regkey der dies steuert?

Danke Gruss Evoco
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). ( 8 KB | Downloads )
Zum Seitenanfang
 
DESoft
WSUS Experte
*****
Offline


I Love WSUS!<br />

Beiträge: 696
Standort: Halle (Saale)
Mitglied seit: 24.07.08
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #8 - 15.02.10 um 01:31:09
Beitrag drucken  
Hallo Evoco,

hier noch ein anderer Ansatz:

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Fazit:
Prüf mal ob über eine GPO oder Lokale Einstellung die Richtlinie "Download missing COM components" unter "Computerkonfiguration => Administrative Vorlagen => System" aktiviert ist.
Wenn ja auf "Deaktiviert" oder "Nicht konfiguriert" setzen.

Bitte mit RSOP prüfen ... kann ja eine GPO von einer OU oder Site oder DefaultDomain sein. Zwinkernd

Gruß Dani
  
Zum Seitenanfang
 
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #9 - 15.02.10 um 13:53:41
Beitrag drucken  
Also diese Police ist beu uns schon deaktiviert.

Ich poste hier mal noch meine Einstellungen die ich jedem Client aufdrücke. Ihr könnt ja mal schauen was ih von diesen Einstellungen haltet...Eure Meinung würde mich interressieren:

Richtlinie Einstellung
Automatische Updates konfigurieren Aktiviert
Automatische Updates konfigurieren: 4 - Autom. Herunterladen und laut Zeitplan installieren
Folgende Einstellungen sind nur erforderlich
und gelten nur, wenn 4 gewählt wird.
Geplanter Installationstag:  0 - Täglich
Geplante Installationszeit: 03:00

Richtlinie Einstellung
Automatische Updates sofort installieren Aktiviert
Clientseitige Zielzuordnung aktivieren Aktiviert
Zielgruppenname für diesen Computer Standort01_Desktops

Richtlinie Einstellung
Erneut zu einem Neustart für geplante Installationen auffordern Aktiviert
Folgenden Zeitraum (in Minuten)
warten, bevor zu einem Neustart
aufgefordert wird: 60

Richtlinie Einstellung
Internen Pfad für den Microsoft Updatedienst angeben Aktiviert
Interner Updatedienst zum Ermitteln von Updates: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Intranetserver für die Statistiken: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Beispiel: http://IntranetUpd01)

Richtlinie Einstellung
Nicht-Administratoren gestatten, Updatebenachrichtigungen zu erhalten Deaktiviert
Suchhäufigkeit für automatische Updates Aktiviert
In folgenden Abständen (Stunden)
nach Updates suchen: 22

Richtlinie Einstellung
Zeitplan für geplante Installationen neu erstellen Aktiviert
Wartezeit nach
Systemstart (Minuten):  5

Es wurde mir auch berichtet das Tagsüber der WSUS Agent hier eine Kommunikation anfängt, so das die svchost.exe voll auf 100% Prozent läuft.
Kann man den irgendwo steuern wann der Agent sein report erstellt das er an den WSUS dann sendet?

  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #10 - 15.02.10 um 14:33:33
Beitrag drucken  
Evoco schrieb on 15.02.10 um 13:53:41:
Ich poste hier mal noch meine Einstellungen die ich jedem Client aufdrücke. Ihr könnt ja mal schauen was ih von diesen Einstellungen haltet...Eure Meinung würde mich interressieren:


Du wurdest gefragt, was denn per RSOP.MSC am Client ankommt. Zwischen dem was Du konfigurierst und was am Client ankommt, kann es große Unterschiede geben. Also liefere bitte das, was man dich fragt.

Evoco schrieb on 15.02.10 um 13:53:41:
Es wurde mir auch berichtet das Tagsüber der WSUS Agent hier eine Kommunikation anfängt, so das die svchost.exe voll auf 100% Prozent läuft.
Kann man den irgendwo steuern wann der Agent sein report erstellt das er an den WSUS dann sendet?


In der Suchhäufigkeit für automatische Updates stellt man das ein. Da hast Du bereits 22 Stunden eingestellt. Also sollte es daran nicht liegen. Mich stört eher die Zeit für die Installation. Und der Zeitplan für geplante Installationen neu erstellen ist in diesem Zusammenhang unglücklich gewählt. Stell doch mal die Installationszeit auf 12.00 Uhr um und beobachte die Reaktion.
  
Zum Seitenanfang
 
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #11 - 15.02.10 um 17:43:53
Beitrag drucken  
Der Kollege schrieb:
Bitte mit RSOP prüfen nicht posten Zwinkernd ist wohl logisch das man dies auch testet. Aber natürlich poste ich gerne das Ergebnis(siehe Anhang)

Welche Zeiten hast du denn bei deinen Clients eingestellt?
12 Uhr ist doch eigentlich nicht so passend oder?

Ich werde es mal bei einem Client testen.

Am liebsten wäre mir ja einzustellen, das er nur bei einem Patchday nach updates sucht und sonst ist dies ja absolut überflüssig oder ?
Jetzt sucht er ja nach Updates obwohl er erst kurz vorher danach gesucht hat. Ich habe dieses 100 % CPU Auslastung jeden Tag.

Danke
  
Zum Seitenanfang
 
UMeadow
WSUS Spezialist
*****
Offline


I Love WSUS!

Beiträge: 1337
Standort: Berlin
Mitglied seit: 22.01.08
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #12 - 15.02.10 um 17:47:18
Beitrag drucken  
Das Problem ist jedenfalls in der Vergangenheit häufiger im Zusammenhang mit Office2K3 SP3 aufgetreten.
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Außerdem scheint dieses Problem auch im Zusammenhang mit Virenscannern aufzutreten.
Hast Du aus diesem Link
DESoft schrieb on 15.02.10 um 01:31:09:
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen)..

mal die Ausnahmeregeln für den Virenscanner ausprobiert?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #13 - 15.02.10 um 18:12:54
Beitrag drucken  
Evoco schrieb on 15.02.10 um 17:43:53:
Der Kollege schrieb:
Bitte mit RSOP prüfen nicht posten Zwinkernd ist wohl logisch das man dies auch testet. Aber natürlich poste ich gerne das Ergebnis(siehe Anhang)


Sorry aber logisch ist gar nichts. Pferde, Apotheke ist dir bekannt? Zwinkernd

Evoco schrieb on 15.02.10 um 17:43:53:
Welche Zeiten hast du denn bei deinen Clients eingestellt?
12 Uhr ist doch eigentlich nicht so passend oder?


Na klar, ich hab aber auch keine Beschwerden bekommen. Nur als wir O2007 ausgerollt hatten, da gabs ein paar Tage manchmal Stress mit älteren Rechnern. Die Beispiel-GPO von hier ist bei mir aktiv: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Evoco schrieb on 15.02.10 um 17:43:53:
Ich werde es mal bei einem Client testen.


Jepp, mach das.

Evoco schrieb on 15.02.10 um 17:43:53:
Am liebsten wäre mir ja einzustellen, das er nur bei einem Patchday nach updates sucht und sonst ist dies ja absolut überflüssig oder ?
Jetzt sucht er ja nach Updates obwohl er erst kurz vorher danach gesucht hat. Ich habe dieses 100 % CPU Auslastung jeden Tag.


Du kannst natürlich auch in einer GPO den Dienst WUAUSERV nach der erfoglreichen Installation deaktivieren. Dann wäre auch Ruhe.
  
Zum Seitenanfang
 
Evoco
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 8
Mitglied seit: 11.02.10
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #14 - 16.02.10 um 12:30:25
Beitrag drucken  
Alos ich habe dies jetzt mal an mehreren Clients getestet also einmal die Einstellung 5 min nach Neustart und Updates installieren um 12 Uhr.
Außerdem habe ich bei einigen Clients den Virenscanner komplett deaktiviert.

Fazit: Das Problem liegt weiterhin noch an direkt nach einem Neustart geht die SVCHOST.exe auf 100 % und der User wartet bis zu 15 Minuten...bis er wieder arbeiten kann. Griesgrämig
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #15 - 16.02.10 um 12:40:59
Beitrag drucken  
Evoco schrieb on 16.02.10 um 12:30:25:
Alos ich habe dies jetzt mal an mehreren Clients getestet also einmal die Einstellung 5 min nach Neustart und Updates installieren um 12 Uhr.
Außerdem habe ich bei einigen Clients den Virenscanner komplett deaktiviert.


Wie hast Du welchen AV-Scanner deaktiviert? Du weißt, viele lassen sich nicht deaktivieren, nur deinstallieren. Hast Du das Verzeichnis %windir%\SoftwareDistribution vom scannen ausgenommen? Probier auch mal probehalber einen anderen AV-Scanner.
  
Zum Seitenanfang
 
DESoft
WSUS Experte
*****
Offline


I Love WSUS!<br />

Beiträge: 696
Standort: Halle (Saale)
Mitglied seit: 24.07.08
Geschlecht: männlich
Re: Seit WSUS 3.0 SP2 CPU auf 100 % durch SVCHOST.exe
Antwort #16 - 21.02.10 um 11:54:58
Beitrag drucken  
Hallo Evoco,

wenn es also COM nicht ist ...
eventuell hilft das Dir weiter (?):
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Virenscanner deaktivieren hat schon sehr oft nicht ausgereicht. Griesgrämig
Aber richtig konfiguriert ist allemal besser. Laut lachend

Wir hatten auch einen Amokläufer, aber bevor ich den mir krallen konnte, wurde er von den örtlichen Betreuern geschlachtet und neu aufgesetzt. Griesgrämig
Also nix mehr mit "in Augenscheinnahme". Grmpf.

Gruß Dani
  
Zum Seitenanfang
 
Seitenindex umschalten Seiten: [1] 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden