Seitenindex umschalten Seiten: [1] 2  Thema versendenDrucken
Heißes Thema (mehr als 10 Antworten) Error 0x8024400A, soap client error 10 (Gelesen: 1313 mal)
meilon
WSUS Neuling
Offline



Beiträge: 8
Mitglied seit: 12.01.12
Error 0x8024400A, soap client error 10
12.01.12 um 16:08:44
Beitrag drucken  
Hallo zusammen!

seit dem 19.12. können sich zwei unserer Domaincontroller (Windows Server 2003 SP2) nicht mehr bei unserem WSUS Server (Server 2008 R2 SP1 mit WSUS 3.2 und IIS 7) verbinden. Hier der Ausschnitt aus dem Log:

Code
2012-01-12	15:38:35:742	 976	2e8	PT	WARNING: GetConfig failure, error = 0x8024400A, soap client error = 10, soap error code = 0, HTTP status code = 200
2012-01-12	15:38:35:742	 976	2e8	PT	WARNING: PTError: 0x8024400a
2012-01-12	15:38:35:742	 976	2e8	PT	WARNING: GetConfig_WithRecovery failed: 0x8024400a
2012-01-12	15:38:35:742	 976	2e8	PT	WARNING: RefreshConfig failed: 0x8024400a
2012-01-12	15:38:35:742	 976	2e8	PT	WARNING: RefreshPTState failed: 0x8024400a
2012-01-12	15:38:35:742	 976	2e8	PT	WARNING: PTError: 0x8024400a
2012-01-12	15:38:35:742	 976	2e8	Report	WARNING: Reporter failed to upload events with hr = 8024400a. 



Das Problem bei der Lösungssuche ist nun, dass ich tausende Seiten finde, dass es wohl mal im IIS 6.0 unter Server 2003 SP1 Probleme gab. Bei mir ist es aber alles schon etwas moderner und die Hotfixes wurden ja bereits in die Service Packs integriert.

Einen Server habe ich mal über einen Proxy zu Microsofts Servern verbinden lassen, das laden der Updates ging dort problemlos. Den WSUS trifft da wohl die Teilschuld, denn alle anderen Server haben im WSUS kein Problem. Es sind auch nicht die einzigen 2003 SP 2 Maschienen.

Ich kann mich an nichts entsinnen, warum genau die zwei Server seit dem Tag nicht mehr mit dem WSUS reden können.

Ausprobiert habe ich schon alles, womit ich sonst immer Erfolg hatte: SoftwareDistirbution löschen, log leeren, bits queue leeren, dll's neu registrieren und neu authentifizieren lassen (das meiste geht ja automatisiert mit "Windows Update Restore 2.80")

Habt ihr da eine Idee??

Grüße
meilon



  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #1 - 13.01.12 um 09:35:51
Beitrag drucken  
Du kannst den aktuellen WU-Agent mit der Option /WUFORCE erneut drüber installieren lassen. In den Bekannten Problemen ist das finden: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Alternativ auch den Fixit (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). ausführen, auch wenn die Fehlermeldung nicht zu deiner passt.

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). wurde wohl eingestellt. Außerdem weiß man nicht was genau dieses Tool alles macht. Da würde ich mich nicht drauf verlassen. Und so schwierig sind die Aufräumarbeiten nicht, das kann man alles manuell auf der Commandline ausführen, bzw. sich eine kleine Batch schreiben und die dann ausführen.
  
Zum Seitenanfang
 
meilon
WSUS Neuling
Offline



Beiträge: 8
Mitglied seit: 12.01.12
Re: Error 0x8024400A, soap client error 10
Antwort #2 - 19.01.12 um 13:02:19
Beitrag drucken  
Sunny schrieb on 13.01.12 um 09:35:51:
Du kannst den aktuellen WU-Agent mit der Option /WUFORCE erneut drüber installieren lassen. In den Bekannten Problemen ist das finden: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Alternativ auch den Fixit (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). ausführen, auch wenn die Fehlermeldung nicht zu deiner passt.

Leider hat weder das Update geholfen noch die manuell ausgeführten Schritte des Fixit (der Download des Fixit sagt mir, dass es für das System nicht geeignet sei)

Sunny schrieb on 13.01.12 um 09:35:51:
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). wurde wohl eingestellt. Außerdem weiß man nicht was genau dieses Tool alles macht. Da würde ich mich nicht drauf verlassen. Und so schwierig sind die Aufräumarbeiten nicht, das kann man alles manuell auf der Commandline ausführen, bzw. sich eine kleine Batch schreiben und die dann ausführen.
Das Tool ist auch nur eine Batchdatei, die diverse Sachen für mich übernimmt (Software Distribution löschen, dll's neu registrieren, etc. Bei interesse kann ich es ja mal zippen und hochladen)
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #3 - 19.01.12 um 17:45:32
Beitrag drucken  
Welcher Port steht bei den betroffenen Servern denn in der Registry beim WSUS Eintrag? HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate > Der Eintrag vom WSUS ist gemeint.
  
Zum Seitenanfang
 
meilon
WSUS Neuling
Offline



Beiträge: 8
Mitglied seit: 12.01.12
Re: Error 0x8024400A, soap client error 10
Antwort #4 - 19.01.12 um 19:48:53
Beitrag drucken  
dort steht, wie es sein soll, http://<hostname des WSUS>

Bei uns läuft der WSUS direkt auf Port 80
  
Zum Seitenanfang
 
DESoft
WSUS Experte
*****
Offline


I Love WSUS!<br />

Beiträge: 696
Standort: Halle (Saale)
Mitglied seit: 24.07.08
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #5 - 19.01.12 um 21:51:06
Beitrag drucken  
Siehe doch mal hier:

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Gruß Dani
  
Zum Seitenanfang
 
meilon
WSUS Neuling
Offline



Beiträge: 8
Mitglied seit: 12.01.12
Re: Error 0x8024400A, soap client error 10
Antwort #6 - 20.01.12 um 09:31:20
Beitrag drucken  
DESoft schrieb on 19.01.12 um 21:51:06:
Siehe doch mal hier:

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Gruß Dani


Wenn du mir mit dem Post sagen möchtest, dass mein WSUS Server evtl. nicht auf Port 80 läuft, so kann ich dich beruhigen: Er läuft auf Port 80, ein Aufruf von http://<WSUS Hostname>/selfupdate/wuident.cab bietet mir die Datei zum Download an, auch auf den nicht funktionierenden Servern. Alle anderen 35 Clients melden sich ja erfolgreich und machen ihre Updates.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #7 - 20.01.12 um 09:42:11
Beitrag drucken  
meilon schrieb on 20.01.12 um 09:31:20:
DESoft schrieb on 19.01.12 um 21:51:06:
Siehe doch mal hier:

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Gruß Dani


Wenn du mir mit dem Post sagen möchtest, dass mein WSUS Server evtl. nicht auf Port 80 läuft, so kann ich dich beruhigen: Er läuft auf Port 80, ein Aufruf von http://<WSUS Hostname>/selfupdate/wuident.cab bietet mir die Datei zum Download an, auch auf den nicht funktionierenden Servern. Alle anderen 35 Clients melden sich ja erfolgreich und machen ihre Updates.



Verschieb doch den betroffenen Server in eine OU/Container, auf der keine WSUS GPO wirken. Gpupdate force ausführen und zweimal neu starten. Prüfen ob kein WSUS mehr eingetragen ist, wenn es in Ordnung ist die WSUS Einträge manuell über GPEDIT.MSC vornehmen. Wenn es funktioniert, Einträge wieder rausnehmen, Server wieder in die ursprüngliche OU verschieben.
  
Zum Seitenanfang
 
meilon
WSUS Neuling
Offline



Beiträge: 8
Mitglied seit: 12.01.12
Re: Error 0x8024400A, soap client error 10
Antwort #8 - 20.01.12 um 09:53:57
Beitrag drucken  
Wir verteilen über die GPO keine WSUS Einstellungen, das wird immer von Hand via Registry/GPedit.msc gemacht. Alle regulären Clients werden über die Softwareverteilungssoftware (was für ein Wort!) mit Patches betankt, die brauchen den WSUS nicht.

Ich kann aber mal für die OU Domain Controllers die Policy anpassen und WSUS Updates eintragen
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #9 - 20.01.12 um 13:09:01
Beitrag drucken  
meilon schrieb on 20.01.12 um 09:53:57:
Wir verteilen über die GPO keine WSUS Einstellungen, das wird immer von Hand via Registry/GPedit.msc gemacht. Alle regulären Clients werden über die Softwareverteilungssoftware (was für ein Wort!) mit Patches betankt, die brauchen den WSUS nicht.


OK, solche nicht unwichtigen Informationen solltest Du im ersten Posting unterbringen.

meilon schrieb on 20.01.12 um 09:53:57:
Ich kann aber mal für die OU Domain Controllers die Policy anpassen und WSUS Updates eintragen


Die DCs alleine kannst Du natürlich schon über eine GPO zum WSUS umleiten, da müsstest Du nichts per GPEDIT.MSC machen.

Hast Du im Windows Verzeichnis einen Temp Ordner? Wenn ja, welche NTFS-Berechtigungen liegen drauf?
  
Zum Seitenanfang
 
meilon
WSUS Neuling
Offline



Beiträge: 8
Mitglied seit: 12.01.12
Re: Error 0x8024400A, soap client error 10
Antwort #10 - 23.01.12 um 10:05:30
Beitrag drucken  
Okay, habs herausgefunden: Das Server Antivirus war schuld! Habe die Portüberwachung für Port 80 ausgeschaltet und die Verbindung kommt nun wieder zustande, WSUS und Client unterhalten sich wieder!
  
Zum Seitenanfang
 
UMeadow
WSUS Spezialist
*****
Offline


I Love WSUS!

Beiträge: 1337
Standort: Berlin
Mitglied seit: 22.01.08
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #11 - 23.01.12 um 11:37:03
Beitrag drucken  
meilon schrieb on 23.01.12 um 10:05:30:
Okay, habs herausgefunden: Das Server Antivirus war schuld! Habe die Portüberwachung für Port 80 ausgeschaltet und die Verbindung kommt nun wieder zustande, WSUS und Client unterhalten sich wieder! 

Und die Portüberwachung hatte sich selbst eingeschaltet und das bei einer Antiviren-Software?  Zwinkernd
Ok na immerhin ist das Problem gefunden.
  
Zum Seitenanfang
 
meilon
WSUS Neuling
Offline



Beiträge: 8
Mitglied seit: 12.01.12
Re: Error 0x8024400A, soap client error 10
Antwort #12 - 23.01.12 um 12:40:02
Beitrag drucken  
Nein, die war schon immer an. Aber irgend ein Update (höchstwahrscheinlich am 19.12.) muss das ganze dann zerbröselt haben!
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #13 - 23.01.12 um 14:02:37
Beitrag drucken  
meilon schrieb on 23.01.12 um 10:05:30:
Okay, habs herausgefunden: Das Server Antivirus war schuld! Habe die Portüberwachung für Port 80 ausgeschaltet und die Verbindung kommt nun wieder zustande, WSUS und Client unterhalten sich wieder!


Welcher AV-Scanner ist denn auf dem Server installiert? Bitte gib auch die genaue Version an. Danke. Freut mich trotzdem dass es wieder funktioniert. Zwinkernd
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Error 0x8024400A, soap client error 10
Antwort #14 - 23.01.12 um 14:03:07
Beitrag drucken  
meilon schrieb on 23.01.12 um 12:40:02:
Nein, die war schon immer an. Aber irgend ein Update (höchstwahrscheinlich am 19.12.) muss das ganze dann zerbröselt haben!


Aber nur das Update vom AV-Scanner, ein Windows Update fummelt da wohl kaum dran.
  
Zum Seitenanfang
 
Seitenindex umschalten Seiten: [1] 2 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden