Normales Thema OpenOffice 4.0 über WPP ausrollen ergibt Fehler 80070643 (Gelesen: 836 mal)
Admin03
WSUS Junior Member
*
Offline


Ich nur putzen Boden

Beiträge: 40
Standort: 99830 Treffurt
Mitglied seit: 09.12.05
Geschlecht: männlich
OpenOffice 4.0 über WPP ausrollen ergibt Fehler 80070643
30.08.13 um 14:20:05
Beitrag drucken  
Hallo an alle,

nachdem ich Flash-Plugin und Flash-Axtive-X, java 32-bit, 7Zip, Adobe Reader und PDF-XChange erfolgreich über WPP in der Domäne ausgerollt habe (und auch das Update auf Adobe Reader 11.0.3 klappte), wagte ich mich an etwas größere Sachen.
Meine Wahl fiel da auf OpenOffice4.0.

Also, das Paket heruntergeladen und ausgepackt.
Dann ein msiexec /a openoffice400.msi, und alles in ein Netzwerkverzeichnis abgelegt.
Mit orca noch ein openoffice400.mst erzeugt*, und dann gings ans paketieren.

Über den Assistenten die MSI-Datei ausgewählt, dann noch die MST und alle anderen Dateien und Verzeichnisse aus dem Netzwershare nacheinander eingetragen.
Als Regel lediglich die Standard-msi-Regel, sowie WinVer >=Win7 und Workstation, im 2. Regelfenster das gleiche (NOT msi regel + Win7 nur WS).
Das Ganze dann für meine Testgruppe freigegeben, "detectnow"  - "reportnow", bischen warten, und schon fing der Client an, das Update zu ziehen.

Leider bricht die Installation ab, und gibt die Fehlermeldung "80070643". lt google stoße ich nur auf Fehler, die für .NET framework oder Office 2003 stehen.

Da kein Office 2003 da drauf ist, scheidet das aus.

Das .NET Framework wurde im Zuge der Win7 Installation (bzw. der darauffolgenden Updateorgie des WSUS) vor gerade mal einem Monat neu installiert.
Bevor ich jetzt anfange, entsrechend (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). alles vom .NET-Framework runter zu werfen und neu zu installieren, möchte ich erst mal in die Runde fragen, ob jemand schon das Gleiche erlebt, und wenn ja, wie er das gelöst hat.

System:
Server2008R2, WSUS 3.0
Windows7 64bit
alles über den WSUS aktuell gehalten.

Gruß und schönes Wochenende



*Da MSOffice 2013 installiert ist, sollen ja doc und docx mit MSWord, xls und xlsx mit MSExcel, etc. geöffnet werden, also da einige Einträge im property-Bereich angepasst. Die gleichen Einträge hatte ich bereits bei der opeoffice321.mst für OpenOffice 3.2, welches über die GruRiLi unter WinXP ausgerollt wurde, geändert, und das lief durch.
  

Gruß

Admin 03

Wer Rechtschreib- und Grammatikfehler findet, darf sie behalten
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: OpenOffice 4.0 über WPP ausrollen ergibt Fehler 80070643
Antwort #1 - 01.09.13 um 21:16:35
Beitrag drucken  
Open Office hab ich noch nicht versucht über den WPP und den WSUS zur Verfügung zu stellen.  Was hast Du denn im MST alles angepasst? Hast Du es auch ohne MST versucht? Gibt es ein Installationslog? Wenn ja, kannst Du es hier anhängen?
  
Zum Seitenanfang
 
Admin03
WSUS Junior Member
*
Offline


Ich nur putzen Boden

Beiträge: 40
Standort: 99830 Treffurt
Mitglied seit: 09.12.05
Geschlecht: männlich
Re: OpenOffice 4.0 über WPP ausrollen ergibt Fehler 80070643
Antwort #2 - 03.09.13 um 07:14:25
Beitrag drucken  
Sunny schrieb on 01.09.13 um 21:16:35:
Was hast Du denn im MST alles angepasst?
Folgende Änderunge habe ich im "Property-Bereich vorgenommen:
* ISCHECKFORPRODUCTUPDATES = 0 (statt 1)
* CREATEDESKTOPLINK = 0 (statt 1)
* AgreeToLicense = Yes (statt No)
* REGISTER_NO_MSO_TYPES = 1 (statt 0)

Sunny schrieb on 01.09.13 um 21:16:35:
Hast Du es auch ohne MST versucht?
Ja, leider das gleiche Ergebnis.

Allerdings habe ich aus lauter Verzweiflung versucht, die openoffice400.msi per Doppelklick zu starten, da bekomme ich die Fehlermeldung "Bitte benutzen Sie die Datei setup.exe, um die Installation zu starten." Gleiches wenn ich es über die Kommandozeile versuche, selbst wenn ich die cmd.exe als Administrator ausführe.
Auch ein Verteilen per GPO schlägt fehl.
Ich gehe daher davon aus, dass der Fehler nicht am Package Publisher liegt, sondern an der openoffice.msi.
Oder an Win7, denn unter Windows XP kann ich die openoffice400.msi direkt aus dem Netzwerkpfad installieren und auch per GPO verteilen.

Sunny schrieb on 01.09.13 um 21:16:35:
Gibt es ein Installationslog? Wenn ja, kannst Du es hier anhängen?
Ich habe nur Einträge im eventlog gefunden, jedoch kein Installationslog.
  

Gruß

Admin 03

Wer Rechtschreib- und Grammatikfehler findet, darf sie behalten
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: OpenOffice 4.0 über WPP ausrollen ergibt Fehler 80070643
Antwort #3 - 03.09.13 um 08:27:54
Beitrag drucken  
In (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). gibt es den Hinweis auf das Entfernen der Zeile mit dem Hinweis auf die Setup.exe. Dort geht es zwar um die Version 3.3, vielleicht hilft dir das weiter. Hier steht auch das man die Zeile removen soll: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Hier ist auch noch ein PDF dafür: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Probier doch die gen. Zeile zu entfernen und jetzt das Paket erneut publishen. Wenn es immer noch Probleme gibt mit den ganzen Parametern, aber die manuelle Installation mit allen Parametern funktioniert, würde ich eine kleine Setup.exe mit VB.NET erstellen, die nichts anderes macht als das MSI mit Parametern aufzurufen.
  
Zum Seitenanfang
 
Admin03
WSUS Junior Member
*
Offline


Ich nur putzen Boden

Beiträge: 40
Standort: 99830 Treffurt
Mitglied seit: 09.12.05
Geschlecht: männlich
Re: OpenOffice 4.0 über WPP ausrollen ergibt Fehler 80070643
Antwort #4 - 03.09.13 um 16:17:32
Beitrag drucken  
Sunny schrieb on 03.09.13 um 08:27:54:
In (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). gibt es den Hinweis auf das Entfernen der Zeile mit dem Hinweis auf die Setup.exe. Dort geht es zwar um die Version 3.3, vielleicht hilft dir das weiter. Hier steht auch das man die Zeile removen soll: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Hier ist auch noch ein PDF dafür: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Probier doch die gen. Zeile zu entfernen und jetzt das Paket erneut publishen.


1000 Dank, das wars, die Zeile gelöscht, und schon flutscht es.

(Bereich "LaunchCondition", Zeile "VersionNT....")

Da ich bis vor kurzem die 3.2.1 verteilt hatte, wo es diese Zeile (noch)gar nicht gab, habe ich mich um weitere How-To von 3.x-Versionen gar nicht gekümmert. Asche auf mein Haupt.

Sunny schrieb on 03.09.13 um 08:27:54:
Wenn es immer noch Probleme gibt mit den ganzen Parametern, aber die manuelle Installation mit allen Parametern funktioniert, würde ich eine kleine Setup.exe mit VB.NET erstellen, die nichts anderes macht als das MSI mit Parametern aufzurufen.

Wer mit mit VB.NET klar kommt, kann das machen.
Aber schön, dass ich jetzt weiß, and wen ich mich in Zukunft  wenden kann *duck*

Aber OO 4.0 verteilt sich gerade schön auf die ersten Rechner in meiner Testgruppe, morgen dann an alle.
  

Gruß

Admin 03

Wer Rechtschreib- und Grammatikfehler findet, darf sie behalten
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: OpenOffice 4.0 über WPP ausrollen ergibt Fehler 80070643
Antwort #5 - 03.09.13 um 19:30:47
Beitrag drucken  
Admin03 schrieb on 03.09.13 um 16:17:32:
Wer mit mit VB.NET klar kommt, kann das machen.
Aber schön, dass ich jetzt weiß, and wen ich mich in Zukunft  wenden kann *duck*

Aber OO 4.0 verteilt sich gerade schön auf die ersten Rechner in meiner Testgruppe, morgen dann an alle.


Wenn man sich ein bisschen mit VB.NET beschäftigt, kriegt man solche kleinen EXEn recht schnell fertig. Zwinkernd

Hauptsache es funktioniert jetzt alles wie gewünscht. Zwinkernd
  
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden