Normales Thema Clients laden keine Updates vom Downstreamserver (Replica) (Gelesen: 905 mal)
christophstephan
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 3
Standort: Raesfeld
Mitglied seit: 26.09.08
Geschlecht: männlich
Clients laden keine Updates vom Downstreamserver (Replica)
15.05.15 um 23:23:36
Beitrag drucken  
Hallo liebe Forumsmitglieder,
nach etlichen Versuchen und einer Menge Sucherei komme ich dennoch nicht weiter.
Habe kürzlich einen Replica Server aufgesetzt, der synchronisiert auch brav mit dem Upstreamserver, und die Clients melden sich auch brav an dem Replica Server an, dem sie per GPO zugeteilt sind. Auf dem Replica steht auch, dass die Clients Updates brachen, aber wenn ich Updates auf dem Client anstoße, kommt die Meldung, das Windows auf dem neuesten Stand sei.
Auszug aus WindowsUpdate.log:

2015-05-15      23:20:30:775      1076      1358      AU      Triggering AU detection through DetectNow API
2015-05-15      23:20:30:775      1076      1358      AU      Triggering Online detection (interactive)
2015-05-15      23:20:30:775      1076      10fc      AU      #############
2015-05-15      23:20:30:775      1076      10fc      AU      ## START ##  AU: Search for updates
2015-05-15      23:20:30:775      1076      10fc      AU      #########
2015-05-15      23:20:30:775      1076      10fc      AU      <<## SUBMITTED ## AU: Search for updates [CallId = {355F66F9-8194-4FF2-AD65-E128167AC974}]
2015-05-15      23:20:30:775      1076      774      Agent      *************
2015-05-15      23:20:30:775      1076      774      Agent      ** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
2015-05-15      23:20:30:775      1076      774      Agent      *********
2015-05-15      23:20:30:775      1076      774      Agent        * Online = Yes; Ignore download priority = No
2015-05-15      23:20:30:775      1076      774      Agent        * Criteria = "IsInstalled=0 and DeploymentAction='Installation' or IsPresent=1 and DeploymentAction='Uninstallation' or IsInstalled=1 and DeploymentAction='Installation' and RebootRequired=1 or IsInstalled=0 and DeploymentAction='Uninstallation' and RebootRequired=1"
2015-05-15      23:20:30:775      1076      774      Agent        * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
2015-05-15      23:20:30:775      1076      774      Agent        * Search Scope = {Machine}
2015-05-15      23:20:30:853      1076      774      Setup      Checking for agent SelfUpdate
2015-05-15      23:20:30:853      1076      774      Setup      Client version: Core: 7.6.7601.18804  Aux: 7.6.7601.18804
2015-05-15      23:20:30:868      1076      774      Misc      Validating signature for C:\windows\SoftwareDistribution\SelfUpdate\wuident.cab with dwProvFlags 0x00000080:
2015-05-15      23:20:30:868      1076      774      Misc       Microsoft signed: NA
2015-05-15      23:20:30:884      1076      774      Misc      Validating signature for C:\windows\SoftwareDistribution\SelfUpdate\TMP2433.tmp with dwProvFlags 0x00000080:
2015-05-15      23:20:30:884      1076      774      Misc       Microsoft signed: NA
2015-05-15      23:20:30:899      1076      774      Misc      Validating signature for C:\windows\SoftwareDistribution\SelfUpdate\wsus3setup.cab with dwProvFlags 0x00000080:
2015-05-15      23:20:30:899      1076      774      Misc       Microsoft signed: NA
2015-05-15      23:20:30:915      1076      774      Misc      Validating signature for C:\windows\SoftwareDistribution\SelfUpdate\wsus3setup.cab with dwProvFlags 0x00000080:
2015-05-15      23:20:30:915      1076      774      Misc       Microsoft signed: NA
2015-05-15      23:20:30:931      1076      774      Setup      Determining whether a new setup handler needs to be downloaded
2015-05-15      23:20:30:931      1076      774      Setup      SelfUpdate handler is not found.  It will be downloaded
2015-05-15      23:20:30:931      1076      774      Setup      Evaluating applicability of setup package "WUClient-SelfUpdate-ActiveX~31bf3856ad364e35~amd64~~7.6.7600.320"
2015-05-15      23:20:30:931      1076      774      Setup      Setup package "WUClient-SelfUpdate-ActiveX~31bf3856ad364e35~amd64~~7.6.7600.320" is not applicable
2015-05-15      23:20:30:931      1076      774      Setup      Evaluating applicability of setup package "WUClient-SelfUpdate-Aux-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.320"
2015-05-15      23:20:30:931      1076      774      Setup      Setup package "WUClient-SelfUpdate-Aux-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.320" is not applicable
2015-05-15      23:20:30:931      1076      774      Setup      Evaluating applicability of setup package "WUClient-SelfUpdate-Core-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.320"
2015-05-15      23:20:30:962      1076      774      Setup      Setup package "WUClient-SelfUpdate-Core-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.320" is not applicable
2015-05-15      23:20:30:962      1076      774      Setup      SelfUpdate check completed.  SelfUpdate is NOT required.
2015-05-15      23:20:33:427      1076      774      PT      +++++++++++  PT: Synchronizing server updates  +++++++++++
2015-05-15      23:20:33:427      1076      774      PT        + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2015-05-15      23:20:45:564      1076      774      PT      +++++++++++  PT: Synchronizing extended update info  +++++++++++
2015-05-15      23:20:45:564      1076      774      PT        + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2015-05-15      23:20:46:671      1076      774      Agent        * Found 0 updates and 81 categories in search; evaluated appl. rules of 2144 out of 3858 deployed entities
2015-05-15      23:20:46:671      1076      774      Agent      *********
2015-05-15      23:20:46:671      1076      774      Agent      **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2015-05-15      23:20:46:671      1076      774      Agent      *************
2015-05-15      23:20:46:749      1076      1310      AU      >>##  RESUMED  ## AU: Search for updates [CallId = {355F66F9-8194-4FF2-AD65-E128167AC974}]
2015-05-15      23:20:46:749      1076      1310      AU        # 0 updates detected
2015-05-15      23:20:46:749      1076      1310      AU      #########
2015-05-15      23:20:46:749      1076      1310      AU      ##  END  ##  AU: Search for updates [CallId = {355F66F9-8194-4FF2-AD65-E128167AC974}]
2015-05-15      23:20:46:749      1076      1310      AU      #############
2015-05-15      23:20:46:749      1076      1310      AU      Successfully wrote event for AU health state:0
2015-05-15      23:20:46:749      1076      1310      AU      Featured notifications is disabled.
2015-05-15      23:20:46:749      1076      1310      AU      AU setting next detection timeout to 2015-05-16 00:45:05
2015-05-15      23:20:46:749      1076      1310      AU      Setting AU scheduled install time to 2015-05-16 10:00:00
2015-05-15      23:20:46:749      1076      1310      AU      Successfully wrote event for AU health state:0
2015-05-15      23:20:46:765      1076      1310      AU      Successfully wrote event for AU health state:0
2015-05-15      23:20:51:679      1076      774      Report      REPORT EVENT: {11E4131C-B0E0-4FA5-B5FF-856E21CEED4E}      2015-05-15 23:20:46:671+0200      1      147      101      {00000000-0000-0000-0000-000000000000}      0      0      AutomaticUpdates      Success      Software Synchronization      Windows Update Client successfully detected 0 updates.
2015-05-15      23:20:51:679      1076      774      Report      REPORT EVENT: {E9C7EBF1-8DF5-4BAD-82A3-B70D7EA9DCD8}      2015-05-15 23:20:46:671+0200      1      156      101      {00000000-0000-0000-0000-000000000000}      0      0      AutomaticUpdates      Success      Pre-Deployment Check      Reporting client status.

Ich sollte noch anmerken:
Der Replica soll die Netzwerklast bei der Verteilung reduzieren: Der Upstreamserver steht in unserem 192.168.10er Netz und hat bisher alle Clients problemlos versorgt.
Der Replica steht im 192.168.20er Netz und macht seit seiner Einführung Probleme.
Ich sollte vielleicht auch noch anfügen, dass sich die Clients seit der Umstellung selbst einer Gruppe zuordnen (PC-Nord bzw. PC-Ost -das klappt aber auch.

Hab' keine Idee woran das liegt (bin aber auch kein Experte) und hoffe auf Eure Hilfe.

Vielen Dank!
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients laden keine Updates vom Downstreamserver (Replica)
Antwort #1 - 16.05.15 um 12:15:09
Beitrag drucken  
christophstephan schrieb on 15.05.15 um 23:23:36:
Der Replica soll die Netzwerklast bei der Verteilung reduzieren: Der Upstreamserver steht in unserem 192.168.10er Netz und hat bisher alle Clients problemlos versorgt.
Der Replica steht im 192.168.20er Netz und macht seit seiner Einführung Probleme.
Ich sollte vielleicht auch noch anfügen, dass sich die Clients seit der Umstellung selbst einer Gruppe zuordnen (PC-Nord bzw. PC-Ost -das klappt aber auch.


OK, die beiden Gruppen gibt es auf *beiden* WSUS-Servern? Wurden die Gruppen nach der Aufteilung erstellt? Die Updates sind für diese Gruppen genehmigt? Weißt Du wie du das prüfen kannst? Siehst Du die Clients vom Replica auch auf dem Master? Wie oft läuft die Synchronisierung vom Replica zum Master? Was steht auf dem Replica auf der Startseite beim Downloadstatus?

Auf welchem OS ist der Master und der Replica installiert? Welche exakte Build hat der WSUS vom Master und vom Replica? Wo du das siehst zeigt dir die WSUS-FAQ No. 44: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Das ?-Menü ist nicht relevant dafür.
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
christophstephan
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 3
Standort: Raesfeld
Mitglied seit: 26.09.08
Geschlecht: männlich
Re: Clients laden keine Updates vom Downstreamserver (Replica)
Antwort #2 - 17.05.15 um 07:04:39
Beitrag drucken  
Hallo Sunny,

danke für Dein Feedback.

Zu Deinen Fragen:
- die Gruppen habe ich auf dem Upstreamserver angelegt und sie wurden auf den Replica übertragen, sind also jetzt auf beiden Servern vorhanden.
- die Gruppen habe ich nach der Aufteilung erstellt. Früher gab es nur den Upstreamserver und dort hatte ich seinerzeit die Clients selbst gruppiert.
- Die Updates sind für alle Gruppen genehmigt (vererbt)
- Die Clients des Replica sehe ich auch auf dem Master (umgekehrt aber nicht)
-Autsch: ich glaube hier liegt der Fehler...
die Synchronisierung zwischen Master und Replica hatte ich wie folgt eingerichtet: 1 x täglich automatisiert um 03:40 Uhr Nachts (Eine Stunde nachdem der Master sich mit Microsoft synchronisiert hat). Allerdings unverschlüsselt (Ich wollte das bei der Installation eigentlich anders machen, aber da erhielt ich eine Fehlermeldung mit der ich nix anfangen konnte)

Das lief auch die ersten Tage fehlerfrei deshalb hab ich da gar nicht mehr drauf geachtet, jetzt steht da plötzlich "Fehlgeschlagen":
In der Fehlerbeschreibung steht:
WebException: Die zugrunde liegende Verbindung wurde geschlossen: Unerwarteter Fehler beim Senden.. ---> System.IO.IOException: Fehler bei Handshake wegen eines unerwarteten Paketformats.
bei System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
   bei System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)
   bei Microsoft.UpdateServices.ServerSync.ServerSyncCompressionProxy.GetWebResponse(We
bRequest webRequest)
   bei System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   bei Microsoft.UpdateServices.ServerSyncWebServices.ServerSync.ServerSyncProxy.GetAut
hConfig()
   bei Microsoft.UpdateServices.ServerSync.ServerSyncLib.InternetGetServerAuthConfig(Se
rverSyncProxy proxy, WebServiceCommunicationHelper webServiceHelper)
   bei Microsoft.UpdateServices.ServerSync.ServerSyncLib.Authenticate(AuthorizationMana
ger authorizationManager, Boolean checkExpiration, ServerSyncProxy proxy, Cookie cookie, WebServiceCommunicationHelper webServiceHelper)
   bei Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.SyncConfigUpdatesFromUS
S()
   bei Microsoft.UpdateServi

Der Downloadstatus auf dem Replica ist nun:
Updates die Dateien erfordern: 4131
62.198,50MB von 102.449,06MB heruntergeladen

- Master und Replica laufen auf Server 2008 R2 SP1 (nicht virtualisiert)

- Master und Replica haben beide die Version 3.2.7600.274

Kannst Du mit der Fehlerbeschreibung etwas anfangen?

Danke für Deine Hilfe

=======

Nachtrag:
Hab gerade nochmal die Einstellungen am Replica überprüft: die Fehlermeldung beider Synchronisation stammt von meinem Versuch, nachträglich die SSL Verschlüsselung wieder zu aktivieren. Die hab' ich jetzt wieder rausgenommen, dann läuft die Synchronisation wieder fehlerfrei! Allerdings bleibt der Downloadstatus auf dem Replica unverändert
Updates die Dateien erfordern: 4131
62.198,50MB von 102.449,06MB heruntergeladen

Warum läd der die fehlenden Dateien nicht?

=======
2. Nachtrag:
habe gerade testweise den Replica -Haken rausgenommen und als Updatequelle "Von Microsoft Updatequelle synchronisieren" aktiviert.
Ich erhalte sofort eine Fehlermeldung:

Die WSUS-Verwaltungskonsole konnte keine Verbindung mit der WSUS-Serverdatenbank herstellen.
   
Stellen Sie sicher, dass SQL Server auf dem WSUS-Server ausgeführt wird. Starten Sie SQL erneut, wenn das Problem weiterhin besteht.
   

System.Data.SqlClient.SqlException -- Maximum stored procedure, function, trigger, or view nesting level exceeded (limit 32).
Info:spSetConfiguration - SyncToMU or UpstreamServerName config value changed - no reset

Source
.Net SqlClient Data Provider

Stack Trace:
   bei Microsoft.UpdateServices.UI.AdminApiAccess.UpdateServerConfigurationManager.Save
ServerConfiguration(IUpdateServerConfiguration configuration)
   bei Microsoft.UpdateServices.UI.SnapIn.Dialogs.UssConnectionSettingsDialog.SaveAllSe
ttings()
   bei Microsoft.UpdateServices.UI.SnapIn.Dialogs.BaseSettingsDialog.OKDialogButton_Cli
ck(Object sender, EventArgs e)

Also stimmt wohl etwas mit der Datenbank auf dem Replica nicht, oder?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients laden keine Updates vom Downstreamserver (Replica)
Antwort #3 - 17.05.15 um 12:57:12
Beitrag drucken  
christophstephan schrieb on 17.05.15 um 07:04:39:
- Die Clients des Replica sehe ich auch auf dem Master (umgekehrt aber nicht)


Das ist schon richtig so, auf dem Master siehst Du alle Clients, auf dem Replica nur die Clients, die auch direkt zum Replica berichten.


christophstephan schrieb on 17.05.15 um 07:04:39:
die Synchronisierung zwischen Master und Replica hatte ich wie folgt eingerichtet: 1 x täglich automatisiert um 03:40 Uhr Nachts (Eine Stunde nachdem der Master sich mit Microsoft synchronisiert hat).


Einmal pro Stunde synchronisieren lassen. Damit auf dem Replica nicht zu viele Logs entstehen, lass dieses Script hier regelmässig laufen: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


christophstephan schrieb on 17.05.15 um 07:04:39:
Allerdings unverschlüsselt (Ich wollte das bei der Installation eigentlich anders machen, aber da erhielt ich eine Fehlermeldung mit der ich nix anfangen konnte)


Du kannst natürlich nachträglich die Kommunikation der Clients/Replicas mit dem Master auf SSL umstellen. Hier gibt es ein HowTo dazu: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Aber warte damit bis beide Server mehrere Tage einwandfrei gelaufen sind.

christophstephan schrieb on 17.05.15 um 07:04:39:
Hab gerade nochmal die Einstellungen am Replica überprüft: die Fehlermeldung beider Synchronisation stammt von meinem Versuch, nachträglich die SSL Verschlüsselung wieder zu aktivieren. Die hab' ich jetzt wieder rausgenommen, dann läuft die Synchronisation wieder fehlerfrei! Allerdings bleibt der Downloadstatus auf dem Replica unverändert
Updates die Dateien erfordern: 4131
62.198,50MB von 102.449,06MB heruntergeladen

Warum läd der die fehlenden Dateien nicht?


Wie lange hast Du gewartet? Starte sicherheitshalber beide Server einmal komplett neu durch und warte ein paar Stunden.

christophstephan schrieb on 17.05.15 um 07:04:39:
habe gerade testweise den Replica -Haken rausgenommen und als Updatequelle "Von Microsoft Updatequelle synchronisieren" aktiviert.
Ich erhalte sofort eine Fehlermeldung:

Die WSUS-Verwaltungskonsole konnte keine Verbindung mit der WSUS-Serverdatenbank herstellen.
   
Stellen Sie sicher, dass SQL Server auf dem WSUS-Server ausgeführt wird. Starten Sie SQL erneut, wenn das Problem weiterhin besteht.
   

System.Data.SqlClient.SqlException -- Maximum stored procedure, function, trigger, or view nesting level exceeded (limit 32).
Info:spSetConfiguration - SyncToMU or UpstreamServerName config value changed - no reset

Source
.Net SqlClient Data Provider

Stack Trace:
   bei Microsoft.UpdateServices.UI.AdminApiAccess.UpdateServerConfigurationManager.Save
ServerConfiguration(IUpdateServerConfiguration configuration)
   bei Microsoft.UpdateServices.UI.SnapIn.Dialogs.UssConnectionSettingsDialog.SaveAllSe
ttings()
   bei Microsoft.UpdateServices.UI.SnapIn.Dialogs.BaseSettingsDialog.OKDialogButton_Cli
ck(Object sender, EventArgs e)

Also stimmt wohl etwas mit der Datenbank auf dem Replica nicht, oder?


Nein, lass die Synchronisierung einfach über Nacht laufen. In der Ruhe liegt die Kraft. Zwinkernd
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
AraldoL
WSUS Experte
*****
Offline


I Love WSUS!

Beiträge: 534
Standort: Bayern
Mitglied seit: 11.06.07
Geschlecht: männlich
Re: Clients laden keine Updates vom Downstreamserver (Replica)
Antwort #4 - 17.05.15 um 13:23:37
Beitrag drucken  
christophstephan schrieb on 17.05.15 um 07:04:39:
Updates die Dateien erfordern: 4131
62.198,50MB von 102.449,06MB heruntergeladen

Aua, 102 GByte. Du hast anscheinend nicht nur die Updates genehmigt die von den Clients auch tatsächlich benötigt werden sondern alles was nicht bei 3 auf dem Baum war ...
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients laden keine Updates vom Downstreamserver (Replica)
Antwort #5 - 17.05.15 um 20:13:24
Beitrag drucken  
AraldoL schrieb on 17.05.15 um 13:23:37:
christophstephan schrieb on 17.05.15 um 07:04:39:
Updates die Dateien erfordern: 4131
62.198,50MB von 102.449,06MB heruntergeladen

Aua, 102 GByte. Du hast anscheinend nicht nur die Updates genehmigt die von den Clients auch tatsächlich benötigt werden sondern alles was nicht bei 3 auf dem Baum war ...


Was ist denn der Standard? STRG + A, Rechtsklick > Genehmigen, OK. 3 Tage warten bis die ~100 GB gedownloadet sind. Zwinkernd
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
christophstephan
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 3
Standort: Raesfeld
Mitglied seit: 26.09.08
Geschlecht: männlich
Re: Clients laden keine Updates vom Downstreamserver (Replica)
Antwort #6 - 18.05.15 um 10:14:20
Beitrag drucken  
Hallo Sunny & AraldoL

vielen dank für Euer Feedback.

Nachdem ich endlich gepeilt hatte, dass eine erfolgreiche Synchronisationsmeldung nichts mit dem Download der eigentlichen Daten auf den Downstreamserver zu tun hat und diese im Hintergrund gemütlich weiterläuft, wurde mir das Szenario deutlich klarer.

Der Hinweis auf die Datenmenge brachte mich dazu, mal zu durchforsten, was von den 102GB tatsächlich noch erforderlich ist und was nicht. Dies und der Best Practice - Hinweis, auf Treiber besser zu verzichten, ließ den Datenbestand auf knapp unter 20GB schrumpfen.

Ich hab dann (weil der Datendownload sich von dieser Großreinemach-Aktion gänzlich unbeeindruckt zeigte) den Downstream-Server kurzzeitig umgestellt (Kein Replica mehr und Daten von Microsoft ziehen) und dann wieder zurück. Dan wurde die Download Menge korrekt angezeigt und die noch fehlenden 10GB sind nun auch fast komplett auf dem Downstream Server angekommen.

Die Clients haben sich auch bereits gemeldet und ziehen fleißig Updates vom Replica und melden brav zurück. Es ist also alles so, wie es sein soll.

Vielen Dank nochmal für Eure Hilfe!!! Durchgedreht
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13101
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients laden keine Updates vom Downstreamserver (Replica)
Antwort #7 - 18.05.15 um 10:25:35
Beitrag drucken  
Freut mich für Dich und Danke für die Rückmeldung. Zwinkernd
  

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Zum Seitenanfang
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden