Heißes Thema (mehr als 10 Antworten) Frisch aufgesetzte XPSP3 Clients ziehen keine Updates (Gelesen: 839 mal)
QandA
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 20
Mitglied seit: 07.03.13
Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
23.02.16 um 11:15:22
Beitrag drucken  
Hallo zusammen,

ich habe einen WSUS auf Server2012R2 mit SSL (nach der Anleitung von WSUS.de) laufen. Alte XP Clients (aus Image Bestand mit neuer WU ID) und Win7/Server2008R2 laufen.
Jetzt habe ich eine neue VM aufgesetzt mit XPSP3. Der Client kann sich nicht beim WSUS melden, also keinen Bericht erstellen.
Auszug aus dem Windows Update Log:
Quote:
2016-02-23      11:03:52+0100      1068      530      Created new event cache file at C:\WINDOWS\SoftwareDistribution\EventCache\{93C38D51-6128-4C2F-8FC9-9E6E5243DBED
}.bin for writing.
2016-02-23      11:03:52+0100      1068      530      REPORT EVENT: {19B67A15-AE6A-4D63-B8C7-F7B64EC2C2A9}      11      2016-02-23 11:03:48+0100      1      148      101      {00000000-0000-0000-0000-000000000000}      0      80248008      AutomaticUpdates      Failure      Software Synchronization      Error: Agent failed detecting with reason: 0x80248008
2016-02-23      11:03:52+0100      1068      530      REPORT EVENT: {4C94A52C-4FCF-41BF-8567-FD75E11910DD}      10      2016-02-23 11:03:47+0100      1      148      101      {D67661EB-2423-451D-BF5D-13199E37DF28}      0      80072efd      SelfUpdate      Failure      Software Synchronization      Error: Agent failed detecting with reason: 0x80072efd
2016-02-23      11:03:48+0100      1068      6ec      WU client completed and deleted call {D8FF5069-878E-40DC-B54C-1D7C027DE944}
2016-02-23      11:03:48+0100      1068      6ec      WU client calls back to search call AutomaticUpdates with code Call failed and error 0x80248008
2016-02-23      11:03:48+0100      1068      6ec      Setting next AU detection timeout to 2016-02-23 10:58:56
2016-02-23      11:03:48+0100      1068      6ec      Search Callback Failed, hr is 0x80248008
2016-02-23      11:03:48+0100      1068      6ec      WU client failed Searching for update with error 0x80248008
2016-02-23      11:03:48+0100      1068      6ec      PT: Using serverID {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}
2016-02-23      11:03:47+0100      1068      6ec      IsUpdateRequired failed with error 0x80072efd
2016-02-23      11:03:47+0100      1068      6ec      DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). error 0x80072efd
2016-02-23      11:03:47+0100      1068      6ec      SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
2016-02-23      11:03:47+0100      1068      6ec      Send failed with hr = 80072efd.
2016-02-23      11:03:46+0100      1068      6ec      SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
2016-02-23      11:03:46+0100      1068      6ec      Send failed with hr = 80072efd.
2016-02-23      11:03:45+0100      1068      6ec      SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
2016-02-23      11:03:45+0100      1068      6ec      Send failed with hr = 80072efd.
2016-02-23      11:03:44+0100      1068      6ec      SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
2016-02-23      11:03:44+0100      1068      6ec      Send failed with hr = 80072efd.
2016-02-23      11:03:43+0100      1068      6ec      WU client executing call {D8FF5069-878E-40DC-B54C-1D7C027DE944} of type Search Call
2016-02-23      11:03:43+0100      1068       dc      WU client succeeds CClientCallRecorder::BeginFindUpdates from AutomaticUpdates with call id {D8FF5069-878E-40DC-B54C-1D7C027DE944}
2016-02-23      11:03:43+0100      1068       dc      AU received event of 1
2016-02-23      11:03:43+0100      1068      568      Triggering AU detection through DetectNow api


Auszug aus dem Reporting Events Log:
Quote:
{11C3DAB3-61E7-4989-9B4F-BE4029D7F6C0}      9      2016-02-23 10:53:02+0100      1      148      101      {00000000-0000-0000-0000-000000000000}      0      80248008      AutomaticUpdates      Failure      Software Synchronization      Error: Agent failed detecting with reason: 0x80248008
{BAD13C2F-C1FE-45DE-A23F-B1EC9841A1D4}      8      2016-02-23 10:53:01+0100      1      148      101      {D67661EB-2423-451D-BF5D-13199E37DF28}      0      80072efd      SelfUpdate      Failure      Software Synchronization      Error: Agent failed detecting with reason: 0x80072efd


Auf dem CLient kann ich:
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
-> Laufzeitfehler:
Quote:
Serverfehler in der Anwendung /ClientWebService.
--------------------------------------------------------------------------------


Laufzeitfehler
Beschreibung: Anwendungsfehler auf dem Server. Aufgrund der aktuellen benutzerdefinierten Fehlereinstellungen für diese Anwendung können die Details des Anwendungsfehlers (aus Sicherheitsgründen) nicht remote angezeigt werden. Sie können jedoch von Browsern angezeigt werden, die auf dem lokalen Server ausgeführt werden.

Details: Sie können die Details dieser Fehlermeldung auf dem lokalen Computer anzeigen, indem Sie ein <customErrors>-Tag in der Konfigurationsdatei web.config erstellen, die sich im Stammverzeichnis der aktuellen Webanwendung befindet. Das mode-Attribut dieses <customErrors>-Tags sollte dann auf "Off" festgelegt werden.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>

Hinweise: Die aktuelle Seite kann durch eine benutzerdefinierte Fehlerseite ersetzt werden, indem Sie das defaultRedirect-Attribut des <customErrors>-Konfigurationstags dieser Anwendung so setzen, das es auf einen benutzerdefinierten Fehlerseiten-URL zeigt.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>



(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
-> Erreichen (GetAuthorizationCookie, Ping)

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
-> Erreichen und die Datei Speichern.

Aber irgendwie werde ich nicht schlau daraus.
- FireWall ist aus
- SoftwareDistribution gelöscht, Dienstneustart usw.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #1 - 23.02.16 um 11:34:38
Beitrag drucken  
Vermutlich bist Du in ein Henne/Ei Problem gelaufen. Der Client kann womöglich der dort geforderten Authentifizierung noch nichts anfangen, weil er nicht up2date ist.

Der Client kann den WSUS pingen? Ausnahme in den Proxysettings gesetzt?

Geh doch mal auf Windows Update Online, hol dort die Updates und probier es dann erneut. Bevor jetzt die Frage nach der Sinnhaftigkeit des SSL kommt, XPSP3 ist out of Support seit 2014.
  
Zum Seitenanfang
 
QandA
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 20
Mitglied seit: 07.03.13
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #2 - 23.02.16 um 11:47:30
Beitrag drucken  
Moin Sunny,
das habe ich auch vermutet. Vergessen zu schreiben, Namensauflöung und Ping funktionieren auch, Proxy gibt es keinen und ist keiner konfiguriert.
Das seltsame ist ich hatte vorher eine Testmaschiene die sich Patchen lies. Nur war sie vorher kurz am anderen Standort und ggf. hat sie vom dortigen WSUS (ohne SSL) was gezogen und den Rest nach verschieben im AD (war nicht schnell genug) dann vom SSL WSUS.
  
Zum Seitenanfang
 
QandA
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 20
Mitglied seit: 07.03.13
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #3 - 23.02.16 um 12:04:56
Beitrag drucken  
Da scheint es wohl noch andere Probleme zu geben. Starte ich im IE Windows Update lädt er auch kurz die richtige Seite. Dann lande ich auf (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Griesgrämig. Mal sehen was hilft.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #4 - 23.02.16 um 13:14:20
Beitrag drucken  
QandA schrieb on 23.02.16 um 12:04:56:
Da scheint es wohl noch andere Probleme zu geben. Starte ich im IE Windows Update lädt er auch kurz die richtige Seite. Dann lande ich auf (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Griesgrämig. Mal sehen was hilft.



Das dort angebotene Tool downloaden und loslegen, oder funktioniert das nicht? Alternativ das dort angebotene manuell ausführen.
  
Zum Seitenanfang
 
QandA
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 20
Mitglied seit: 07.03.13
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #5 - 23.02.16 um 13:18:44
Beitrag drucken  
Ich hatte alles manuell gemacht, aber dann habe die Maschine auf den alten WSUS verschoben.
Danach:
Quote:
{01BC30CF-E152-4300-9190-05F3A184651B}      2016-02-23 12:07:35:861+0100      1      183      101      {D67661EB-2423-451D-BF5D-13199E37DF28}      0      0      SelfUpdate      Success      Content Install      Installation Successful: Windows successfully installed the following update: Automatische Updates
{8E42F4B3-E407-4B4A-B73D-BFE34B5DFBFF}      15      2016-02-23 12:07:32+0100      1      201      101      {D67661EB-2423-451D-BF5D-13199E37DF28}      0      0      SelfUpdate      Success      Content Install      Installation pending.
{68A76678-19C7-4A3E-9A52-5A7167085055}      14      2016-02-23 12:07:25+0100      1      162      101      {D67661EB-2423-451D-BF5D-13199E37DF28}      0      0      SelfUpdate      Success      Content Download      Download succeeded.
{07A84DC9-2993-4D2C-8CDC-20A57F8A99E3}      13      2016-02-23 11:59:41+0100      1      148      101      {00000000-0000-0000-0000-000000000000}      0      80248008      AutomaticUpdates      Failure      Software Synchronization

Im Anschluss konnte er die Updates vom SSL WSUS ziehen.
Liegt also wohl an Henne/Ei/SSL Zwinkernd
Es scheint das Update KB910437 zu sein. Aber im Web bei MS kriegt mand as nicht mehr. Kann man das irgendwie aus dem WSUS extrahieren und manuell installieren?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #6 - 23.02.16 um 14:17:22
Beitrag drucken  
QandA schrieb on 23.02.16 um 13:18:44:
Im Anschluss konnte er die Updates vom SSL WSUS ziehen.
Liegt also wohl an Henne/Ei/SSL Zwinkernd
Es scheint das Update KB910437 zu sein. Aber im Web bei MS kriegt mand as nicht mehr. Kann man das irgendwie aus dem WSUS extrahieren und manuell installieren?


Wenn Du es im WSUS siehst und lokalisieren kannst, dann hast Du ja auch eine ID stehen bei dem Update, mit der kannst Du im Content auf die Suche gehen.
  
Zum Seitenanfang
 
QandA
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 20
Mitglied seit: 07.03.13
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #7 - 24.02.16 um 13:58:46
Beitrag drucken  
Ok jetzt muss ich noch mal fragen. Ich kann das KB910437 unter Updates suchen und die "Eigenschaften" ansehen. Aber eine ID sehe ich nicht. Im WsusContent Ordner haben die ja alle nur diese ellen lange ID :/.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #8 - 24.02.16 um 22:57:17
Beitrag drucken  
QandA schrieb on 24.02.16 um 13:58:46:
Ok jetzt muss ich noch mal fragen. Ich kann das KB910437 unter Updates suchen und die "Eigenschaften" ansehen. Aber eine ID sehe ich nicht. Im WsusContent Ordner haben die ja alle nur diese ellen lange ID :/.



Ich hab jetzt keinen WSUS greifbar, aber man sieht schon den langen Ordnernamen. Klick das Update in der Ansicht an, im unteren Teil ist das zu finden, was Du suchst.
  
Zum Seitenanfang
 
QandA
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 20
Mitglied seit: 07.03.13
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #9 - 07.04.16 um 11:04:09
Beitrag drucken  
So, späte Rückmeldung. Hatte gefunden, was du meintest. Das reichte aber nicht. Lösung für die, die sich noch mit "frischen" XP Clients rumschlagen müssen. Der einfachste weg geht über das Tool vom Herrn Führer, dem WSUS Helper (gibt es auch hier). Dort mit dem entsprechenden PC verbinden, oder lokal ausführen, und dann den Button "Reinstall Agent" klicken. Die Neue Version kann dann ein SelfUpdate beim WSUS ausführen und weiter machen.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13104
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Frisch aufgesetzte XPSP3 Clients ziehen keine Updates
Antwort #10 - 07.04.16 um 11:36:45
Beitrag drucken  
Na wunderbar, freut mich für Dich und Danke für die Rückmeldung. Zwinkernd
  
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden