Heißes Thema (mehr als 10 Antworten) WSUS-Dienst läuft nicht mehr... (Gelesen: 1912 mal)
Machu
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 7
Mitglied seit: 02.06.08
WSUS-Dienst läuft nicht mehr...
13.06.08 um 11:05:56
Beitrag drucken  
hallo ich habe schon stunden lang gegooglet u.s.w. aber nichts für meinen fall gefunden!

der wsus läuft nicht mehr... habe versucht ihn zu starten, brachte aber alles nichts deshalb wollte ich einfach neu install! habe versucht zu deinstall, geht leider nicht! komischerweise sind die registry-einträge entfernt... ich habe keine ahnung was da schief gelaufen ist!

einfach neu install geht auch nicht...
hier die fehlermeldung beim neu install:
2008-06-13 10:48:47  Success   MWUSSetup          WSUS Server Setup Started.
2008-06-13 10:48:47  Success   MWUSSetup          Parsing command line arguments
2008-06-13 10:48:47  Success   MWUSSetup          WSUS Setup: Performing Install
2008-06-13 10:48:48  Success   MWUSSetup          Validating pre-requisites
2008-06-13 10:48:48  Success   MWUSSetup          .Net framework SP1 is detected on this machine
2008-06-13 10:48:48  Success   MWUSSetup          Creating WSUS registry key
2008-06-13 10:48:48  Success   MWUSSetup          Initializing installation details
2008-06-13 10:48:48  Success   MWUSSetup          Initializing wizard
2008-06-13 10:48:53  Error     MWUSSetup          GetProcAddress failed in SKU Check (Error 0x8007007F: Die angegebene Prozedur wurde nicht gefunden.)
2008-06-13 10:48:53  Error     MWUSSetup          GetSqlFlavor failed (Error 0x8007007F: Die angegebene Prozedur wurde nicht gefunden.)
2008-06-13 10:48:53  Error     MWUSSetup          Failed to determine Sql type of instance. Assuming it to be SQL... (Error 0x8007007F: Die angegebene Prozedur wurde nicht gefunden.)
2008-06-13 10:48:58  Success   MWUSSetup          Installing ASP.Net
2008-06-13 10:49:20  Success   MWUSSetup          Asp.Net is installed successfully
2008-06-13 10:49:20  Success   MWUSSetup          ASP.Net is installed successfully
2008-06-13 10:49:20  Success   MWUSSetup          MSXML2 is already installed on this machine
2008-06-13 10:49:21  Success   MWUSSetup          Installing WMSDE
2008-06-13 10:50:13  Success   MWUSSetup          WMSDE Installed Successfully
2008-06-13 10:50:15  Success   MWUSSetup          WMSDE is installed successfully
2008-06-13 10:50:15  Success   MWUSSetup          Initializing MWUS installation
2008-06-13 10:50:15  Success   MWUSSetup          Installing PSFSIP
2008-06-13 10:50:15  Success   MWUSSetup          VerInstallFile return code: 7
2008-06-13 10:50:15  Error     MWUSSetup          Failed to install PSFSIP (Error 0x80004005: Unbekannter Fehler)
2008-06-13 10:50:15  Error     MWUSSetup          InstallPSFSIP failed (Error 0x80004005: Unbekannter Fehler)
2008-06-13 10:50:15  Error     MWUSSetup          Installation of PSFSIP failed (Error 0x80004005: Unbekannter Fehler)
2008-06-13 10:50:15  Error     MWUSSetup          PerformInstall failed (Error 0x80004005: Unbekannter Fehler)
2008-06-13 10:50:15  Success   MWUSSetup          Rolling back Installation
2008-06-13 10:50:15  Success   MWUSSetup          WSUS Server installation failed. You can look at C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1048.log file to determine the cause of the failure
2008-06-13 10:51:10  Success   MWUSSetup          WMSDE Uninstall Succeeded
2008-06-13 10:51:10  Error     MWUSSetup          Failed to copy Setup\UninstallHelper.exe to C:\DOKUME~1\ADMINI~1\LOKALE~1\Temp\UninstallHelper.exe (Error 0x80070003: Das System kann den angegebenen Pfad nicht finden.)
2008-06-13 10:51:10  Success   MWUSSetup          Insert string: %1 Weitere Informationen erhalten Sie im Setup-Protokoll "%2".
2008-06-13 10:51:10  Success   MWUSSetup          szErrorType: Microsoft Windows Server Update Services konnte PSFSIP nicht installieren.
2008-06-13 10:51:10  Success   MWUSSetup          ErrorLog: C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1048.log
2008-06-13 10:51:10  Success   MWUSSetup          StringObtained: Microsoft Windows Server Update Services konnte PSFSIP nicht installieren. Weitere Informationen erhalten Sie im Setup-Protokoll "C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1048.log".

beim deinstall:
2008-06-13 11:02:08  Error     MWUSSetup          Wsus 3.0 is not installed. The only possible setup actions are full install and console-only install (Error 0x80041453)
2008-06-13 11:02:15  Error     MWUSSetup          DoInstall: ParseCommandLine failed (Error 0x80041453)
2008-06-13 11:02:35  Error     MWUSSetup          Wsus 3.0 is not installed. The only possible setup actions are full install and console-only install (Error 0x80041453)
2008-06-13 11:02:37  Error     MWUSSetup          DoInstall: ParseCommandLine failed (Error 0x80041453)
2008-06-13 11:03:03  Error     MWUSSetup          Wsus 3.0 is not installed. The only possible setup actions are full install and console-only install (Error 0x80041453)
2008-06-13 11:03:04  Error     MWUSSetup          DoInstall: ParseCommandLine failed (Error 0x80041453)

mein system
wsus 3.0 SP1 auf windows server sbs 2003 SP2
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13250
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS-Dienst läuft nicht mehr...
Antwort #1 - 13.06.08 um 12:42:26
Beitrag drucken  
Machu schrieb on 13.06.08 um 11:05:56:
hallo ich habe schon stunden lang gegooglet u.s.w. aber nichts für meinen fall gefunden!


Scheint auch einmalig zu sein.

Machu schrieb on 13.06.08 um 11:05:56:
der wsus läuft nicht mehr... habe versucht ihn zu starten, brachte aber alles nichts deshalb wollte ich einfach neu install!


Schlechte Idee. Vorher fragen ist immer die bessere Alternative. Und ie Aussage: "brachte aber alles nichts" ist schon sehr aussagekräftig.


Machu schrieb on 13.06.08 um 11:05:56:
habe versucht zu deinstall, geht leider nicht! komischerweise sind die registry-einträge entfernt... ich habe keine ahnung was da schief gelaufen ist!


Hmm, sorry für die harten Worte, aber ja, das merkt man.

Machu schrieb on 13.06.08 um 11:05:56:
einfach neu install geht auch nicht...
hier die fehlermeldung beim neu install:


In dem von dir geposteten Ausschnitt gibts noch andere Logdateien. Findest Du dort genauere Hinweise?

Geh mal diesen Thread durch: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
Machu
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 7
Mitglied seit: 02.06.08
Re: WSUS-Dienst läuft nicht mehr...
Antwort #2 - 13.06.08 um 13:21:21
Beitrag drucken  
hallo sunny!

danke für deine erste fixe antwort...

den thread von dir habe ich mir gereits angeschaut... ich denk mal das es an den nicht vorhandenen registry einträgen liegt! nur leider ist der anhang den du da hinterlassen hast gelöscht  weinend

Quote:
Hmm, sorry für die harten Worte, aber ja, das merkt man.


ja ich geb ja zu das ich nicht der guru auf dem gebiet bin, nur leider hab e ich das system schon so übernommen

Quote:
In dem von dir geposteten Ausschnitt gibts noch andere Logdateien. Findest Du dort genauere Hinweise?


ist genau der selbe log...
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13250
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS-Dienst läuft nicht mehr...
Antwort #3 - 13.06.08 um 13:51:41
Beitrag drucken  
Dann probiers mit dieser. Der Anhang ist eine TXT, abspeichern und die Endung auf REG ändern, dann mit Doppelklick auf dem WSUS importieren.
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). ( 12 KB | Downloads )
Zum Seitenanfang
 
Machu
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 7
Mitglied seit: 02.06.08
Re: WSUS-Dienst läuft nicht mehr...
Antwort #4 - 13.06.08 um 14:56:12
Beitrag drucken  
regitry eintäge sind jetzt da (pfade stimmen auch)

nur leider klappt die deinstall nicht, immer noch die selbe fehlermeldung!
ich versteh das net...

  • "C:\Programme\Update Services\Service\bin\WsusService.exe" läuft nun wieder

  • "C:\Programme\Update Services\Service\bin\WsusCertServer.exe" läuft aber nicht... kann angeblich den pfad nicht finden! ist aber der richtige ?!?!?!

  • beim start des snap-in kommt auch ne fehlermeldung (siehe anhang)


ich habe festgestellt das die sql-db fehlt... ich frag mich was der hier vorher gemacht hat!  unentschlossen mir kommt es so vor als ob der halbe system-ordner fehler würde!

das install geht auch nicht, selbe fehlermeldung:
2008-06-13 14:24:40  Success   MWUSSetup          WSUS Server Setup Started.
2008-06-13 14:24:40  Success   MWUSSetup          Parsing command line arguments
2008-06-13 14:24:40  Success   MWUSSetup          WSUS Setup: Performing Install
2008-06-13 14:24:41  Success   MWUSSetup          Validating pre-requisites
2008-06-13 14:24:41  Success   MWUSSetup          .Net framework SP1 is detected on this machine
2008-06-13 14:24:41  Success   MWUSSetup          Creating WSUS registry key
2008-06-13 14:24:41  Success   MWUSSetup          Initializing installation details
2008-06-13 14:24:41  Success   MWUSSetup          Initializing wizard
2008-06-13 14:25:01  Error     MWUSSetup          GetProcAddress failed in SKU Check (Error 0x8007007F: Die angegebene Prozedur wurde nicht gefunden.)
2008-06-13 14:25:01  Error     MWUSSetup          GetSqlFlavor failed (Error 0x8007007F: Die angegebene Prozedur wurde nicht gefunden.)
2008-06-13 14:25:01  Error     MWUSSetup          Failed to determine Sql type of instance. Assuming it to be SQL... (Error 0x8007007F: Die angegebene Prozedur wurde nicht gefunden.)
2008-06-13 14:25:54  Success   MWUSSetup          Installing ASP.Net
2008-06-13 14:26:03  Success   MWUSSetup          Asp.Net is installed successfully
2008-06-13 14:26:03  Success   MWUSSetup          ASP.Net is installed successfully
2008-06-13 14:26:03  Success   MWUSSetup          MSXML2 is already installed on this machine
2008-06-13 14:26:03  Success   MWUSSetup          Installing WMSDE
2008-06-13 14:26:49  Success   MWUSSetup          WMSDE Installed Successfully
2008-06-13 14:26:51  Success   MWUSSetup          WMSDE is installed successfully
2008-06-13 14:26:51  Success   MWUSSetup          Initializing MWUS installation
2008-06-13 14:26:51  Success   MWUSSetup          Installing PSFSIP
2008-06-13 14:26:51  Success   MWUSSetup          VerInstallFile return code: 7
2008-06-13 14:26:51  Error     MWUSSetup          Failed to install PSFSIP (Error 0x80004005: Unbekannter Fehler)
2008-06-13 14:26:51  Error     MWUSSetup          InstallPSFSIP failed (Error 0x80004005: Unbekannter Fehler)
2008-06-13 14:26:51  Error     MWUSSetup          Installation of PSFSIP failed (Error 0x80004005: Unbekannter Fehler)
2008-06-13 14:26:51  Error     MWUSSetup          PerformInstall failed (Error 0x80004005: Unbekannter Fehler)
2008-06-13 14:26:51  Success   MWUSSetup          Rolling back Installation
2008-06-13 14:26:51  Success   MWUSSetup          WSUS Server installation failed. You can look at C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1424.log file to determine the cause of the failure
2008-06-13 14:27:34  Success   MWUSSetup          WMSDE Uninstall Succeeded
2008-06-13 14:27:34  Error     MWUSSetup          Failed to copy Setup\UninstallHelper.exe to C:\DOKUME~1\ADMINI~1\LOKALE~1\Temp\UninstallHelper.exe (Error 0x80070003: Das System kann den angegebenen Pfad nicht finden.)
2008-06-13 14:27:34  Success   MWUSSetup          Insert string: %1 Weitere Informationen erhalten Sie im Setup-Protokoll "%2".
2008-06-13 14:27:34  Success   MWUSSetup          szErrorType: Microsoft Windows Server Update Services konnte PSFSIP nicht installieren.
2008-06-13 14:27:34  Success   MWUSSetup          ErrorLog: C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1424.log
2008-06-13 14:27:34  Success   MWUSSetup          StringObtained: Microsoft Windows Server Update Services konnte PSFSIP nicht installieren. Weitere Informationen erhalten Sie im Setup-Protokoll "C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1424.log".
2008-06-13 14:27:56  Error     MWUSSetup          WSUS Setup: Performing Install Failed. (Error 0x80004005: Unbekannter Fehler)
2008-06-13 14:27:56  Error     MWUSSetup          WSUS Setup Failed. (Error 0x80004005: Unbekannter Fehler)

  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13250
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS-Dienst läuft nicht mehr...
Antwort #5 - 13.06.08 um 15:12:32
Beitrag drucken  
Der Fehler Error 0x80004005 deutet auf Berechtigungsprobleme hin. Schau mal im Eventlog ob Du was findest. Access Denied. Mit welchem Benutzerkontor wird der Dienst Update Services gestartet?

Was genau steht in diesem Log?
C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1424.log
Hier hochladen und den Link posten: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Gibts diesen Pfad? C:\DOKUME~1\ADMINI~1\LOKALE~1\Temp
Wenn ja, wie sind die NTFS-Berechtigungen vergeben?

Kannst Du den WSUS denn jetzt deinstallieren? Das ist vermutlich zuerst die bessere Variante. Wenn das klappt, Neustart und wieder installieren.
  
Zum Seitenanfang
 
Machu
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 7
Mitglied seit: 02.06.08
Re: WSUS-Dienst läuft nicht mehr...
Antwort #6 - 13.06.08 um 15:34:36
Beitrag drucken  
Der Fehler Error 0x80004005 deutet auf Berechtigungsprobleme hin. Schau mal im Eventlog ob Du was findest. Access Denied. Mit welchem Benutzerkontor wird der Dienst Update Services gestartet?

wird vom lokalen systemkonto gestartet... dürfte also nicht das prob sein

Was genau steht in diesem Log?
C:\Programme\Update Services\LogFiles\WSUSSetup_080613_1424.log
Hier hochladen und den Link posten: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Gibts diesen Pfad? C:\DOKUME~1\ADMINI~1\LOKALE~1\Temp
Wenn ja, wie sind die NTFS-Berechtigungen vergeben?

der pfad existert, es besteht vollzugriff!

Kannst Du den WSUS denn jetzt deinstallieren? Das ist vermutlich zuerst die bessere Variante. Wenn das klappt, Neustart und wieder installieren.

geht nicht zu deinstall (siehe anhang) hier nochmal die wsussetup.log... (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). fehler2.JPG (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13250
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS-Dienst läuft nicht mehr...
Antwort #7 - 13.06.08 um 16:09:17
Beitrag drucken  
Setz mal in der Registry wYukonInstalled von 1 auf 0 und probier die Deinstallation nochmal.
  
Zum Seitenanfang
 
Machu
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 7
Mitglied seit: 02.06.08
Re: WSUS-Dienst läuft nicht mehr...
Antwort #8 - 13.06.08 um 16:35:11
Beitrag drucken  
kommt die selbe meldung:

2008-06-13 16:31:26  Error     MWUSSetup          Wsus 3.0 is not installed. The only possible setup actions are full install and console-only install (Error 0x80041453)
2008-06-13 16:31:28  Error     MWUSSetup          DoInstall: ParseCommandLine failed (Error 0x80041453)
2008-06-13 16:31:30  Error     MWUSSetup          Wsus 3.0 is not installed. The only possible setup actions are full install and console-only install (Error 0x80041453)
2008-06-13 16:31:32  Error     MWUSSetup          DoInstall: ParseCommandLine failed (Error 0x80041453)

aber warum gibt der aus das wsus angeblich nicht install ist?  hä?
  
Zum Seitenanfang
 
Machu
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 7
Mitglied seit: 02.06.08
Re: WSUS-Dienst läuft nicht mehr...
Antwort #9 - 13.06.08 um 16:38:06
Beitrag drucken  
Quote:
aber warum gibt der aus das wsus angeblich nicht install ist?  hä?


habe gerade mal das windows installer clean up - tool gestartet (war schon istalliert) ... dorf steht komischer weise nichts von wsus drin ! ! ! ! ! !
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13250
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS-Dienst läuft nicht mehr...
Antwort #10 - 14.06.08 um 00:36:30
Beitrag drucken  
Machu schrieb on 13.06.08 um 16:35:11:
aber warum gibt der aus das wsus angeblich nicht install ist?  hä?


Ich hab keine Idee mehr.  Griesgrämig
  
Zum Seitenanfang
 
Machu
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 7
Mitglied seit: 02.06.08
Re: WSUS-Dienst läuft nicht mehr...
Antwort #11 - 24.06.08 um 10:08:19
Beitrag drucken  
Quote:
Ich hab keine Idee mehr...


ICH HABS HINBEKOMMEN ! ! ! ! JUHHHU ! ! ! ! ! ! !  Durchgedreht Durchgedreht Durchgedreht Durchgedreht Durchgedreht Durchgedreht Durchgedreht

DANK DIR TROTZDEM FÜR DEINE HILFE ! ! ! ! ! !  Smiley Smiley Smiley Smiley Smiley Smiley Smiley Smiley Smiley Smiley
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13250
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS-Dienst läuft nicht mehr...
Antwort #12 - 24.06.08 um 10:39:29
Beitrag drucken  
Und was war die Lösung?
  
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden