Seitenindex umschalten Seiten: [1] 2  Thema versendenDrucken
Heißes Thema (mehr als 10 Antworten) Problem mit GPO (Gelesen: 2956 mal)
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Problem mit GPO
14.05.09 um 09:25:51
Beitrag drucken  
Hallo zusammen...

Ich hab den WSUS 3.0 SP1 auf einem SBS2003 Server installiert.
Die installation sowie die das Herunterladen der Updates hat alles super geklappt!

Nun wollte ich noch die Clients in den WSUS einbinden. Wie ich gelesen habe, gibt es dafür eine tolle Variante mit den Gruppenrichtlinien.

Nun zu meinem Problem:
Die Gruppenrichtlinie namens WSUS, welche ich erfasst habe, verteilt sich nicht auf die Clients. Wenn ich bei den Clients im GPO-Editor schaue, sind dort alle Einstellung, welche übernommen werden sollten, auf "nicht konfiguriert" gestellt.

Was kann hier das Problem sein?

Als Anhang sende ich euch noch ein PrtScr von der GPMC.

Vielen Dank für eure Hilfe

PS: @benutze zuerst die Suchfunktion: habe ich getan  Zwinkernd
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). 14_05.png (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Problem mit GPO
Antwort #1 - 14.05.09 um 09:36:12
Beitrag drucken  
JSUS schrieb on 14.05.09 um 09:25:51:
Nun wollte ich noch die Clients in den WSUS einbinden. Wie ich gelesen habe, gibt es dafür eine tolle Variante mit den Gruppenrichtlinien.


Zu deinem Bildchen. Das sind keine Container, das sind OUs. Bitte mach dich dazu schlau, die richtigen Begriffe zu kennen und zu benutzen ist schon sehr wichtig.

JSUS schrieb on 14.05.09 um 09:25:51:
Die Gruppenrichtlinie namens WSUS, welche ich erfasst habe, verteilt sich nicht auf die Clients. Wenn ich bei den Clients im GPO-Editor schaue, sind dort alle Einstellung, welche übernommen werden sollten, auf "nicht konfiguriert" gestellt.

Was kann hier das Problem sein?



Der Möchtegern-Admin vor Ort. Der lokale GPO-Editor > GPEDIT.MSC hat mit den GPOs der Domain nichts zu tun. Hier kannst Du lokale Einstellungen definieren, die dann nur für den Client und alle darauf angelegten Benutzer gelten. RSOP.MSC suchst Du.

Desweiteren willst Du (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). auswendig lernen. Zwinkernd
  
Zum Seitenanfang
 
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Re: Problem mit GPO
Antwort #2 - 14.05.09 um 09:53:26
Beitrag drucken  
Danke für die schnelle Antwort.

Sorry das ich nicht "Organisation Unit" gesagt habe..  Zwinkernd
Mein Kopf wurde in den letzten Wochen mit so vielen Begriffen bombadiert, da kann mir mal ein "kleiner" Fehler unterlaufen! Zwinkernd

Aso in diesem Fall muss ich die Gruppenrichtlinien-Einstellungen auf den Clients mit dem Befehl RSOP.MSC überprüfen???

Wenn die dort drin sind, sollte es theoretisch funktionieren?

  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Problem mit GPO
Antwort #3 - 14.05.09 um 10:47:41
Beitrag drucken  
JSUS schrieb on 14.05.09 um 09:53:26:
Sorry das ich nicht "Organisation Unit" gesagt habe..  Zwinkernd
Mein Kopf wurde in den letzten Wochen mit so vielen Begriffen bombadiert, da kann mir mal ein "kleiner" Fehler unterlaufen! Zwinkernd


Der Unterschied ist an dieser Stelle sehr wichtig. Auf einen Container kannst Du keine GPO verknüpfen, auf eine OU schon.

JSUS schrieb on 14.05.09 um 09:53:26:
Aso in diesem Fall muss ich die Gruppenrichtlinien-Einstellungen auf den Clients mit dem Befehl RSOP.MSC überprüfen???


Genau.

JSUS schrieb on 14.05.09 um 09:53:26:
Wenn die dort drin sind, sollte es theoretisch funktionieren?


Und auch praktisch. Zwinkernd Melden sich die Clients nicht in der WSUS-Konsole? Kontrollier die %windir%\Windowsupdate.log nach Fehlern.
  
Zum Seitenanfang
 
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Re: Problem mit GPO
Antwort #4 - 14.05.09 um 11:20:52
Beitrag drucken  
Hier ein paar auszüge aus der Log-Datei
Code
2009-05-13	02:04:27:354	 916	d14	AU	#############
2009-05-13	02:04:27:369	 916	d14	AU	## START ##  AU: Search for updates
2009-05-13	02:04:27:369	 916	d14	AU	#########
2009-05-13	02:04:27:432	 916	d14	AU	<<## SUBMITTED ## AU: Search for updates [CallId = {8EB1CDA3-81A6-4824-B4C2-D87975F79333}]
2009-05-13	02:04:27:432	 916	1a08	Agent	*************
2009-05-13	02:04:27:432	 916	1a08	Agent	** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
2009-05-13	02:04:27:432	 916	1a08	Agent	*********
2009-05-13	02:04:27:432	 916	1a08	Agent	  * Online = Yes; Ignore download priority = No
2009-05-13	02:04:27:432	 916	1a08	Agent	  * Criteria = "IsHidden=0 and IsInstalled=0 and DeploymentAction='Installation' and IsAssigned=1 or IsHidden=0 and IsPresent=1 and DeploymentAction='Uninstallation' and IsAssigned=1 or IsHidden=0 and IsInstalled=1 and DeploymentAction='Installation' and IsAssigned=1 and RebootRequired=1 or IsHidden=0 and IsInstalled=0 and DeploymentAction='Uninstallation' and IsAssigned=1 and RebootRequired=1"
2009-05-13	02:04:27:432	 916	1a08	Agent	  * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}
2009-05-13	02:04:27:432	 916	1a08	Agent	  * Search Scope = {Machine}
2009-05-13	02:04:27:541	 916	1a08	Misc	Validating signature for C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wuident.cab:
2009-05-13	02:04:27:823	 916	1a08	Misc	 Microsoft signed: Yes
2009-05-13	02:04:27:854	 916	1a08	Misc	WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80190194
2009-05-13	02:04:27:854	 916	1a08	Misc	WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80190194
2009-05-13	02:04:27:854	 916	1a08	Misc	WARNING: DownloadFileInternal failed for http://*HierStehtDerServerName*/selfupdate/wuident.cab: error 0x80190194
2009-05-13	02:04:27:854	 916	1a08	Setup	FATAL: IsUpdateRequired failed with error 0x80244019
2009-05-13	02:04:27:916	 916	1a08	Setup	WARNING: SelfUpdate: Default Service: IsUpdateRequired failed: 0x80244019
2009-05-13	02:04:27:916	 916	1a08	Setup	WARNING: SelfUpdate: Default Service: IsUpdateRequired failed, error = 0x80244019
2009-05-13	02:04:27:916	 916	1a08	Agent	  * WARNING: Skipping scan, self-update check returned 0x80244019
2009-05-13	02:04:28:870	 916	1a08	Agent	  * WARNING: Exit code = 0x80244019
2009-05-13	02:04:28:870	 916	1a08	Agent	*********
2009-05-13	02:04:28:870	 916	1a08	Agent	**  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2009-05-13	02:04:28:870	 916	1a08	Agent	*************
2009-05-13	02:04:28:870	 916	1a08	Agent	WARNING: WU client failed Searching for update with error 0x80244019
2009-05-13	02:04:28:885	 916	210c	AU	>>##  RESUMED  ## AU: Search for updates [CallId = {8EB1CDA3-81A6-4824-B4C2-D87975F79333}]
2009-05-13	02:04:28:885	 916	210c	AU	  # WARNING: Search callback failed, result = 0x80244019
2009-05-13	02:04:28:885	 916	210c	AU	  # WARNING: Failed to find updates with error code 80244019
2009-05-13	02:04:28:885	 916	210c	AU	#########
2009-05-13	02:04:28:885	 916	210c	AU	##  END  ##  AU: Search for updates [CallId = {8EB1CDA3-81A6-4824-B4C2-D87975F79333}]
2009-05-13	02:04:28:885	 916	210c	AU	#############
2009-05-13	02:04:28:916	 916	210c	AU	AU setting next detection timeout to 2009-05-13 04:38:20
2009-05-13	02:04:28:916	 916	210c	AU	Setting AU scheduled install time to 2009-05-13 10:00:00
2009-05-13	02:04:32:979	 916	1a08	Report	REPORT EVENT: {52D2C287-EBD6-4513-BD4A-DD3B409EB901}	2009-05-13 02:04:27:916+0200	1	148	101	{D67661EB-2423-451D-BF5D-13199E37DF28}	0	80244019	SelfUpdate	Failure	Software Synchronization	Windows Update Client failed to detect with error 0x80244019.
2009-05-13	02:17:41:229	 916	1a08	PT	WARNING: GetConfig failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404
2009-05-13	02:17:41:229	 916	1a08	PT	WARNING: PTError: 0x80244019
2009-05-13	02:17:41:229	 916	1a08	PT	WARNING: GetConfig_WithRecovery failed: 0x80244019
2009-05-13	02:17:41:229	 916	1a08	PT	WARNING: RefreshConfig failed: 0x80244019
2009-05-13	02:17:41:229	 916	1a08	PT	WARNING: RefreshPTState failed: 0x80244019
2009-05-13	02:17:41:229	 916	1a08	PT	WARNING: PTError: 0x80244019
2009-05-13	02:17:41:229	 916	1a08	Report	WARNING: Reporter failed to upload events with hr = 80244019.
2009-05-13	02:37:52:786	 916	25b4	PT	WARNING: GetConfig failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404
2009-05-13	02:37:52:802	 916	25b4	PT	WARNING: PTError: 0x80244019
2009-05-13	02:37:52:802	 916	25b4	PT	WARNING: GetConfig_WithRecovery failed: 0x80244019
2009-05-13	02:37:52:802	 916	25b4	PT	WARNING: RefreshConfig failed: 0x80244019
2009-05-13	02:37:52:802	 916	25b4	PT	WARNING: RefreshPTState failed: 0x80244019
2009-05-13	02:37:52:802	 916	25b4	PT	WARNING: PTError: 0x80244019
2009-05-13	02:37:52:802	 916	25b4	Report	WARNING: Reporter failed to upload events with hr = 80244019.
2009-05-13	02:56:48:485	 916	2598	PT	WARNING: GetConfig failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404
2009-05-13	02:56:48:485	 916	2598	PT	WARNING: PTError: 0x80244019
2009-05-13	02:56:48:485	 916	2598	PT	WARNING: GetConfig_WithRecovery failed: 0x80244019
2009-05-13	02:56:48:485	 916	2598	PT	WARNING: RefreshConfig failed: 0x80244019
2009-05-13	02:56:48:485	 916	2598	PT	WARNING: RefreshPTState failed: 0x80244019
2009-05-13	02:56:48:485	 916	2598	PT	WARNING: PTError: 0x80244019
2009-05-13	02:56:48:485	 916	2598	Report	WARNING: Reporter failed to upload events with hr = 80244019.
2009-05-13	15:54:28:560	 916	d14	Service	WARNING: GetUserTokenFromSessionId failed with error 800704dd for session 0
2009-05-13	15:54:28:560	 916	d14	Service	WARNING: GetUserTokenFromSessionId failed with error 800704dd for session 0
2009-05-13	15:54:28:560	 916	d14	AU	WARNING: AU found no suitable session to launch client in
2009-05-14	08:40:13:449	3184	2068	Misc	===========  Logging initialized (build: 7.2.6001.788, tz: +0200)  ===========
2009-05-14	08:40:13:449	3184	2068	Misc	  = Process: C:\WINDOWS\system32\wuauclt.exe
2009-05-14	08:40:13:449	3184	2068	AUClnt	Launched Client UI process
2009-05-14	08:40:13:418	 916	d14	AU	Launched new AU client for directive 'Install Approval', session id = 0x0
2009-05-14	08:40:14:387	3184	2068	Misc	===========  Logging initialized (build: 7.2.6001.788, tz: +0200)  ===========
2009-05-14	08:40:14:387	3184	2068	Misc	  = Process: C:\WINDOWS\system32\wuauclt.exe
2009-05-14	08:40:14:387	3184	2068	Misc	  = Module: C:\WINDOWS\system32\wucltui.dll
2009-05-14	08:40:14:387	3184	2068	CltUI	AU client got new directive = 'Install Approval', serviceId = {9482F4B4-E343-43B6-B170-9A65BC822C77}, return = 0x00000000
2009-05-14	08:40:14:387	3184	2068	CltUI	AU client creating default WU/WSUS UI plugin 




Er bringt einfach eine Fehlermeldung, das er kein Selbstupdate machen kann.
Desweiteren kommt teilweise noch die Meldung das der RPC-Server nicht vorhanden sei!

PS: Ich bin kein Windows Server Spezialist! Zwinkernd
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Problem mit GPO
Antwort #5 - 14.05.09 um 11:46:55
Beitrag drucken  
Du hast bei der Installation nicht aufgepasst und ansonsten auch keinerlei Dokumentationen zum WSUS gelesen, richtig?
WARNING: DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
In der GPO muß natürlich beim SBS der Port 8530 mit rein, auf dem Port läuft ja auch der WSUS auf dem SBS: http://Dein_WSUS:8530
Trag das in der GPO ein und mach ein gpupdate auf den Clients. Jetzt sollten die langsam in der WSUS-Konsole kommen.

Weiter ist schon hilfreich zu schreiben, wer er ist, der die Fehlermeldungen bringt, und wo die Fehlermeldung erscheint.

Auch wenn Du kein Windows Server Spezialist bist, darfst Du trotzdem Anleitungen/White Paper lesen. Zwinkernd
  
Zum Seitenanfang
 
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Re: Problem mit GPO
Antwort #6 - 14.05.09 um 12:25:02
Beitrag drucken  
Sunny schrieb on 14.05.09 um 11:46:55:
Weiter ist schon hilfreich zu schreiben, wer er ist, der die Fehlermeldungen bringt, und wo die Fehlermeldung erscheint.


Der Fehler mit dem RPC kam, als ich versuchte von einem Client ein Richtlinienergebnissatz zu protokolieren.

  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). 14_05_001.png (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Problem mit GPO
Antwort #7 - 14.05.09 um 12:59:18
Beitrag drucken  
Ist denn auch WMI oder der Dienst auf dem Client installiert/konfiguriert?
  
Zum Seitenanfang
 
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Re: Problem mit GPO
Antwort #8 - 14.05.09 um 13:27:17
Beitrag drucken  
Also es funktioniert! Vielen Dank!

In diesem Fall muss es wirklich an diesem Port gelegen haben!
5 der Clients sind haben sich nun automatisch beim WSUS angemolden und sind sogar in die Entsprechende Gruppe verschoben.

Danke nochmals! Durchgedreht Durchgedreht Durchgedreht
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). 14_05_002.png (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Problem mit GPO
Antwort #9 - 14.05.09 um 13:52:16
Beitrag drucken  
Kontrollier trotzdem auch, das die Clients einen Statusbericht erstellen. Auch schau ins Log vom WSUS, ob dort noch Fehlermeldungen auftauchen.

BTW: Dieses kleine Howto solltest Du dir auch mal ansehen: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Re: Problem mit GPO
Antwort #10 - 14.05.09 um 14:39:41
Beitrag drucken  
Sunny schrieb on 14.05.09 um 13:52:16:
Kontrollier trotzdem auch, das die Clients einen Statusbericht erstellen. Auch schau ins Log vom WSUS, ob dort noch Fehlermeldungen auftauchen.


Das sehe ich ja in der WSUS Konsole, oder?
Zur Zeit ist noch kein Statusbericht erstellt, jedoch sind die Clients auch erst seit kurzem angemeldet!

Falls sie keinen Statusbericht erstellen, wie könnte ich dies beeinflussen/beheben?

Sunny schrieb on 14.05.09 um 13:52:16:
BTW: Dieses kleine Howto solltest Du dir auch mal ansehen: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Ich habe den WSUS-Server etwa ähnlich konfiguriert, bis auf ein paar kleine ausnahmen! Den wir brauchen ihn eigentlich nicht um die Updates für die Clients zu verwalten (also wer was installieren darf, sondern das die Clients überhaupt Updates bekommen, den sie dürfen/können nicht ins Internet Zwinkernd )


PS: Es sind schon 9Clients angemeldet! Durchgedreht Durchgedreht Durchgedreht


  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Problem mit GPO
Antwort #11 - 14.05.09 um 15:16:29
Beitrag drucken  
JSUS schrieb on 14.05.09 um 14:39:41:
Sunny schrieb on 14.05.09 um 13:52:16:
Kontrollier trotzdem auch, das die Clients einen Statusbericht erstellen. Auch schau ins Log vom WSUS, ob dort noch Fehlermeldungen auftauchen.


Das sehe ich ja in der WSUS Konsole, oder?


Nein, ich meinte das Eventlog vom Server. Start > Ausführen > eventvwr.msc[ENTER].

JSUS schrieb on 14.05.09 um 14:39:41:
Zur Zeit ist noch kein Statusbericht erstellt, jedoch sind die Clients auch erst seit kurzem angemeldet!


Behalte das im Auge.

JSUS schrieb on 14.05.09 um 14:39:41:
Falls sie keinen Statusbericht erstellen, wie könnte ich dies beeinflussen/beheben?


Auf dem Client in die %windir%\windowsupdate.log schauen. Ganz unten sind die Fehler zu finden.
  
Zum Seitenanfang
 
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Re: Problem mit GPO
Antwort #12 - 14.05.09 um 16:05:37
Beitrag drucken  
Sunny schrieb on 14.05.09 um 15:16:29:
Auf dem Client in die %windir%\windowsupdate.log schauen. Ganz unten sind die Fehler zu finden. 

In der Log-Datei sind zurzeit keine weiteren Einträge augelistet worden.


Sunny schrieb on 14.05.09 um 15:16:29:
Behalte das im Auge.

Ich werde Morgen nochmals in die Konsole schauen.


Sunny schrieb on 14.05.09 um 15:16:29:
Nein, ich meinte das Eventlog vom Server. Start > Ausführen > eventvwr.msc[ENTER].

In der Ereignisanzeige bringt er folgenden Fehler!
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). 14_052123.png (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Problem mit GPO
Antwort #13 - 14.05.09 um 16:25:23
Beitrag drucken  
JSUS schrieb on 14.05.09 um 16:05:37:
In der Ereignisanzeige bringt er folgenden Fehler!


Dachte ich mir doch. Zwinkernd

Schau dir diesen Artikel an: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Du brauchst unbedingt auch auf Port 80 im IIS das Verzeichnis Selfupdate und ClientWebService. Die beiden sind bei dir nur auf Port 8530 installiert, aber nicht auf Port 80 = Standardwebsite. Leg die beiden Seiten so wie im Artikel beschrieben an.

Evtl. hast Du die MSI ja auf dem WSUS: Wenn das virtuelle Verzeichnis von SelfUpdate fehlt oder nicht auf der Website, die an Port 80 gebunden ist, aufgelistet ist, führen Sie die Datei "Selfupdate.msi" aus, die sich im Ordner "Programme\Update Services\Setup" befindet.

Alternativ gibts hier auch noch einen Artikel: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). > cscript WSUSInstallDirectory\setup\installselfupdateonport80.vbs
  
Zum Seitenanfang
 
JSUS
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 14.05.09
Re: Problem mit GPO
Antwort #14 - 15.05.09 um 09:20:40
Beitrag drucken  
Sunny schrieb on 14.05.09 um 16:25:23:
Schau dir diesen Artikel an: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Du brauchst unbedingt auch auf Port 80 im IIS das Verzeichnis Selfupdate und ClientWebService. Die beiden sind bei dir nur auf Port 8530 installiert, aber nicht auf Port 80 = Standardwebsite. Leg die beiden Seiten so wie im Artikel beschrieben an. 

OK hab ich gemacht!
Nervt mich ein bisschen, das Windows bzw. WSUS das nicht selbst macht!
Nun steht im Ereignissprotokoll, "Selbstupdate funktioniert"

Also es ist nun so, das alle Clients sich am WSUS angemeldet haben. Nur hat bisher noch keiner einen Statusbericht erstellt.

  
Zum Seitenanfang
 
Seitenindex umschalten Seiten: [1] 2 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden