Heißes Thema (mehr als 10 Antworten) WSUS 3.0 SP1: Server werden nur teilweise integriert (Gelesen: 1191 mal)
kneubi89
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 10.06.09
WSUS 3.0 SP1: Server werden nur teilweise integriert
10.06.09 um 13:56:55
Beitrag drucken  
Hallo zusammen

Ich bin ein relativ neuer WSUS-Anwender. Ich habe meine Abschlussarbeit über den WSUS durchgeführt, dort hat eigentlich auch alles ohne Probleme funktioniert. Doch nun habe ich das weiter unten beschriebene Problem.

Erstmal ein paar Systemangaben.

Bei mir läuft WSUS 3.0 SP1 auf einem Windows Server 2003 R2 Standart Edition. 300 GB Speicherplatz (sollte bei weitem reichen denn wir wollen nur Serverupdates und keine WinXP und ähnliches). Wir wollen Windows Server 2003 Enterprise und Standart Edition mit WSUS bedienen sowie einzelne Windows Server 2008. Ungefähr 20% der Server werden über Domänen GPO und 80% per lokal konfigurierte GPO in den WSUS hinzugefügt, da diese in einer Workgroup sind und aus Konfigurationsgründen nicht in die Domäne aufgenommen werden können. Der WSUS ist auf die Default IIS-Seite konfiguriert mit Port 80.

Wichtig: Bei diesem Problem handelt es sich nur um Server die über die Domänen GPO in den WSUS aufgenommen werden sollen.

Ich will die Domänenserver alle über GPO in den WSUS integrieren. Zur Zeit schaut es so aus, dass ich ein OU "WSUS" erstellt habe, dort werden alle Einstellungen getätigt (Welcher WSUS angesteuert werden soll etc. da bin ich mir auch sicher dass ich nichts vergessen habe da der WSUS in Form der alten Installation genau mit der Konfiguration funktioniert hat, aber welcher Gruppe der Server auf dem WSUS zugehören soll, ist in dieser GPO nicht konfiguriert). Nun ist aber neu dass ich unterhalb dieser OU "WSUS" 8 weitere OUs habe. Jede davon steht für eine Gruppe im WSUS z.B. eine OU heisst "Testserver". Auf dieser OU habe ich eine GPO konfiguriert, die lediglich Clientseitige Zuweisung in die WSUSgruppen angibt, in diesem Fall wäre es "Testserver". In der GPO zur WSUS zuteilung habe ich die Angabe http://WSUSserver:80" gemacht.

Im WSUS habe ich die Option aktiviert dass die Computer/Server über GPO den einzelnen Gruppen zugeteilt werden.

Nun das eigentliche Problem.

Zwei der ungefähr 20 Server die über die Domäne integriert werden sollen, funktionieren ohne Probleme und werden auch integriert und den richtigen Gruppen zugewiesen. Egal welcher OU ich sie in der Domäne zuteile, nach einem "gpupdate /force" sind die Server auf dem WSUS in der Richtigen Gruppe zu finden. Allerdings funktionieren nur diese zwei Server. Bei allen andern 18 Servern, wird die GPO der Domäne angewendet (per RSOP.MSC kontrolliert), die Server werden aber auch nach "gpupdate /force" und auch nach 24 Stunden immernoch nicht im WSUS angezeigt (als würde der WSUS die abblocken).

Hat mir da jemand einen Tipp? Ich habe in den Foren bisher leider keine Fehlerlösung gefunden, die bei mir funktioniert hat.

Gruss
Kneubi89
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #1 - 10.06.09 um 14:52:15
Beitrag drucken  
Die Server sind geklont: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Entferne die angegebenen Registry Keys und lass ein wuauclt /detectnow auf den betroffenen Systemen laufen. Es wird alles gut. Zwinkernd

BTW: Es heißt immer Standard. Smiley
  
Zum Seitenanfang
 
kneubi89
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 10.06.09
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #2 - 10.06.09 um 15:01:55
Beitrag drucken  
Vielen Dank für die rasche Antwort.

Wenn die Problemlösung doch immer so eine Kleinigkeit wäre....

*hüstel* bist nicht der erste der mir das sagt Sunny, aber irgendwie schreib ich es immer mit t, schaut für mich normal aus  Smiley irgendwie hat sich das so eingebrannt, ist (zum Glück) nicht meine Muttersprache


Mr. Edit:
Von den 3 Schlüsseln die man löschen sollte, war nur einer dort vorhanden. Die andern zwei waren gar nicht erst vorhanden.

# Öffnen sie das Startmenü, klicken auf Ausführen.
Geben sie regedit ein und klicken anschließend auf OK.
# Gehen sie zu HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
Sofern sie existieren, sollten Sie die folgenden Werte löschen:

    * AccountDomainSid --> Nicht vorhanden gewesen
    * PingID --> Nicht vorhanden gewesen
    * SusClientId --> wurde von mir gelöscht
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #3 - 10.06.09 um 15:13:01
Beitrag drucken  
War es denn wenigstens der richtige Tipp mit dem klonen? Zwinkernd
  
Zum Seitenanfang
 
kneubi89
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 10.06.09
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #4 - 10.06.09 um 15:23:09
Beitrag drucken  
So, gerade getestet. Bei einem der zwei Server hat es funktioniert. Der ist nun integriert. Der andere nach wie vor nicht. Ich habe gerade noch ClientDiag ausgeführt und festgestellt dass mir dieses Tool einen Fehler verursacht. Ich kann mit der Fehlermeldung leider nichts anfangen und per Google hab ich leider auch nichts gefunden.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #5 - 10.06.09 um 16:18:06
Beitrag drucken  
Du solltest Google verklagen. Durchgedreht Oder Du bist nur zu faul zum suchen, kann ja auch sein.

Auf der Hautpseite von wsus.de gibts die Errorcodes, dort sind schon viele Lösungen zu finden. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). + (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Einfach mal ausprobieren.

BTW: Wenn Du schon Lösungen probiert hast, dann schreib das immer gleih dazu, was Du schon probiert hast, hilft den helfenden ungemein.
  
Zum Seitenanfang
 
kneubi89
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 10.06.09
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #6 - 10.06.09 um 16:29:07
Beitrag drucken  
Ich habe die beiden schon gesehen gehabt unter den Errorcodes. Allerdings frage ich mich, wie sich diese Problemlösungen auf meines auswirken sollten. Der ClientDiag wurde auf dem Server ausgeführt, der vom WSUS nicht integriert wird. Der Server hat ein Windows Server 2008 Betriebsystem. Und die erste Fehlerlösung bezieht sich auf Windows XP, wenn ich mich richtig geachtet habe. Zur zweiten Fehlerlösung, hat einen zusammenhang wenn ich die Updates von Hand auf der Webseite herunterlade und installiere. Ich Installiere auf dem Server aber weder Updates noch sonst was.

Aber ich werde die Problemlösungen austesten.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #7 - 10.06.09 um 16:48:46
Beitrag drucken  
kneubi89 schrieb on 10.06.09 um 16:29:07:
Ich habe die beiden schon gesehen gehabt unter den Errorcodes. Allerdings frage ich mich, wie sich diese Problemlösungen auf meines auswirken sollten. Der ClientDiag wurde auf dem Server ausgeführt, der vom WSUS nicht integriert wird.


Der WSUS ist dumm wie Stroh und tut gar nix. Der steht nur dumm da und gibt den Clients das was sie wollen. Der Fehler liegt also am Client/Server der den WSUS nicht findet.

kneubi89 schrieb on 10.06.09 um 16:29:07:
Der Server hat ein Windows Server 2008 Betriebsystem. Und die erste Fehlerlösung bezieht sich auf Windows XP, wenn ich mich richtig geachtet habe. Zur zweiten Fehlerlösung, hat einen zusammenhang wenn ich die Updates von Hand auf der Webseite herunterlade und installiere. Ich Installiere auf dem Server aber weder Updates noch sonst was.

Aber ich werde die Problemlösungen austesten.


Das muß man nur verstehen. Ob Windows Update manuell im Browser oder WSUS, das Prinzip ist das gleiche. Der lokale WU-Agent muß den Weg dorthin finden.

Du kannst auch in der %windir%\Windowsupdate.log nach Fehlern schauen.

Probier mal auf dem Client/Server:
net stop wuauserv
rd /s /q %windir%\SoftwareDistribution
net start wuauserv
wuauclt /resetauthorization /detectnow
wuauclt /detectnow
wuauclt /reportnow

Alternativ kannst Du auch den aktuellen WU-Agent nochmals installieren. Notfalls mit der Option /WUFORCE wie hier genannt: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
kneubi89
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 10.06.09
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #8 - 12.06.09 um 15:34:03
Beitrag drucken  
War leider am Donnerstag nicht in der Firma, somit habe ich es erst heute ausprobieren können.

Ich habe das von dir vorgeschlagene getestet. Musste aber schon feststellen, dass "net stop wuauserv" gar nicht funkioniert.

Wenn ich die Dienste anschaue ist der Windows Update Dienst hängen geblieben bei "Stopping". Sprich der Dienst ist gar nicht erst richtig gestoppt bzw. gestartet.

Hat jemand das Problem schon gehabt? Problem ist ich darf den Server nicht neustarten. Ich gehe mich nun durch die Webseiten wälzen... Wenn jemand ein Tipp hat wie ich den Dienst wieder zum laufen bringe wäre ich dankbar.

Gruss
Kneubi89


Mr Edit:

Konnte den Task beenden (zuerst mit "sc queryex wuauserv" im CMD die PID rausgesucht und anschliessend mit "Taskkill /pid XXX -f" den task beendet). Ich starte ihn nun wieder und teste nochmal die Angabe von Sunny

Anmerkung nach dem von Sunny vorgeschlagene:
Der Svchostdienst unter dem der wuauserv läuft, ist nun dauerhaft mit 25% Prozessorauslastung angezeigt. Das Log habe ich unten angehängt. Habe das alte wegkopiert (bevor ich das von Sunny durchgeführt habe) um ein neues anzulegen, damit es für mich übersichtlicher ist. Im alten Log sind leider keinerlei Fehlermeldungen angezeigt gewesen(Auch nicht als der Dienst sich aufgehängt hatte).

2009-06-12      15:53:03:272      3632      1514      AU      Triggering AU detection through DetectNow API
2009-06-12      15:53:03:272      3632      1514      AU      Piggybacking on an AU detection already in progress
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13157
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #9 - 12.06.09 um 19:05:21
Beitrag drucken  
Starte am besten auch mal den Server komplett durch. Dann sehen wir weiter.
  
Zum Seitenanfang
 
kneubi89
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 11
Mitglied seit: 10.06.09
Re: WSUS 3.0 SP1: Server werden nur teilweise integriert
Antwort #10 - 15.06.09 um 12:50:02
Beitrag drucken  
Nach dem Neustart wurde der Server nun integriert. Danke für eure hilfestellung.
  
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden