Heißes Thema (mehr als 10 Antworten) WSUS 3.0 SP1 Problem bei Installation (Gelesen: 1935 mal)
nobbivm
WSUS Junior Member
*
Offline



Beiträge: 10
Mitglied seit: 24.06.08
Geschlecht: männlich
WSUS 3.0 SP1 Problem bei Installation
04.08.09 um 16:34:20
Beitrag drucken  
Hallo Leute,
ich habe mal wieder ein paar Fragen an euch und zwar habe ich den Auftrag bekommen einen WSUS bei uns zu installieren, so weit, so gut.
Der WSUS soll auf einer Server 2003 R2 ESX VM laufen, die DB auf unserem SQL 2005 Cluster.
Beim Setup wird die Verbindung zum DB Cluster hergestellt und er findet sogar ne ältere WSUS DB die da noch liegt und verbindet sich laut Setup auch damit.
Die Website Erstellung läuft auch durch, trotzdem erhlate ich am ende vom Setup eine Meldung die mir sagt, dass die Konfiguration nicht zu ende geführt werden konnte da keine Verbindung zum WSUS Server hergestellt werden kann und dass man die Verbindung aber über Optionen in der WSUS Konsole manuell herstellen soll.
Wenn ich das versuche bekomme ich immer die Meldung: Es kann keine Verbindung mit "server" hergestellt werden, SQL server wird auf dem Server möglicherweise nicht ausgeführt usw.
Klar der SQLer läuft ja auch nicht auf dem WSUS sondern auf dem Cluster Ärgerlich

Was mich wundert ist, dass das Setup die WSUS DB auf dem SQL Cluster findet, aber WSUS dennoch anmeckert dass er keine Verbindung herstellen kann hä?
Oder wohin bekommt er keine Verbindung?

Wäre für ein paar Tipps sehr dankbar.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13357
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #1 - 04.08.09 um 16:49:43
Beitrag drucken  
Kannst Du denn die MMC aufrufen? Kannst Du dich hier zum WSUS verbinden? Wenn nein, was spricht dagegen es komplett neu zu machen? Neue Instanz und neue DB.
  
Zum Seitenanfang
 
nobbivm
WSUS Junior Member
*
Offline



Beiträge: 10
Mitglied seit: 24.06.08
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #2 - 05.08.09 um 09:20:05
Beitrag drucken  
Nein kann mich in der MMC leider nicht zum WSUS verbinden.
Aber ich werde heute mal eine neue Lun clonen und den WSUS neu aufsetzen.
Es könnte ja sein, dass noch irgendwelche "Altlasten" auf dem Server für Problem sorgen.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13357
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #3 - 05.08.09 um 09:35:29
Beitrag drucken  
OK, viel Erfolg. Zwinkernd
  
Zum Seitenanfang
 
nobbivm
WSUS Junior Member
*
Offline



Beiträge: 10
Mitglied seit: 24.06.08
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #4 - 05.08.09 um 12:39:24
Beitrag drucken  
Aahhrgg Ärgerlich
Geht immer noch nicht Traurig
Habe den WSUS neu aufgestezt, DB neu erstellen lassen, alles neu und trotzdem kommt immer noch die gleiche Fehlermeldung von wegen keine Verbindung mit WSUS möglich, SQl server wird nicht ausgeführt.

Muss auf dem SQL Server auch der IIS Dienst installiert werden?
  
Zum Seitenanfang
 
L_I
WSUS Full Member
**
Offline


I Love WSUS!

Beiträge: 59
Mitglied seit: 28.10.08
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #5 - 05.08.09 um 12:58:35
Beitrag drucken  
Der Content muss ja auf einem lokalen Laufwerk liegen. Wie funktioniert das eigentlich mit der DB?

Frage 45: Kann ich den WSUS Content auf einem SAN oder in einem Netzwerklaufwerk speichern? 
   
Antwort: Der Content muss sich lokal auf dem WSUS-Server befinden. WSUS läuft unter dem "Netzwerkdienst"-Account, der jedoch keine Berechtigungen auf externen Datenträgern besitzt.

  
Zum Seitenanfang
 
nobbivm
WSUS Junior Member
*
Offline



Beiträge: 10
Mitglied seit: 24.06.08
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #6 - 05.08.09 um 13:09:54
Beitrag drucken  
Der Content liegt ja auch lokal auf dem WSUS, lediglich die DB lag auf dem SQL Server.
Habe es nochmals neu installiert mit lokaler DB und nun gehts....
EDIT:
die anderen Fehler haben sich erledigt.

Aber mich würde immer noch interessieren warum der WSUS keine Verbindung zum SQL Server aufbaut und ich deshalb die lokale DB verwenden muss.
In meiner alten Firma hatten wir den WSUS auch mit SQL 2005 laufen und dort gabs keine Probleme bei der Installation.
  
Zum Seitenanfang
 
L_I
WSUS Full Member
**
Offline


I Love WSUS!

Beiträge: 59
Mitglied seit: 28.10.08
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #7 - 05.08.09 um 13:40:31
Beitrag drucken  
nobbivm schrieb on 05.08.09 um 13:09:54:
Aber mich würde immer noch interessieren warum der WSUS keine Verbindung zum SQL Server aufbaut und ich deshalb die lokale DB verwenden muss.

Vielleicht eine Firewall dazwischen? Port nicht frei gegeben?
  
Zum Seitenanfang
 
nobbivm
WSUS Junior Member
*
Offline



Beiträge: 10
Mitglied seit: 24.06.08
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #8 - 05.08.09 um 15:00:46
Beitrag drucken  
Nein es ist keine Firewall dazwischen, aber ich weiß nun warum das Setup die DB auf dem SQL erstellen, aber nicht darauf zugreifen kann wenn das Setup abgeschlossen ist.
Des Rätsels Lösung ist das Dienstkonto vom WSUS, der ja vom Netzwerkdienst ausgeführt wird und genau dieses hat ja keine Berechtigung auf dem SQLer Zwinkernd
Beim Setup greift der WSUS ja über mein Konto auf den SQLer zu und das geht logischerweise.
Also ein Dienstkonto erstellen, dem Konto das Recht auf der SUSDB einrichten und den WSUS Dienst mit diesem ausführen, fertig und läuft Cool

Danke nochmals für eure Tipps Smiley
  
Zum Seitenanfang
 
L_I
WSUS Full Member
**
Offline


I Love WSUS!

Beiträge: 59
Mitglied seit: 28.10.08
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #9 - 05.08.09 um 15:08:08
Beitrag drucken  
nobbivm schrieb on 05.08.09 um 15:00:46:
Des Rätsels Lösung ist das Dienstkonto vom WSUS, der ja vom Netzwerkdienst ausgeführt wird und genau dieses hat ja keine Berechtigung auf dem SQLer Zwinkernd
Beim Setup greift der WSUS ja über mein Konto auf den SQLer zu und das geht logischerweise.
Also ein Dienstkonto erstellen, dem Konto das Recht auf der SUSDB einrichten und den WSUS Dienst mit diesem ausführen, fertig und läuft Cool


Hmmm... ein interessanter Lösungsansatz. Würde das auch mit dem Content funktionieren? Das heisst, dass man den Content auf einem Fileserer (Server-Laufwerk) auslagern könnte?
  
Zum Seitenanfang
 
nobbivm
WSUS Junior Member
*
Offline



Beiträge: 10
Mitglied seit: 24.06.08
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #10 - 05.08.09 um 15:19:38
Beitrag drucken  
Das geht leider nicht, weil der WSUS gar nicht die möglichkeit bietet den Content extern abzulegen.
Das Setup meckert ja rum wenn man einen UNC Pfad eingibt.
Ob es im Nachhinein möglich ist den Content umzuziehen ist mir nicht bekannt, wüsste nicht wie.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13357
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #11 - 05.08.09 um 16:51:10
Beitrag drucken  
nobbivm schrieb on 05.08.09 um 15:19:38:
Das geht leider nicht, weil der WSUS gar nicht die möglichkeit bietet den Content extern abzulegen.
Das Setup meckert ja rum wenn man einen UNC Pfad eingibt.


Auch wenn es ein Netzlaufwerk ist, soll es nicht funktionieren.

nobbivm schrieb on 05.08.09 um 15:19:38:
Ob es im Nachhinein möglich ist den Content umzuziehen ist mir nicht bekannt, wüsste nicht wie.


Geht schon, Movecontent lautet das Stichwort: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13357
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 Problem bei Installation
Antwort #12 - 05.08.09 um 16:51:57
Beitrag drucken  
nobbivm schrieb on 05.08.09 um 15:00:46:
Nein es ist keine Firewall dazwischen, aber ich weiß nun warum das Setup die DB auf dem SQL erstellen, aber nicht darauf zugreifen kann wenn das Setup abgeschlossen ist.
Des Rätsels Lösung ist das Dienstkonto vom WSUS, der ja vom Netzwerkdienst ausgeführt wird und genau dieses hat ja keine Berechtigung auf dem SQLer Zwinkernd
Beim Setup greift der WSUS ja über mein Konto auf den SQLer zu und das geht logischerweise.
Also ein Dienstkonto erstellen, dem Konto das Recht auf der SUSDB einrichten und den WSUS Dienst mit diesem ausführen, fertig und läuft Cool


Hmm, steht auch so in der Doku von MS: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Smiley
  
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden