Normales Thema Deinstallation nicht möglich / Dienste starten nicht / SBS 2008 (Gelesen: 2296 mal)
Evil Master
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 2
Mitglied seit: 20.08.09
Deinstallation nicht möglich / Dienste starten nicht / SBS 2008
20.08.09 um 11:50:02
Beitrag drucken  
Ich hab seid der Installation bzw. der Migration von SBS 2003 auf SBS 2008 (welches WSUS mit SP1 als Rolle beinhaltet) massive Probleme mit dem WSUS!

Undzwar lassen sich alle WSUS interne Dieste nicht starten bzw. Eventlog sagt das diese nichit funktionieren, wobei das noch nicht alles ist!

Folgende Dienste:

Quote:
Der DSS-Authentifizierungswebdienst funktioniert nicht. Event ID: 12052
Der SimpleAuth-Webdienst funktioniert nicht. Event ID: 12042
Der Clientwebdienst funktioniert nicht. Event ID: 12022
Der Serversynchronisierungs-Webdienst funktioniert nicht. Event ID: 12032
Der API-Remoting-Webdienst funktioniert nicht. Event ID: 12012
Der Berichterstattungswebdienst funktioniert nicht. Event ID: 12002
Viele Clientcomputer haben sich in den letzten 30 Tagen nicht beim Server gemeldet. 6 wurden bisher erkannt. Event ID: 13032
Selbstupdate funktioniert nicht. Event ID: 13042


Also praktisch alles :/

Desweiteren habe ich versucht aus der Verzweiflung, den WSUS als Rolle zu deinstallieren, was aber wiederum scheiterte mit dem Error: 0x80070643
(Googlen nach diesem Error ist nicht so einfach, da dieser in vielen bereichen Auftritt, nur nicht da wo ich ihn habe)

Nach weiteren rescheschieren habe ich den Uninstall.log von WSUS gefunden mit folgenden Einträgen:

Quote:
2009-08-18 15:33:17  Success   MWUSSetup          Validating pre-requisites...
2009-08-18 15:33:28  Success   MWUSSetup          Removing Wsus...
2009-08-18 15:33:29  Success   CustomActions.Dll  Successfully set propery of WSUS admin groups' full names
2009-08-18 15:33:46  Error     CustomActions.Dll  CSqlConnection:Schockiert/Erstauntpen: Failed to open SQL connection to instance <servername>\MICROSOFT##SSEE (Error 0x80004005: Unbekannter Fehler)
2009-08-18 15:33:46  Error     CustomActions.Dll  GetDatabaseLocation: Failed to open connection to SQL instance %computername%\MICROSOFT##SSEE (Error 0x80004005: Unbekannter Fehler)
2009-08-18 15:33:46  Error     CustomActions.Dll  SetWyukonInstallDirProperty: Failed to get installed location of SUSDB in WYukon (Error 0x80004005: Unbekannter Fehler)
2009-08-18 15:33:46  Error     CustomActions.Dll  SetUnInstallProperties: Failed to set WYUKON install directory (Error 0x80004005: Unbekannter Fehler)
2009-08-18 15:33:46  Error     MWUSSetup          RemoveWsus: MWUS Uninstall Failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
2009-08-18 15:33:46  Error     MWUSSetup          Wsus MSI uninstallation failed. (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
2009-08-18 15:33:46  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
2009-08-18 15:33:55  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)


Hier scheint wiederum ein Problem mit dem SQL zu geben wie ich das sehe. Was interessant ist, das wiederum nach der weiteren Suche ich herausgefunden habe, das im SQL.log bzw. bei der Datenbank die WSUS anlegt (MICROSOFT##SSEE) ein falsches bzw. ein Konto hinterlegt wurde das keine Berechtigungen auf die Datenbank hat. Was wiederum folgenden eintrag im SQL.log gibt:
Quote:
2009-08-18 12:32:06.94 Logon       Login failed for user 'NT-AUTORITÄT\NETZWERKDIENST'. [CLIENT: <named pipe>]


Und soweit ich das beuhrteilen kann ist dieser Netzwerkdienst eine Pre-Historie aus SBS 2003.
So habe ich den Domain Admin als Amledekonto hinterlegt, was zumindest kein Fehler mehr in der .log veruhrsachte, aber die bestehenden Probleme nicht löste.

Was auch ganz kommisch ist, wenn man beim Thema SQL bleibt ist das die WSUS-Datenbank überall als "MICROSOFT##SSEE"
dargerstellt wird, jedoch wenn man auf diese versucht sich zu connecten kommt das:

Quote:
sqlcmd -S np:\\.\pipe\MICROSOFT##SSEE\sql\query
HResult '0x2', Ebene '16', Status '1'
'Named Pipes Provider: Could not open a connection to SQL Server [2]. '
Sqlcmd: Fehler: Microsoft SQL Native Client : An error has occurred while establ
ishing a connection to the server. When connecting to SQL Server 2005, this fail
ure may be caused by the fact that under the default settings SQL Server does no
t allow remote connections..
Sqlcmd: Fehler: Microsoft SQL Native Client : Login timeout expired.


Jedoch wenn ich das hier eingebe, dann erhalte ich ein Prompt:

Quote:
sqlcmd -S np:\\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query


Was auch noch komisch ist, die Datenbank scheint voll zu sein bzw. der WSUS hat schon viele Updates herundergeladen, was sich an einem 3.3 GB großen WSUS Ordner wiederspiegelt...

Jetzt kommen wir noch zu dem IIS, der anscheined auch ohne weiteres läuft, wobei ich hier erlich gesgat nicht wirklich sicher bin oder er das tut. zumindest scheint er den WSUS-Eitrag zu haben sowie die haben zugriffe:

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Zum schlüss noch, ich komme auch nicht über die Verwaltungskonsole (Snap-in) auf den WSUS Server bzw. ich kann nicht zu diesem connecten, egal welchen Port ich nehme (80,443, 8530, 8531) hier dann die frage ob der IIS eine make hat!?

Vielen Dank für die Vorschläge und sry das es so lang geworden ist, aber ist ein ganz spezieller Fall, wie es scheint Smiley
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13542
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Deinstallation nicht möglich / Dienste starten nicht / SBS 2008
Antwort #1 - 20.08.09 um 13:26:31
Beitrag drucken  
Evil Master schrieb on 20.08.09 um 11:50:02:
Ich hab seid der Installation bzw. der Migration von SBS 2003 auf SBS 2008 (welches WSUS mit SP1 als Rolle beinhaltet) massive Probleme mit dem WSUS!


Wie genau hast Du installiert bzw. migriert?

Evil Master schrieb on 20.08.09 um 11:50:02:
Undzwar lassen sich alle WSUS interne Dieste nicht starten bzw. Eventlog sagt das diese nichit funktionieren, wobei das noch nicht alles ist!

Folgende Dienste:

Quote:
Der DSS-Authentifizierungswebdienst funktioniert nicht. Event ID: 12052
Der SimpleAuth-Webdienst funktioniert nicht. Event ID: 12042
Der Clientwebdienst funktioniert nicht. Event ID: 12022
Der Serversynchronisierungs-Webdienst funktioniert nicht. Event ID: 12032
Der API-Remoting-Webdienst funktioniert nicht. Event ID: 12012
Der Berichterstattungswebdienst funktioniert nicht. Event ID: 12002
Viele Clientcomputer haben sich in den letzten 30 Tagen nicht beim Server gemeldet. 6 wurden bisher erkannt. Event ID: 13032
Selbstupdate funktioniert nicht. Event ID: 13042


Also praktisch alles :/


Kontrollier die Einstellungen und NTFS-Berechtigungen im IIS: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Und auch für die Ordnerstruktur im Filesystem: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Wenn das Selfupdate nicht funktioniert, fehlt zu 99% in der Standardwebsite (Port 80) ein virtuelles Directory Selfupdate ins Filesystem. Hier gibts Infos und KB-Artikel dazu: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). + (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Evil Master schrieb on 20.08.09 um 11:50:02:
Desweiteren habe ich versucht aus der Verzweiflung, den WSUS als Rolle zu deinstallieren, was aber wiederum scheiterte mit dem Error: 0x80070643
(Googlen nach diesem Error ist nicht so einfach, da dieser in vielen bereichen Auftritt, nur nicht da wo ich ihn habe)


Probier auf der Comandline ein: lodctr /r und probier anschließend nochmals den WSUS zu deinstallieren.

Evil Master schrieb on 20.08.09 um 11:50:02:
Hier scheint wiederum ein Problem mit dem SQL zu geben wie ich das sehe. Was interessant ist, das wiederum nach der weiteren Suche ich herausgefunden habe, das im SQL.log bzw. bei der Datenbank die WSUS anlegt (MICROSOFT##SSEE) ein falsches bzw. ein Konto hinterlegt wurde das keine Berechtigungen auf die Datenbank hat. Was wiederum folgenden eintrag im SQL.log gibt:
Quote:
2009-08-18 12:32:06.94 Logon       Login failed for user 'NT-AUTORITÄTNETZWERKDIENST'. [CLIENT: <named pipe>]


Und soweit ich das beuhrteilen kann ist dieser Netzwerkdienst eine Pre-Historie aus SBS 2003.
So habe ich den Domain Admin als Amledekonto hinterlegt, was zumindest kein Fehler mehr in der .log veruhrsachte, aber die bestehenden Probleme nicht löste.


Dann füg den Netzwerkdienst wieder hinzu, der wird schon noch benötigt.

Evil Master schrieb on 20.08.09 um 11:50:02:
Was auch noch komisch ist, die Datenbank scheint voll zu sein bzw. der WSUS hat schon viele Updates herundergeladen, was sich an einem 3.3 GB großen WSUS Ordner wiederspiegelt...


3,3 GB für ein Content ist nicht groß. Das ist fast normal. Wie groß ist die SUSDB?

Evil Master schrieb on 20.08.09 um 11:50:02:
Jetzt kommen wir noch zu dem IIS, der anscheined auch ohne weiteres läuft, wobei ich hier erlich gesgat nicht wirklich sicher bin oder er das tut. zumindest scheint er den WSUS-Eitrag zu haben sowie die haben zugriffe:


Kontrollier doch erstmal, ob Du wirklich alles an Rollen vorher hinzugefügt hast: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Desweiteren wird der WSUS bei einem SBS immer auf Port 8530 installiert, das scheint mir bei dir nicht der Fall zu sein, deshalb kann auch nichts funktionieren.

Evil Master schrieb on 20.08.09 um 11:50:02:
Zum schlüss noch, ich komme auch nicht über die Verwaltungskonsole (Snap-in) auf den WSUS Server bzw. ich kann nicht zu diesem connecten, egal welchen Port ich nehme (80,443, 8530, 8531) hier dann die frage ob der IIS eine make hat!?


Der IIS hat keine Macke, hier mußt Du dir schon an die eigene Nase fassen. Zwinkernd Wenn der WSUS korrekt konfiguriert ist, bekommst Du auch Zugriff, vermutlich über Port 8530.

Zum Thema anmelden an der WSUS-DB leg ich dir dieses HowTo ans Herz: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
Evil Master
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 2
Mitglied seit: 20.08.09
Re: Deinstallation nicht möglich / Dienste starten nicht / SBS 2008
Antwort #2 - 21.08.09 um 15:08:36
Beitrag drucken  
Sunny schrieb on 20.08.09 um 13:26:31:
Wie genau hast Du installiert bzw. migriert?


Garnicht, das hat der SBS 2008 bei der Installation bzw. Migration selbst gemacht.

Sunny schrieb on 20.08.09 um 13:26:31:
Kontrollier die Einstellungen und NTFS-Berechtigungen im IIS: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Und auch für die Ordnerstruktur im Filesystem: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Ich hab mir die Berechtigungen soweit angeguck und habe festgestellt das es einen User bzw. Windows eingens erstelltes vordifiniertes Konto (IUSR_servername) falsch ist bzw. ich mir nicht sicher bin ob dieses richtig ist, weil der "servername" den alten Server beschreibt und nicht den neuen.


Sunny schrieb on 20.08.09 um 13:26:31:
Wenn das Selfupdate nicht funktioniert, fehlt zu 99% in der Standardwebsite (Port 80) ein virtuelles Directory Selfupdate ins Filesystem. Hier gibts Infos und KB-Artikel dazu: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). + (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen)..


Die Fehlermeldung SelfUpdate konnte ich jetzt weg kriegen mit der Umstellung des Ports in der Registry unter "Update Services", wobei so wie ich das gelsen habe tut der SBS 2008 standard mässig mit dem POrt 8530 arbeiten (welche auch dort zuvor eingetragen war)

Sunny schrieb on 20.08.09 um 13:26:31:
Probier auf der Comandline ein: lodctr /r und probier anschließend nochmals den WSUS zu deinstallieren.


Hat leider nichts gebracht

Sunny schrieb on 20.08.09 um 13:26:31:
Dann füg den Netzwerkdienst wieder hinzu, der wird schon noch benötigt.


Das funktioniert leider nicht mehr Griesgrämig

Folgende Fehlermeldung erscheint, wenn ich versuche den SQL-Server auf Netzwerkdienst umzustellen:
Fehler bei WMI-Anbieter: Ein neues Mitglied konnte nicht zu einer lokalen Gruppe hinzugefügt werden, da das Mitglied den falschen Kontentyp aufweist. [0x8007056c]

Sunny schrieb on 20.08.09 um 13:26:31:
3,3 GB für ein Content ist nicht groß. Das ist fast normal. Wie groß ist die SUSDB?


Die SUSDB ist fast 2.2 GB Groß

Sunny schrieb on 20.08.09 um 13:26:31:
Kontrollier doch erstmal, ob Du wirklich alles an Rollen vorher hinzugefügt hast: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Desweiteren wird der WSUS bei einem SBS immer auf Port 8530 installiert, das scheint mir bei dir nicht der Fall zu sein, deshalb kann auch nichts funktionieren.


Wie schon vorhin erwähnt, war der auf Port 8530 (zumindest in der Registry) eingestellt.

Sunny schrieb on 20.08.09 um 13:26:31:
Zum Thema anmelden an der WSUS-DB leg ich dir dieses HowTo ans Herz: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Habe ich ausprobiert und konnte den script erfolgreich ausführen (wobei das ziemlich lange gedauert hat :/)

Was würde eigendlich passieren wenn ich den IIS als Rolle deinstalliere und dann neu istalliere? Weil ich weiss nicht igendwie ist alles komisch...
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13542
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Deinstallation nicht möglich / Dienste starten nicht / SBS 2008
Antwort #3 - 21.08.09 um 15:32:01
Beitrag drucken  
Evil Master schrieb on 21.08.09 um 15:08:36:
Sunny schrieb on 20.08.09 um 13:26:31:
Wie genau hast Du installiert bzw. migriert?


Garnicht, das hat der SBS 2008 bei der Installation bzw. Migration selbst gemacht.


Anders gefragt, wie wurde der SBS 2008 installiert? Hast Du einen laufenden SBS2003 einfach upgedated oder den 2008er daneben hingestellt und migriert?

Evil Master schrieb on 21.08.09 um 15:08:36:
Sunny schrieb on 20.08.09 um 13:26:31:
Kontrollier die Einstellungen und NTFS-Berechtigungen im IIS: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Und auch für die Ordnerstruktur im Filesystem: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Ich hab mir die Berechtigungen soweit angeguck und habe festgestellt das es einen User bzw. Windows eingens erstelltes vordifiniertes Konto (IUSR_servername) falsch ist bzw. ich mir nicht sicher bin ob dieses richtig ist, weil der "servername" den alten Server beschreibt und nicht den neuen.


Hmm, kannst du dort nicht einen anderen eintragen? Du hast also ein sog. InPlaceUpgrade gefahren. Wenn ja, das ist eigentlich nicht zu empfehlen.

Evil Master schrieb on 21.08.09 um 15:08:36:
Sunny schrieb on 20.08.09 um 13:26:31:
Wenn das Selfupdate nicht funktioniert, fehlt zu 99% in der Standardwebsite (Port 80) ein virtuelles Directory Selfupdate ins Filesystem. Hier gibts Infos und KB-Artikel dazu: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). + (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). S...


Die Fehlermeldung SelfUpdate konnte ich jetzt weg kriegen mit der Umstellung des Ports in der Registry unter "Update Services", wobei so wie ich das gelsen habe tut der SBS 2008 standard mässig mit dem POrt 8530 arbeiten (welche auch dort zuvor eingetragen war)


OK, Du hast das Selfupdate-Directory also auf Port 80 installiert/eingerichtet. Das ist OK so.

Evil Master schrieb on 21.08.09 um 15:08:36:
Sunny schrieb on 20.08.09 um 13:26:31:
Probier auf der Comandline ein: lodctr /r und probier anschließend nochmals den WSUS zu deinstallieren.


Hat leider nichts gebracht


Hmm, das sieht nicht wirklich gut aus.

Evil Master schrieb on 21.08.09 um 15:08:36:
Sunny schrieb on 20.08.09 um 13:26:31:
Dann füg den Netzwerkdienst wieder hinzu, der wird schon noch benötigt.


Das funktioniert leider nicht mehr Griesgrämig

Folgende Fehlermeldung erscheint, wenn ich versuche den SQL-Server auf Netzwerkdienst umzustellen:
Fehler bei WMI-Anbieter: Ein neues Mitglied konnte nicht zu einer lokalen Gruppe hinzugefügt werden, da das Mitglied den falschen Kontentyp aufweist. [0x8007056c]


Hmm, was sagt die MS-KB dazu?

Evil Master schrieb on 21.08.09 um 15:08:36:
Die SUSDB ist fast 2.2 GB Groß


Das ist auch nicht weiter schlimm. Du könntest mal ein paar alte Updates ablehnen und den Bereinigungsassi regelmässig laufen lassen. Dann wird die DB auch wieder etwas kleiner. Und der Content schrumpft auch ein bisschen.

Sunny schrieb on 20.08.09 um 13:26:31:
Kontrollier doch erstmal, ob Du wirklich alles an Rollen vorher hinzugefügt hast: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Hier bist Du noch eine Antwort schuldig geblieben.

Evil Master schrieb on 21.08.09 um 15:08:36:
Sunny schrieb on 20.08.09 um 13:26:31:
Zum Thema anmelden an der WSUS-DB leg ich dir dieses HowTo ans Herz: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Habe ich ausprobiert und konnte den script erfolgreich ausführen (wobei das ziemlich lange gedauert hat :/)


Beim ersten Mal dauert es immer etwas länger. Zwinkernd

Evil Master schrieb on 21.08.09 um 15:08:36:
Was würde eigendlich passieren wenn ich den IIS als Rolle deinstalliere und dann neu istalliere? Weil ich weiss nicht igendwie ist alles komisch...


Das könnte böse enden. Beim SBS ist ja ein Exchange Server dabei, möglicherweise funktioniert der nachher nicht mehr. Du solltest nachdenken, dir entweder externe Hilfe ins Haus zu holen, oder einen weiteren DC zu installieren und den SBS komplett neu zu installieren.
  
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden