Seitenindex umschalten Seiten: [1] 2  Thema versendenDrucken
Heißes Thema (mehr als 10 Antworten) WSUS 3.0 SP1 funktioniert nicht mehr (Gelesen: 3827 mal)
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
WSUS 3.0 SP1 funktioniert nicht mehr
07.09.09 um 11:17:51
Beitrag drucken  
Hallo zusammen,

habe folgendes Problem: Auf einem unserer w2k3 r2 (SP1) läuft wsus 3.0 sp1. Letzte Woche stellte ich fest, nachdem ich im wsus eine Datenbankbereinigung machen wollte, dass sich die wsus über die mmc nicht mehr starten liess (serverknoten zurücksetzen....)
Ich habe dann die entsprechenden Dienste neudurchgestartet - kein Ergebnis und den Server neugestartet - auch kein Ergebnis.
In den Ereignislogs finde ich nun folgende Warnungen/Fehlermeldungen:

Fehlerüberwachung:
EventID: 18456
Login failed for user 'NT-AUTORITÄT\NETZWERKDIENST'. [CLIENT: <named pipe>]


Warnung:
EventID: 7032
Die WSUS-Verwaltungskonsole konnte über die Remote-API keine Verbindung mit dem WSUS-Server herstellen.

Stellen Sie sicher, dass der Update Services-Dienst, IIS und SQL auf dem Server ausgeführt werden. Starten Sie IIS, SQL und den Update Services-Dienst erneut, wenn das Problem weiterhin besteht.

An der WSUS-Verwaltungskonsole ist ein unerwarteter Fehler aufgetreten. Möglicherweise ist es ein vorübergehender Fehler. Versuchen Sie, die Verwaltungskonsole erneut zu starten. Wenn der Fehler weiterhin besteht,

entfernen Sie die gespeicherten Einstellungen für die Konsole, indem Sie die WSUS-Datei unter "%appdata%\Microsoft\MMC\" löschen.


System.IO.IOException -- Fehler bei Handshake wegen eines unerwarteten Paketformats.

Source
System

Stack Trace:
   bei System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
   bei System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
   bei System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
   bei System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
   bei System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
   bei System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
   bei System.Net.TlsStream.CallProcessAuthentication(Object state)
   bei System.Threading.ExecutionContext.runTryCode(Object userData)
   bei System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(
TryCode code, CleanupCode backoutCode, Object userData)
   bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   bei System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
   bei System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
   bei System.Net.PooledStream.Write(Byte[] buffer, Int32 offset, Int32 size)
   bei System.Net.ConnectStream.WriteHeaders(Boolean async)
** this exception was nested inside of the following exception **


System.Net.WebException -- Die zugrunde liegende Verbindung wurde geschlossen: Unerwarteter Fehler beim Senden..

Source
Microsoft.UpdateServices.Administration

Stack Trace:
   bei Microsoft.UpdateServices.Administration.AdminProxy.CreateUpdateServer(Object[] args)
   bei Microsoft.UpdateServices.Administration.AdminProxy.GetUpdateServer(String serverName, Boolean useSecureConnection, Int32 portNumber)
   bei Microsoft.UpdateServices.UI.AdminApiAccess.AdminApiTools.GetUpdateServer(String serverName, Boolean useSecureConnection, Int32 portNumber)
   bei Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.GetUpdateServer(
PersistedServerSettings settings)
   bei Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.ConnectToServer(
)
   bei Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.get_ServerTools(
)

Fehler:
EventID: 3414
An error occurred during recovery, preventing the database 'SUSDB' (database ID 5) from restarting. Diagnose the recovery errors and fix them, or restore from a known good backup. If errors are not corrected or expected, contact Technical Support.

Fehler:
EventID: 9004
An error occurred while processing the log for database 'SUSDB'.  If possible, restore from backup. If a backup is not available, it might be necessary to rebuild the log.

Wer kann mir helfen?
Mein nächster Schritt wäre evtl. zu versuchen wsus 3.0 sp2 zu installieren?!

Vielen Dank im Voraus  Smiley Zunge
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13536
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #1 - 07.09.09 um 11:41:38
Beitrag drucken  
houzer schrieb on 07.09.09 um 11:17:51:
In den Ereignislogs finde ich nun folgende Warnungen/Fehlermeldungen:

Fehlerüberwachung:
EventID: 18456
Login failed for user 'NT-AUTORITÄTNETZWERKDIENST'. [CLIENT: <named pipe>]


Du mußt kontrollieren, ob der NETZWERKDIENST genügend Rechte hat. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

houzer schrieb on 07.09.09 um 11:17:51:
An der WSUS-Verwaltungskonsole ist ein unerwarteter Fehler aufgetreten. Möglicherweise ist es ein vorübergehender Fehler. Versuchen Sie, die Verwaltungskonsole erneut zu starten. Wenn der Fehler weiterhin besteht,

entfernen Sie die gespeicherten Einstellungen für die Konsole, indem Sie die WSUS-Datei unter "%appdata%MicrosoftMMC" löschen.


Hast Du das ausprobiert? Kannst Du dich von einem anderen Client aus beim WSUS anmelden?

houzer schrieb on 07.09.09 um 11:17:51:
Wer kann mir helfen?


Nur Du dir selbst. Zwinkernd

houzer schrieb on 07.09.09 um 11:17:51:
Mein nächster Schritt wäre evtl. zu versuchen wsus 3.0 sp2 zu installieren?!


Diese Aussage solltest Du dir nochmal überlegen. Was könnte wohl rauskommen, wenn Du ein Update machen möchtest und Du jetzt schon keinen Zugriff hast?
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #2 - 07.09.09 um 12:17:17
Beitrag drucken  
Hi Sunny,

erstmal danke  Durchgedreht

Quote:
Du mußt kontrollieren, ob der NETZWERKDIENST genügend Rechte hat. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen)..

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen)..

Also die Rechte im IIS habe ich bereits gecheckt, die sind ok lt. dem Link. Die Eigenschaften der WebServices mit adsutil sind das allgemeine Einstellungen (d.h. die gelten für jeden)? Muss ich die alle checken?

Quote:
Hast Du das ausprobiert? Kannst Du dich von einem anderen Client aus beim WSUS anmelden?

Falls Du damit meinst, die "wuident.cab" über den IE per Client abzurufen, habe ich schon probiert und funktioniert nicht mehr. Die WSUS-Datei habe ich gar nicht.

Quote:
Diese Aussage solltest Du dir nochmal überlegen. Was könnte wohl rauskommen, wenn Du ein Update machen möchtest und Du jetzt schon keinen Zugriff hast?

Ok habe ich mir nochmal überlegt  Smiley Aber es hat sich an den Rechten für "Netzwerk" nichts geändert.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13536
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #3 - 07.09.09 um 12:32:49
Beitrag drucken  
houzer schrieb on 07.09.09 um 12:17:17:
Quote:
Du mußt kontrollieren, ob der NETZWERKDIENST genügend Rechte hat. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen)..

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen)..

Also die Rechte im IIS habe ich bereits gecheckt, die sind ok lt. dem Link. Die Eigenschaften der WebServices mit adsutil sind das allgemeine Einstellungen (d.h. die gelten für jeden)? Muss ich die alle checken?


Die Fehlermeldung in deinem ersten Posting ist ja recht eindeutig. Es fehlen Zugriffsrechte. Also mußt kontrollieren, wo genau dem NETZWERKDIENST die Berechtigungen fehlen. Vermutlich direkt auf der SUSDB.*. Kontrollier das.

Auch kannst Du dich auf der SUSDB wie in diesem Artikel genannt anmelden und die Berechtigungen für den NETZWERKDIENST kontrollieren. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


houzer schrieb on 07.09.09 um 12:17:17:
Quote:
Hast Du das ausprobiert? Kannst Du dich von einem anderen Client aus beim WSUS anmelden?

Falls Du damit meinst, die "wuident.cab" über den IE per Client abzurufen, habe ich schon probiert und funktioniert nicht mehr. Die WSUS-Datei habe ich gar nicht.


Nein, meinte ich nicht. Ich  meinte auf einem Client die WSUS-Konsole installieren und von dort aus verbinden.

Diesen Link aufrufen und downloaden klappt nicht? (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

houzer schrieb on 07.09.09 um 12:17:17:
Quote:
Diese Aussage solltest Du dir nochmal überlegen. Was könnte wohl rauskommen, wenn Du ein Update machen möchtest und Du jetzt schon keinen Zugriff hast?

Ok habe ich mir nochmal überlegt  Smiley


Und was ist dabei raus gekommen?

houzer schrieb on 07.09.09 um 12:17:17:
Aber es hat sich an den Rechten für "Netzwerk" nichts geändert.


Weshalb wohl? Tankt sich dein Auto auch von alleine voll? Smiley
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #4 - 07.09.09 um 13:00:53
Beitrag drucken  
Quote:
Auch kannst Du dich auf der SUSDB wie in diesem Artikel genannt anmelden und die Berechtigungen für den NETZWERKDIENST kontrollieren. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Muss ich den Server neustarten, wenn ich den SQL Server Management.... installiere?

Quote:
Nein, meinte ich nicht. Ich  meinte auf einem Client die WSUS-Konsole installieren und von dort aus verbinden.

Hab ich nocht nicht probiert, werde ich gleich probieren.

Quote:
Diesen Link aufrufen und downloaden klappt nicht? (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Nein funktioniert nicht mehr. Rückmeldung im IE: Seite nicht gefunden

Quote:
Und was ist dabei raus gekommen?

Na ich warte erstmal ob ich es so hinbekomme  Zwinkernd

Quote:
Weshalb wohl? Tankt sich dein Auto auch von alleine voll?

Damit meinte ich das es komisch ist, das der Netzwerkdienst plötzlich fehlende Rechte hat, weil hier nichts geändert wurde.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13536
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #5 - 07.09.09 um 13:33:05
Beitrag drucken  
houzer schrieb on 07.09.09 um 13:00:53:
Quote:
Auch kannst Du dich auf der SUSDB wie in diesem Artikel genannt anmelden und die Berechtigungen für den NETZWERKDIENST kontrollieren. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Muss ich den Server neustarten, wenn ich den SQL Server Management.... installiere?


Nein.

houzer schrieb on 07.09.09 um 13:00:53:
Quote:
Nein, meinte ich nicht. Ich  meinte auf einem Client die WSUS-Konsole installieren und von dort aus verbinden.

Hab ich nocht nicht probiert, werde ich gleich probieren.


Dann mal los. Zwinkernd

houzer schrieb on 07.09.09 um 13:00:53:
Quote:
Diesen Link aufrufen und downloaden klappt nicht? (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Nein funktioniert nicht mehr. Rückmeldung im IE: Seite nicht gefunden


Der WSUS ist auf Port 80 installiert? Kontrollier im IIS doch mal ob alles läuft. Du kannst auch ein IISRESET auf dem WSUS laufen lassen. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

houzer schrieb on 07.09.09 um 13:00:53:
Damit meinte ich das es komisch ist, das der Netzwerkdienst plötzlich fehlende Rechte hat, weil hier nichts geändert wurde.


Das kann viele Ursachen haben. Nicht gestartete Dienste, kauptte HDDs, defektes Filesystem oder Manipulationen durch Fremde/Freund oder auch AV-Scanner. Zwinkernd
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #6 - 07.09.09 um 13:33:26
Beitrag drucken  
Quote:
Hab ich nocht nicht probiert, werde ich gleich probieren.

Hab ich probiert - geht nicht. Im Anhang die Meldung....

Der Dienst "Windows Internal Database läuft aber....
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). DB.GIF (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13536
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #7 - 07.09.09 um 13:43:03
Beitrag drucken  
houzer schrieb on 07.09.09 um 13:33:26:
Quote:
Hab ich nocht nicht probiert, werde ich gleich probieren.

Hab ich probiert - geht nicht. Im Anhang die Meldung....

Der Dienst "Windows Internal Database läuft aber....


Was soll ich sagen? Du sitzt vor dem Server, Du mußt das Eventlog nach Fehlern durchsuchen. Du mußt IISRESET ausführen.

Hast Du das SQL-Tool auch auf dem WSUS direkt installiert und aufgerufen? Remote funktioniert das nicht.
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #8 - 07.09.09 um 13:43:28
Beitrag drucken  
Sunny schrieb on 07.09.09 um 13:33:05:
Zitat:
Auch kannst Du dich auf der SUSDB wie in diesem Artikel genannt anmelden und die Berechtigungen für den NETZWERKDIENST kontrollieren. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Ich kann mit dem SQL Server Manager schon gar keine Verbindung zur DB aufbauen. Siehe Anhang  Schockiert/Erstaunt weinend

  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). DB1.GIF (Anhang gelöscht)
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #9 - 07.09.09 um 13:45:39
Beitrag drucken  
Sunny schrieb on 07.09.09 um 13:43:03:
Was soll ich sagen? Du sitzt vor dem Server, Du mußt das Eventlog nach Fehlern durchsuchen. Du mußt IISRESET ausführen.

Hast Du das SQL-Tool auch auf dem WSUS direkt installiert und aufgerufen? Remote funktioniert das nicht.


Am besten das was mir hilft  Durchgedreht
Ja das SQL Tool ist auf dem Server installiert. Einen iisreset habe ich auch schon letzte Woche durchgeführt.  unentschlossen
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #10 - 07.09.09 um 13:52:58
Beitrag drucken  
Sunny schrieb on 07.09.09 um 13:33:05:
Der WSUS ist auf Port 80 installiert? Kontrollier im IIS doch mal ob alles läuft. Du kannst auch ein IISRESET auf dem WSUS laufen lassen. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).


Nein der WSUS läuft bei uns unter Port: 8530. Habe gerade nochmal ein iisreset gemacht, ohne Erfolg.
Kann die DB nen Macken haben?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13536
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #11 - 07.09.09 um 13:53:18
Beitrag drucken  
houzer schrieb on 07.09.09 um 13:45:39:
Sunny schrieb on 07.09.09 um 13:43:03:
Was soll ich sagen? Du sitzt vor dem Server, Du mußt das Eventlog nach Fehlern durchsuchen. Du mußt IISRESET ausführen.

Hast Du das SQL-Tool auch auf dem WSUS direkt installiert und aufgerufen? Remote funktioniert das nicht.


Am besten das was mir hilft  Durchgedreht


Mal ehrlich, was erwartest Du mit so wenig Informationen? Am besten Du installierst den WSUS temporär auf einem anderen Server, synchronsisierst und machst auf dem Problem-WSUS alles neu.

houzer schrieb on 07.09.09 um 13:45:39:
Ja das SQL Tool ist auf dem Server installiert.


Hmm, schade. Hier gibts noch zwei Tipps: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #12 - 07.09.09 um 14:06:36
Beitrag drucken  
Sunny schrieb on 07.09.09 um 13:53:18:
Mal ehrlich, was erwartest Du mit so wenig Informationen? Am besten Du installierst den WSUS temporär auf einem anderen Server, synchronsisierst und machst auf dem Problem-WSUS alles neu.

Was für Informationen kann ich sonst noch liefern? Um auf dem WSUS-Server alles neuzumachen, deinstalliere ich komplett alles (wsus 3.0 sp1, internal database, content usw.)?
  
Zum Seitenanfang
 
UMeadow
WSUS Spezialist
*****
Offline


I Love WSUS!

Beiträge: 1347
Standort: Berlin
Mitglied seit: 22.01.08
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #13 - 07.09.09 um 14:45:37
Beitrag drucken  
Hi Houzer,
ist Dein SQL-Server für Remoteverbindungen konfiguriert? Sonst siehe hier (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
Ich bin mir nicht sicher wie das bei der Windows Internal Database ist, aber eigentlich müsste auch eine Instanz Microsofft##SSEE bei den Diensten gestartet sein.
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: WSUS 3.0 SP1 funktioniert nicht mehr
Antwort #14 - 07.09.09 um 15:04:39
Beitrag drucken  
UMeadow schrieb on 07.09.09 um 14:45:37:
ist Dein SQL-Server für Remoteverbindungen konfiguriert? Sonst siehe hier (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen)..
Ich bin mir nicht sicher wie das bei der Windows Internal Database ist, aber eigentlich müsste auch eine Instanz Microsofft##SSEE bei den Diensten gestartet sein. 


Hi, ich habe ja keinen SQL-Server installiert sondern nutze die MS internal DB, hier kann ich keine Oberflächenkonfiguration vornehmen. Der SQL Server Management Studio Express bietet diese Möglichkeit mir nicht.
Ausserdem greife ich doch eigentlich nicht Remote zu, da ja beides auf dem gleichen Server installiert ist, oder??
  
Zum Seitenanfang
 
Seitenindex umschalten Seiten: [1] 2 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden