Normales Thema Clients melden sich teilweiße nur unregelmäßig/garnicht (Gelesen: 1059 mal)
s.Merk
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 30
Mitglied seit: 04.02.09
Clients melden sich teilweiße nur unregelmäßig/garnicht
18.02.09 um 11:09:25
Beitrag drucken  
Hallo zusammen,

Ich habe folgendes Problem.
Wir wollen im Netzwerk an die Mitarbeiter-PCs und and unsere Windows Server Updates mithilfe des WSUS verteilen. Den WSUS haben wir durch eine GPO bekanntgemacht (GPO von Sunny, mit kleinen Modifikationen).
Die meisten Server und wenige PCs melden sich nun in regelmäßigen Abständen.
Allerdings melden sich die meisten PCs nur in sehr unregelmäßigen Abständen, bzw. gar nicht mehr.
Wird auf diesen PCs in der Konsole der Befehl "wuauclt.exe /detectnow" eingegeben, melden sie sich einmalig beim WSUS ohne die Gesamtsituation zu verändern.
Verschiedene Einstellungen in der GPO bei der Suchhäufigkeit ändern dieses Verhalten nicht.
Woran könnte dieses Verhalten liegen? Alle PCs benutzen die selbe GPO aber Verhalten sich völlig unterschiedlich.
Wenn weitere Infos von Nöten sind (Auszüge aus den Regfiles etc. einfach bescheid geben)

Danke schon mal im Voraus
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13520
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients melden sich teilweiße nur unregelmäßig/garnicht
Antwort #1 - 18.02.09 um 11:18:25
Beitrag drucken  
s.Merk schrieb on 18.02.09 um 11:09:25:
Wir wollen im Netzwerk an die Mitarbeiter-PCs und and unsere Windows Server Updates mithilfe des WSUS verteilen. Den WSUS haben wir durch eine GPO bekanntgemacht (GPO von Sunny, mit kleinen Modifikationen).


An welcher Stelle wurden welche Modifikationen vorgenommen?

s.Merk schrieb on 18.02.09 um 11:09:25:
Die meisten Server und wenige PCs melden sich nun in regelmäßigen Abständen.
Allerdings melden sich die meisten PCs nur in sehr unregelmäßigen Abständen, bzw. gar nicht mehr.


Sind denn alle Clients und Server schon in der WSUS-Konsole zu sehen? Simmt die angezeigte Gesamtanzahl mit der eurer Geräte insgesamt?

s.Merk schrieb on 18.02.09 um 11:09:25:
Wird auf diesen PCs in der Konsole der Befehl "wuauclt.exe /detectnow" eingegeben, melden sie sich einmalig beim WSUS ohne die Gesamtsituation zu verändern.
Verschiedene Einstellungen in der GPO bei der Suchhäufigkeit ändern dieses Verhalten nicht.
Woran könnte dieses Verhalten liegen? Alle PCs benutzen die selbe GPO aber Verhalten sich völlig unterschiedlich.


Habt ihr denn eine vernünftige OU-Struktur? Oder habt ihr die GPO auf Domain-Ebene erstellt und verlinkt? Haben die Server eine eigene GPO?

Schuß ins Blaue, die Clients/Server sind geklont. (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Auch wenn Du es nicht glaubst, probier es aus. Das tut nicht weh und es geht auch nichts dabei kaputt.
  
Zum Seitenanfang
 
s.Merk
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 30
Mitglied seit: 04.02.09
Re: Clients melden sich teilweiße nur unregelmäßig/garnicht
Antwort #2 - 18.02.09 um 12:12:09
Beitrag drucken  
modifikationen siehe anhang

Die Anzahl stimmt soweit ich es Überprüfen kann überein. Im WSUS ist mir auch die Unterschiedliche Meldezeit aufgefallen.

Wir verwenden momentan noch eine hingewerkelte OU-Struktur. Die GPo wurde auf domain-Ebene erstellt und verlinkt. Die Server haben keine Eigene Struktur.
Könnte eine Ordentliche OU-Struktur den Fehler beheben? (geplant ist das Ordnen schon)
Wen du mit Clone meinst, dass ein Fertiges Windows auf die Verschiedenen rechner kopiert wurde, sind unsere Rechner nicht geclont. Jeder Rechner durchläuft das Komplette Windows Setup.
Ich habe dennoch die Clone lösung auf einem Client ausprobiert. Bisher ohne erfolg
Nach der Mittagspause werde ich das bei weiteren Rechnern noch ausprobieren.
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). wsusgpo.JPG (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13520
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients melden sich teilweiße nur unregelmäßig/garnicht
Antwort #3 - 18.02.09 um 12:37:42
Beitrag drucken  
Auweia, da ist ja Chaos vorprogrammiert. Eine vernünftige kleine OU-Struktur solltest Du so schnell als möglich erstellen. So wie der Zustand jetzt ist, spazierst Du auf äußerst dünnem Eis, und denk dran, der Frühling kommt. Smiley Ist das eine SBS-Domain?

Hier ein kleines Beispiel: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
In der Default Domain und Default Domain Controller Policy wird nichts verändert, außer SMB-Signing gem. BestPraxis eingestellt und Passwortrichtlinien vergeben, sonst nichts!
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Erstell dir für die Server und für die Clients je eine eigene WSUS-GPO, die Client-GPO stellst Du auf die Option 4 um. Die Option 3 ist für normale User denkbar schlecht. Achte drauf, das die Benutzereinstellung auch auf die Benutzerobjekte verlinkt ist. Je nach Größe des Unternehmens kannst Du die OU-Struktur ja aus dem Beispiel übernehmen.

Was sind das für zusätzliche Reg-Einstellungen in der GPO? Was sollen die bewirken?

Bei den Diensten hast Du den WUAUSERV nicht mit drin. Das ist der Dienst Automatische Updates. Ohne den läuft auch nichts.

Erstell dir eine TestOU, dort packst Du einen Testclient mit einem Benutzer zum testen rein. Auf die OU verlinkst Du nun meine GPO komplett, Servernamen natürlich anpassen. Auch sollten immer diese beiden Einstellungen aus der GPO-FAQ No. 36 auf alle Clients und Server wirken: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). Zum testen kannst Du auch die Suchhäufigkeit auf 1 Stunde runter drehen. Am besten zweimal booten und anschließend in das Eventlog sehen. Sind Fehler drin? Wie siehts mit dem WSUS aus? Fehlermeldungen in der %windir%\WindowsUpdate.log?
  
Zum Seitenanfang
 
s.Merk
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 30
Mitglied seit: 04.02.09
Re: Clients melden sich teilweiße nur unregelmäßig/garnicht
Antwort #4 - 19.02.09 um 13:21:42
Beitrag drucken  
so da bin ich mal wieder


Sunny schrieb on 18.02.09 um 12:37:42:
Ist das eine SBS-Domain? [/qutoe]
Nein das ist keine SBS-Domain, die Domain läuft auf einem windows server 03 r2

[quote author=654358584F360 link=1234951765/3#3 date=1234957062] Was sind das für zusätzliche Reg-Einstellungen in der GPO? Was sollen die bewirken?

welche zusätzlichen Reg-Einstellungen meinst du? Wen du dich auf meinen ersten Post beziehst, damit meine ich die Regeinträge die von der GPO verändert werden.

Sunny schrieb on 18.02.09 um 12:37:42:
Bei den Diensten hast Du den WUAUSERV nicht mit drin. Das ist der Dienst Automatische Updates. Ohne den läuft auch nichts.


Das war ein Unterschied zwischen den Rechnern die Funktioniert haben und den anderen. Mittlerweile wird der Dienst über die GPO aktiviert. Nach neustart auf Testrechner der vorher Probleme hatte funktioniert alles Wunderbar... Jetzt bin ich mal gespannt ob sich bis morgen mittag noch einige Mitarbeiter rechner gemeldet haben.

Wen das nicht der Fall ist, arbeite ich mal die "Liste" die du mir aufgestellt hast weiter ab.

Bis hierher schonmal DANKE für die Tipps
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13520
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Clients melden sich teilweiße nur unregelmäßig/garnicht
Antwort #5 - 19.02.09 um 16:03:33
Beitrag drucken  
s.Merk schrieb on 19.02.09 um 13:21:42:
Sunny schrieb on 18.02.09 um 12:37:42:
Was sind das für zusätzliche Reg-Einstellungen in der GPO? Was sollen die bewirken?

welche zusätzlichen Reg-Einstellungen meinst du? Wen du dich auf meinen ersten Post beziehst, damit meine ich die Regeinträge die von der GPO verändert werden.


Ich meine die Reg-Einstellungen, die zusätzlich in dem Bild zu sehen sind, das Du gepostet hast.

s.Merk schrieb on 19.02.09 um 13:21:42:
Sunny schrieb on 18.02.09 um 12:37:42:
Bei den Diensten hast Du den WUAUSERV nicht mit drin. Das ist der Dienst Automatische Updates. Ohne den läuft auch nichts.


Das war ein Unterschied zwischen den Rechnern die Funktioniert haben und den anderen. Mittlerweile wird der Dienst über die GPO aktiviert. Nach neustart auf Testrechner der vorher Probleme hatte funktioniert alles Wunderbar... Jetzt bin ich mal gespannt ob sich bis morgen mittag noch einige Mitarbeiter rechner gemeldet haben.


Beachte nur eins bei den Diensten. Wird ein Dienst per GPO auf Automatisch gesetzt, übernimmt der Client beim ersten booten den Wert Automatisch. Damit ist der Dienst aber noch nicht gestartet, erst beim nächsten booten wird der Dienst auch tatsächlich gestartet. Ab VISTA soll das in einem Rutsch gehen.

s.Merk schrieb on 19.02.09 um 13:21:42:
Wen das nicht der Fall ist, arbeite ich mal die "Liste" die du mir aufgestellt hast weiter ab.


Meinst Du mit der Liste, die eigenen OUs? Wenn ja, das ist wirklich wichtig. Ansonsten findest Du dich ganz schnell in einer Sackgasse wieder.

s.Merk schrieb on 19.02.09 um 13:21:42:
Bis hierher schonmal DANKE für die Tipps


Bitte, gern geschehen. Zwinkernd
  
Zum Seitenanfang
 
s.Merk
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 30
Mitglied seit: 04.02.09
Re: Clients melden sich teilweiße nur unregelmäßig/garnicht
Antwort #6 - 20.02.09 um 09:08:43
Beitrag drucken  
Sunny schrieb on 19.02.09 um 16:03:33:
s.Merk schrieb am Gestern um 13:21:42:
Sunny schrieb am 18.02.2009 um 12:37:42:
Was sind das für zusätzliche Reg-Einstellungen in der GPO? Was sollen die bewirken?

welche zusätzlichen Reg-Einstellungen meinst du? Wen du dich auf meinen ersten Post beziehst, damit meine ich die Regeinträge die von der GPO verändert werden.


Ich meine die Reg-Einstellungen, die zusätzlich in dem Bild zu sehen sind, das Du gepostet hast.


Das ist ein Überbleibsel aus dem Regfile (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
ist inzwischen entferntSunny schrieb on 19.02.09 um 16:03:33:
Beachte nur eins bei den Diensten. Wird ein Dienst per GPO auf Automatisch gesetzt, übernimmt der Client beim ersten booten den Wert Automatisch. Damit ist der Dienst aber noch nicht gestartet, erst beim nächsten booten wird der Dienst auch tatsächlich gestartet. Ab VISTA soll das in einem Rutsch gehen.


Das habe ich bedacht, allerdings viel mir auf das alle XP-Clients die ich angeschaut hatte, bereits bei übernahme der GPO den Status auf Automatisch gesetzt haben. Nicht erst bei einem Neustart.
Gestartet wurde der Dienst allerdings, wie du sagtest, erst nach einem Neustart.

Langsam melden sich nun immer mehr PCs beim WSUS. Ich hoffe das bis heute Mittag alle PCs und Notebooks die heute im Haus sind sich gemeldet haben.

Bisher bekommen alle PCs die sich gemeldet haben das "testupdate" zur Verfügung gestellt.
Nur ein Server macht Probleme und spuckt ein Merkwürdiges Log-File aus....

Nochmal danke für die Hilfe bei diesem Problem (das ja allem anschein nach nun erledigt ist)
  
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden