Seitenindex umschalten Seiten: [1] 2  Thema versendenDrucken
Heißes Thema (mehr als 10 Antworten) Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr (Gelesen: 2725 mal)
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
16.01.09 um 11:41:29
Beitrag drucken  
Hi,

ich habe folgendes Problem. Wir haben letztes Jahr im Dezember unseren WSUS auf 3.0 (SP1) upgedatet. Nun bekommen alle XP Clients, die ich frisch aufsetze keine Updates mehr. Alle anderen Clients funktionieren einwandfrei. Das virtuelle Verzeichnis im IIS ist auch gesetzt.

Hier mal ein Auszug aus dem  Windows-Update.log eines dieser Clients:

2009-01-16      07:56:56+0100      1064      73c      Service Main starts
2009-01-16      07:56:58+0100      1064      73c      Using BatchFlushAge = 20532.
2009-01-16      07:56:58+0100      1064      73c      Using SamplingValue = 712.
2009-01-16      07:56:58+0100      1064      73c      Successfully loaded event namespace dictionary.
2009-01-16      07:57:00+0100      1064      73c      Successfully loaded client event namespace descriptor.
2009-01-16      07:57:00+0100      1064      73c      Successfully initialized local event logger. Events will be logged at C:\WINDOWS\SoftwareDistribution\ReportingEvents.log.
2009-01-16      07:57:00+0100      1064      73c      Successfully initialized NT event logger.
2009-01-16      07:57:00+0100      1064      73c      Successfully initialized event uploader 0.
2009-01-16      07:57:00+0100      1064      73c      Successfully initialized event uploader 1.
2009-01-16      07:57:00+0100      1064      73c      WU client with version 5.4.3790.2180 successfully initialized
2009-01-16      07:57:00+0100      1064      73c      Service status is now SERVICE_RUNNING
2009-01-16      07:57:00+0100      1064      7e8      Successfully opened event cache file at C:\WINDOWS\SoftwareDistribution\EventCache\{DCB7F30D-BF19-42C9-A523-3B928DF52408
}.bin for reading.
2009-01-16      07:57:01+0100       220       e0      Trying to make out of proc datastore active
2009-01-16      07:57:03+0100       220       e0      Out of proc datastore is now active
2009-01-16      07:57:03+0100      1064      7e8      PT: Using serverID {9482F4B4-E343-43B6-B170-9A65BC822C77}
2009-01-16      07:57:03+0100      1064      7e8      Checking for different Redirector at: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2009-01-16      07:57:05+0100      1064      7e8      DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). error 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to download the Redirector cab on try 1: 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Checking for different Redirector at: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2009-01-16      07:57:05+0100      1064      7e8      DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). error 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to download the Redirector cab on try 2: 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Checking for different Redirector at: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2009-01-16      07:57:05+0100      1064      7e8      DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). error 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to download the Redirector cab on try 3: 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to obtain cached cookie with hr = 80244021.
2009-01-16      07:57:05+0100      1064      7e8      PT: Using serverID {9482F4B4-E343-43B6-B170-9A65BC822C77}
2009-01-16      07:57:05+0100      1064      7e8      Checking for different Redirector at: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2009-01-16      07:57:05+0100      1064      7e8      DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). error 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to download the Redirector cab on try 1: 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Checking for different Redirector at: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2009-01-16      07:57:05+0100      1064      7e8      DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). error 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to download the Redirector cab on try 2: 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Checking for different Redirector at: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
2009-01-16      07:57:05+0100      1064      7e8      DownloadFileInternal failed for (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). error 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to download the Redirector cab on try 3: 0x801901f6
2009-01-16      07:57:05+0100      1064      7e8      Failed to obtain cached url with hr = 80244021.
2009-01-16      07:57:05+0100      1064      7e8      Failed to upload events with hr = 80244021.
2009-01-16      07:57:45+0100      1064      73c      start delayed initialization of WU client
2009-01-16      07:57:45+0100      1064      73c      Client Call Recorder finished delayed initialization
2009-01-16      07:57:45+0100      1064      73c      Setting next AU detection timeout to 2009-01-16 06:57:45
2009-01-16      07:57:45+0100      1064      73c      Launching Legacy AU client
2009-01-16      07:59:14+0100      1064      42c      Service received logon notification
2009-01-16      07:59:14+0100      1064      42c      Forwarding control handler info to legacy AU
2009-01-16      08:02:46+0100       220       e0      Out of proc datastore is shutting down
2009-01-16      08:02:47+0100       220       e0      Out of proc datastore is now inactive




Es sieht so aus als ob diese Clients nun versuchen, die Updates über die MS Windows-Update Seite zu beziehen?

Hier auch noch der Auszug aus dem WSUS Client Diag-Tool:

Checking Machine State
       Checking for admin rights to run tool . . . . . . . . . PASS
       Automatic Updates Service is running. . . . . . . . . . PASS
       Background Intelligent Transfer Service is running. . . PASS
       Wuaueng.dll version 5.4.3790.2180 . . . . . . . . . . . PASS
               This version is SUS 1.0

Checking AU Settings
       AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
               Option is from Policy settings

Checking Proxy Configuration
       Checking for winhttp local machine Proxy settings . . . PASS
               Winhttp local machine access type
                       <Direct Connection>
               Winhttp local machine Proxy. . . . . . . . . .  NONE
               Winhttp local machine ProxyBypass. . . . . . .  NONE
       Checking User IE Proxy settings . . . . . . . . . . . . PASS
               User IE Proxy
               server:8080
               User IE ProxyByPass
               <local>
               User IE AutoConfig URL Proxy . . . . . . . . .  NONE
               User IE AutoDetect
               AutoDetect not in use

Checking Connection to WSUS/SUS Server
               WUServer = http://server:8530
               WUStatusServer = http://server:8530
       UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
       Connection to server. . . . . . . . . . . . . . . . . . PASS

WinHttpDownloadFileToMemory(szURLDest, NULL, 0, NULL, NULL, NULL, &downloadBuffe
r) failed with hr=0x80190194

No Error description could be found



Die Clients werden über eine GPO dem WSUS zugeordnet. An dieser wurde nichts verändert. Die Clients tauchen aber nicht im WSUS auf.

Hat jemand mir ein paar Tips?
Vielen Dank.





  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13248
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #1 - 16.01.09 um 11:50:13
Beitrag drucken  
Kommt denn die GPO überhaupt auf den Clients an? RSOP.MSC auf einem solchen Client sollte Klarheit verschaffen. Alternativ in der Registry kontrollieren, ob die Einträge da sind: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate und darunter.
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #2 - 16.01.09 um 12:02:27
Beitrag drucken  
Hi,

ja die GPO kommt am Client an. Die Einträge sind richtig gesetzt, wie bei den anderen Clients.

  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13248
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #3 - 16.01.09 um 12:20:27
Beitrag drucken  
Dann lösch mal die SUSClientID auf den Clients: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #4 - 16.01.09 um 12:24:22
Beitrag drucken  
Ich habe gerade folgenden Patch auf einem der Clients installiert und nun funktioniert es: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).

Muss ich den Windows Update Agent nun immer bei einer Neuinstallation installieren?
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13248
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #5 - 16.01.09 um 12:28:58
Beitrag drucken  
Hmm, komisch, wir machen das hier auch nicht und es klappt. Welche Clients sind das? XPSP3?
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #6 - 16.01.09 um 12:31:06
Beitrag drucken  
Sind alles XP SP2.
Wie gesagt vor dem Update funktionierte dies auch noch ohne diesen Patch.
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13248
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #7 - 16.01.09 um 12:37:30
Beitrag drucken  
Du bist sicher auch die %windir%\Windowsupdate.log kontrolliert zu haben? Es gibt auch eine mit einem Leerzeichen im Namen.

Habt ihr auch die WSUS-Updates zum installieren freigegeben?
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #8 - 16.01.09 um 12:55:05
Beitrag drucken  
Ja in der mit Leerzeichen steht so gut wie gar nichts drin.
Meinst Du die WSUS-Updates die in der WSUS-Konsole angezeigt werden (s. Screenshot)
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13248
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #9 - 16.01.09 um 13:20:55
Beitrag drucken  
houzer schrieb on 16.01.09 um 12:55:05:
Ja in der mit Leerzeichen steht so gut wie gar nichts drin.


Jepp, genau die meinte ich.

houzer schrieb on 16.01.09 um 12:55:05:
Meinst Du die WSUS-Updates die in der WSUS-Konsole angezeigt werden (s. Screenshot)


Jepp, die meinte ich. Wo ist der Screenshot?Zwinkernd
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #10 - 16.01.09 um 14:03:13
Beitrag drucken  
Uuupss...  Zunge
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). WSUS-Updates.jpg (Anhang gelöscht)
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13248
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1
Antwort #11 - 16.01.09 um 14:07:51
Beitrag drucken  
Jepp, die Updates meinte ich. Du müssen für alle Clients/Server zum installieren freigegeben sein.

EDIT: Laufen denn auf den XPSP2 Clients nach der Installation auch die beiden erforderlichen Dienste WUAUSERV + BITS?
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #12 - 16.01.09 um 14:27:36
Beitrag drucken  
Quote:
Jepp, die Updates meinte ich. Du müssen für alle Clients/Server zum installieren freigegeben sein.

Ok check ich mal.

Quote:
EDIT: Laufen denn auf den XPSP2 Clients nach der Installation auch die beiden erforderlichen Dienste WUAUSERV + BITS?

Das hab ich auch gecheckt. WUAUSERV war gestartet - BITS nicht! (sollte der eigentlich nicht automatisch gestartet werden?)
  
Zum Seitenanfang
 
Sunny
Microsoft MVP
*****
Offline



Beiträge: 13248
Mitglied seit: 11.02.07
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #13 - 16.01.09 um 14:38:11
Beitrag drucken  
Quote:
EDIT: Laufen denn auf den XPSP2 Clients nach der Installation auch die beiden erforderlichen Dienste WUAUSERV + BITS?

Das hab ich auch gecheckt. WUAUSERV war gestartet - BITS nicht! (sollte der eigentlich nicht automatisch gestartet werden?) [/quote]

Der BITS sollte mind. auf Manuell stehen, bei einem Download steht der dann auf Automatisch und ist gestartet.

Kannst Du aber auch alles gleich per GPO mitgeben: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen).
  
Zum Seitenanfang
 
houzer
WSUS Junior Member
*
Offline


I Love WSUS!

Beiträge: 40
Mitglied seit: 16.01.09
Geschlecht: männlich
Re: Neuaufgesetzte XP-Clients (SP2) bekommen nach Update auf WSUS 3.0 (SP1) keine Updates mehr
Antwort #14 - 16.01.09 um 15:31:46
Beitrag drucken  
Super vielen Dank für die vielen Infos.

Nice weekend  Durchgedreht
  
Zum Seitenanfang
 
Seitenindex umschalten Seiten: [1] 2 
Thema versendenDrucken
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden