Normales Thema MMC Funktioniert nicht - gelöst - Danke für die Aufmerksamkeit (Gelesen: 480 mal)
Wurstsalat
WSUS Neuling
Offline


I Love WSUS!

Beiträge: 1
Mitglied seit: 23.04.08
MMC Funktioniert nicht - gelöst - Danke für die Aufmerksamkeit
26.05.08 um 11:53:40
Beitrag drucken  
Hallo,

folgendes Problem hab ich seit heute (ohne dass etwas geändert wurde - ausser dass ein paar neue update kamen)

Umgebung ist wie folgt:
Windows 2003 SP2
WSUS 3.0 SP1
IIS 6
.net Framework 2.0 SP1
MMC 3.0
SQL 2005 Express (lokal)

Wenn ich die MMC Konsole aufrufen will kommt jener fehler:

Die WSUS-Verwaltungskonsole konnte über die Remote-API keine Verbindung mit dem WSUS-Server herstellen.

Stellen Sie sicher, dass der Update Services-Dienst, IIS und SQL auf dem Server ausgeführt werden. Starten Sie IIS, SQL und den Update Services-Dienst erneut, wenn das Problem weiterhin besteht.

An der WSUS-Verwaltungskonsole ist ein unerwarteter Fehler aufgetreten. Möglicherweise ist es ein vorübergehender Fehler. Versuchen Sie, die Verwaltungskonsole erneut zu starten. Wenn der Fehler weiterhin besteht,

entfernen Sie die gespeicherten Einstellungen für die Konsole, indem Sie die WSUS-Datei unter "%appdata%\Microsoft\MMC\" löschen.


System.IO.IOException -- Fehler bei Handshake wegen eines unerwarteten Paketformats.

Source
System

Stack Trace:
  bei System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
  bei System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
  bei System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
  bei System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
  bei System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
  bei System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
  bei System.Net.TlsStream.CallProcessAuthentication(Object state)
  bei System.Threading.ExecutionContext.runTryCode(Object userData)
  bei System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(
TryCode code, CleanupCode backoutCode, Object userData)
  bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
  bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
  bei System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
  bei System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
  bei System.Net.PooledStream.Write(Byte[] buffer, Int32 offset, Int32 size)
  bei System.Net.ConnectStream.WriteHeaders(Boolean async)
** this exception was nested inside of the following exception **


System.Net.WebException -- Die zugrunde liegende Verbindung wurde geschlossen: Unerwarteter Fehler beim Senden..

Source
Microsoft.UpdateServices.Administration

Stack Trace:
  bei Microsoft.UpdateServices.Administration.AdminProxy.CreateUpdateServer(Object[] args)
  bei Microsoft.UpdateServices.Administration.AdminProxy.GetUpdateServer(String serverName, Boolean useSecureConnection, Int32 portNumber)
  bei Microsoft.UpdateServices.UI.AdminApiAccess.AdminApiTools.GetUpdateServer(String serverName, Boolean useSecureConnection, Int32 portNumber)
  bei Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.GetUpdateServer(
PersistedServerSettings settings)
  bei Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.ConnectToServer(
)
  bei Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.get_ServerTools(
)


Den gegebenen Tipp hab ich schon probiert, brachte nichts.
WSUS Berechtigungen auf die Webseite etc (u.a. nach dem hier: (Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). ) habe ich geprüft und angepasst (der IUSER war nicht auf die Webseiten berechtigt, das hatte bisher aber keine probleme bereitet)
Standardwebseite liegt auf Port 80 und hört auf alle IP`s (also es gibt kein festes mapping)
Wenn man versucht remote zu verbinden sagt er dass kein wsus server gefunden werden konnte

Deinstallation ging nicht, er sagt "Windows Update blabla wurde aufgrund eines fehlers nicht entfernt"...der softwareeintrag ist jetzt aber weg, startet man das setup erneut kommt der deinstallationsdialog und der gleiche fehler

Das log sagt:

2008-05-26 11:44:46  Success   MWUSSetup          Validating pre-requisites...
2008-05-26 11:45:23  Success   MWUSSetup          Removing Wsus...
2008-05-26 11:45:24  Success   CustomActions.Dll  Successfully set propery of WSUS admin groups' full names
2008-05-26 11:45:24  Error     CustomActions.Dll  SetWyukonInstallDirProperty: Failed to open WYUKON registry key: SOFTWARE\Microsoft\Microsoft SQL Server\MICROSOFT##SSEE\Setup (Error 0x80070002: Das System kann die angegebene Datei nicht finden.)
2008-05-26 11:45:24  Error     CustomActions.Dll  SetUnInstallProperties: Failed to set WYUKON install directory (Error 0x80070002: Das System kann die angegebene Datei nicht finden.)
2008-05-26 11:45:24  Error     MWUSSetup          RemoveWsus: MWUS Uninstall Failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
2008-05-26 11:45:24  Error     MWUSSetup          Wsus MSI uninstallation failed. (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
2008-05-26 11:45:24  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
2008-05-26 11:46:13  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)

Was ich merkwürdig finde, er sucht MICROSOFT##SSEE, sprich die desktop engine...die war da zwar mal drauf aber zu wsus 2.0 zeiten (die wsus 3 installation war eine "updateinstallation"), könnte hier vielleicht der hund begraben liegen?

Im Anhang noch die Log Datei der MSI.

Ich hoffe mir kann einer helfen


edit -> Lösung für mich
Wie es ausschaut geht die Deinstallation nach setzen von WYUKON auf 0 astrein...
Windows Internal Database war korrekt deinstalliert
Installation startet, der balken bleibt aber bei ~90% und bewegt sich nun schon ne weile nichtmehr...naja mal warten

edit 2
das warten hat sich gelohnt...er ist durch und hat fertig Smiley

Scheinbar läuft wieder alles, prima \o/
  
(Du musst Dich Einloggen oder Registrieren um Multimediadateien oder Links zu sehen). WSUSSetupmsi_080526_1145.zip (Anhang gelöscht)
Zum Seitenanfang
 
Bookmarks: Facebook Google Google+ Linked in Twitter Yahoo
 



Nutzungsbedingungen | Datenschutz
Kontakt | RSS | Feedback | Impressum
Facebook | News einsenden